Results 1 to 4 of 4

Thread: Zimbra refusing to start on bootup

  1. #1
    Join Date
    Nov 2005
    Posts
    2
    Rep Power
    9

    Default Zimbra refusing to start on bootup

    OS: CentOS 4.2

    My machine boots up and I see all of the services launching fine. When it gets to Zimbra, it hangs, so all I see is:
    Starting Zimbra:
    (Normally I would expect to see Starting Zimbra: [OK])

    This hang is infinite. But then I notice in /var/log/messages that there is an unusual message...
    "Nov 12 20:20:01 zebrax-cent zimbra: Do you want to choose a different one? [n]"
    So it seems that the Zimbra startup process is blocking waiting for me to hit 'y' or 'n'. And sure enough, hitting 'n' at my primary console (which shows the boot up) unblocks Zimbra. But I have to do this at every bootup.

    If I disable Zimbra from startup and try running /etc/init.d/zimbra start manually as root, it starts up fine.

    Anyone have any idea?

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Did you enable SELinux? I did a quick google search on the error/question and it seems that SELinux has this exact question on many su and sudo commands.

  3. #3
    Join Date
    Nov 2005
    Posts
    2
    Rep Power
    9

    Default Problem resolved

    That did it. SELinux was the problem. I've disabled SELinux and now the prompt is no more. Of course I'd really like to keep SELinux active but my SELinux knowledge is rather limited at this point and this ain't the SELinux forums so I guess I have some more learning to do

    On a not-quite-so-related note, I notice I'm getting a bunch of these:

    Nov 13 09:36:43 zebrax-cent zimbramon[2265]: 2265:info: start app postfix
    Nov 13 09:36:43 zebrax-cent zimbramon[2265]: 2265:err: SMTP RESPONSE: FAILURE from localhost: problem connecting to "localhost", port 25: Connection refused
    Nov 13 09:36:43 zebrax-cent zimbramon[2265]: 2265:info: Starting child postfix: (20051113093643)

    Although the server does finish loading and Postfix is successfully running (I telnet'ed to port 25 and got a Postfix prompt). Are these error messages ignorable?

  4. #4
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default postfix error messages

    Yes, you can ignore that - when we start postfix, we first attempt to connect to it, to see if it's running - that's when the error is logged.

Similar Threads

  1. Replies: 9
    Last Post: 03-01-2008, 07:21 PM
  2. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 09:39 AM
  3. Logger
    By jholder in forum Installation
    Replies: 24
    Last Post: 03-31-2006, 10:50 AM
  4. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 09:47 AM
  5. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 07:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •