Results 1 to 6 of 6

Thread: FQDN Bounce

  1. #1
    Join Date
    Jan 2014
    Posts
    86
    Rep Power
    1

    Default FQDN Bounce

    I have ZCS 8.0.6 installed and running fine. I'm using a web server that has a form system to create web-based forms that will send an email to a recipient upon submission. If I specify my gmail account in the form as the delivery address it comes through no problem. However if I specify user@domain.com (where domain is is my fqdn.com) address I receive the below error in Postfix on the web server that is submitting the form:

    Code:
    Feb  8 18:15:30 www postfix/smtp[7890]: 146859AF6: to=<user@domain.com>, relay=mail.domain.com[72.14.179.xxx]:25, delay=0.01, delays=0/0/0.01/0, dsn=5.5.2, status=bounced (host mail.domain.com[72.14.179.xxx] said: 504 5.5.2 <www-data@localhost>: Sender address rejected: need fully-qualified address (in reply to RCPT TO command))
    Feb  8 18:15:30 www postfix/clean
    I assume this is some check in the MTA in ZCS causing it to bounce. I've set a FQDN address in my reply-to in the form itself and it still has the same problem.

    I also disabled reject_non_fqdn_sender via Global Settings -> MTA and it still had no effect. I'm still bouncing.

    Is this something I should address with Postfix on the webserver (setting the fqdn or looking into the hosts/hostname)? Or is there something in ZCS that I can uncheck to allow this message through?

  2. #2
    Join Date
    Jan 2014
    Posts
    86
    Rep Power
    1

    Default

    I think I may have found the problem. On the web server's postfix configuration I didn't have an FQDN set for the hostname. I set the fqdn to the fqdn of the server itself, restarted postfix and the form submitted no problem and was delivered.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by czguy View Post
    Code:
    Feb  8 18:15:30 www postfix/smtp[7890]: 146859AF6: to=<user@domain.com>, relay=mail.domain.com[72.14.179.xxx]:25, delay=0.01, delays=0/0/0.01/0, dsn=5.5.2, status=bounced (host mail.domain.com[72.14.179.xxx] said: 504 5.5.2 <www-data@localhost>: Sender address rejected: need fully-qualified address (in reply to RCPT TO command))
    Feb  8 18:15:30 www postfix/clean
    I assume this is some check in the MTA in ZCS causing it to bounce. I've set a FQDN address in my reply-to in the form itself and it still has the same problem.
    It's the sender address that needs a correct domain name not the "reply to".
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    Jan 2014
    Posts
    86
    Rep Power
    1

    Default

    Quote Originally Posted by phoenix View Post
    It's the sender address that needs a correct domain name not the "reply to".
    The sender's (from) address had a correct address. I even tried turning off non_fqdn_sender and it still bounced.

    Here's my current MTA restriction

    Code:
    zimbra@mail:~$ zmprov gacf | grep zimbraMtaRestriction
    zimbraMtaRestriction: reject_non_fqdn_sender
    What ended up fixing the problem was to set the hostname in Postfix (on the web server) from localhost to the FQDN of the web server. No problems after that.

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by czguy View Post
    The sender's (from) address had a correct address.
    Not according to the error message you' posted earlier:

    Code:
    said: 504 5.5.2 <www-data@localhost>: Sender address rejected: need fully-qualified address
    You've either not got the from address correct or you've got a configuration error in postfix 'mydomain' setting.
    Last edited by phoenix; 02-09-2014 at 11:33 AM. Reason: spelling
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Jan 2014
    Posts
    86
    Rep Power
    1

    Default

    Quote Originally Posted by phoenix View Post
    Not according to the error message you' posted earlier:

    Code:
    said: 504 5.5.2 <www-data@localhost>: Sender address rejected: need fully-qualified address
    You've either not got the from address correct or you've got a configuration error in postfix 'mydomain' setting.
    In this case fixing the myhostname directive in /etc/postfix/main.cf resolved the problem.

Similar Threads

  1. [SOLVED] FQDN Fix
    By Ogima in forum Installation
    Replies: 2
    Last Post: 05-18-2010, 11:53 AM
  2. Bounce email should get bounce to 2 email address
    By abhiz in forum Administrators
    Replies: 1
    Last Post: 11-16-2009, 10:44 PM
  3. Fqdn
    By eelali in forum Installation
    Replies: 2
    Last Post: 06-12-2008, 12:49 PM
  4. problem abt FQDN. help plz
    By manjunath in forum Installation
    Replies: 2
    Last Post: 04-11-2006, 07:54 AM
  5. Fqdn
    By SteveP in forum Installation
    Replies: 3
    Last Post: 03-06-2006, 03:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •