We are on

Centos 5.6 (x86_64)
Zimbra OSE 7.2.6_GA_2926.RHEL5_64_20131203115905
Postfix - postfix-

We upgraded our system from 7.0.4 some time ago. All of the external hosts settings were wiped up during the upgrade as expected but we were not able to re-instate the settings as before following our internal procedures that worked with 7.0.4.

Please don't insult my intelligence and with some link to the following articles which I have followed to the T.
Relay per Domain - Zimbra :: Wiki

The above Articles DO NOT work on 7.2.6.

And secondly, don't make any comments about the version of Centos I am using either I am well aware of its age; stick to answering my question.

Settings as follows:-
mydomain.com :

I tried also:-
mydomain.com :[]

even tried:-
mydomain.com smtp:[]

and tried also:-
mydomain.com relay:[]

postmap /opt/zimbra/postfix/conf/transportfile

zmlocalconfig shows:-
zmlocalconfig |grep -i postfix_transport_maps
postfix_transport_maps = hash:/opt/zimbra/postfix/conf/transportfile proxy:ldap:/opt/zimbra/conf/ldap-transport.cf

restarted Zimbra
zmcontrol stop
zmcontrol start

or zmmtactl stop
zmmtactl start

I am trying to get "mydomain.com" emails to be delivered to an external server or relayed through an external - to no avail.

The above settings / protocol worked before but not anymore.

When I conduct tests sending emails to someperson@mydomain.com through another account on the same server - the emails are delivered locally rather than externally. /var/log/maillog still shows the MTA to be

Why is this not working since upgrading o 7.2.6.??

Can some intelligent person shed light on this???