Results 1 to 7 of 7

Thread: send mail issue

  1. #1
    Join Date
    Feb 2014
    Location
    dubai
    Posts
    6
    Rep Power
    1

    Default send mail issue

    Hello,

    I have installed Zimbra 8 on centos 6.5, NO firewall or NAT, I receive all incoming emails but when I send any emails to outside the domain then it is not delivering, I have not configured DNS or Split DNS either not sure this is to be configured when the serverís NIC is connected a static IP, I was searching on google, wiki, zimbra forums, but was not able to find a step by step guide to configure DNS on zimbra fresh installation

    Here are my current configuration I have done for hosts file & resolv.conf
    /etc/hosts
    127.0.0.1 localhost localhost.localdomain
    94.200.36.202 mail.fashionfriday.me mail

    /etc/resolv.conf
    search 213.132.63.25 fashionfriday.me
    nameserver 94.200.200.200

    domain name = fashionfriday.me (purchased from mydomain.com)
    MX record is configured @ mydomain.com control panel = 10 @ 94.200.36.202
    FQDN = mail.fashionfriday.me
    Server IP = 94.200.36.202
    PTR configured from the ISP side

    Not Sure where to start,

    Thanks

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by selikm View Post
    Not Sure where to start,
    Might the problem be the fact that you have invalid (or no) DNS A & MX records? Your MX record should be an FQDN (not an IP address) to a corresponding A record (which doesn't exist).

    Code:
    host -v fashionfriday.me
    Trying "fashionfriday.me"
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64606
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;fashionfriday.me.              IN      A
    
    ;; ANSWER SECTION:
    fashionfriday.me.       3272    IN      A       66.96.163.198
    
    Received 50 bytes from 192.168.1.11#53 in 0 ms
    Trying "fashionfriday.me"
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2437
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;fashionfriday.me.              IN      AAAA
    
    ;; AUTHORITY SECTION:
    fashionfriday.me.       3272    IN      SOA     ns1.mydomain.com. dnsadmin.mydomain.com. 2012123149 10800 3600 604800 3600
    
    Received 95 bytes from 192.168.1.11#53 in 0 ms
    Trying "fashionfriday.me"
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47990
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;fashionfriday.me.              IN      MX
    
    ;; ANSWER SECTION:
    fashionfriday.me.       3272    IN      MX      10 94.200.36.202.
    
    Received 63 bytes from 192.168.1.11#53 in 0 ms
    The requirements for DNS records has been covered many time in the forums and wiki, the Split DNS article tells you exactly what the records should look like (with the obvious change of the IP address to your Public IP).

    You really should have a firewall (or NAT router) in front of this server otherwise you will regret it sooner rather than later.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Feb 2014
    Location
    dubai
    Posts
    6
    Rep Power
    1

    Smile send email issue

    Thanks for your advice, I will put it behind a firewall, right now I'm trying to see how it works, The reason why I tried without a firewall because the Split DNS didn't work for me in my previous installation,

    I will configure MX records and A Records then FQDN will be used in domain provider's control panel



    Quote Originally Posted by phoenix View Post
    Might the problem be the fact that you have invalid (or no) DNS A & MX records? Your MX record should be an FQDN (not an IP address) to a corresponding A record (which doesn't exist).

    Code:
    host -v fashionfriday.me
    Trying "fashionfriday.me"
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64606
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;fashionfriday.me.              IN      A
    
    ;; ANSWER SECTION:
    fashionfriday.me.       3272    IN      A       66.96.163.198
    
    Received 50 bytes from 192.168.1.11#53 in 0 ms
    Trying "fashionfriday.me"
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2437
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;fashionfriday.me.              IN      AAAA
    
    ;; AUTHORITY SECTION:
    fashionfriday.me.       3272    IN      SOA     ns1.mydomain.com. dnsadmin.mydomain.com. 2012123149 10800 3600 604800 3600
    
    Received 95 bytes from 192.168.1.11#53 in 0 ms
    Trying "fashionfriday.me"
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47990
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;fashionfriday.me.              IN      MX
    
    ;; ANSWER SECTION:
    fashionfriday.me.       3272    IN      MX      10 94.200.36.202.
    
    Received 63 bytes from 192.168.1.11#53 in 0 ms
    The requirements for DNS records has been covered many time in the forums and wiki, the Split DNS article tells you exactly what the records should look like (with the obvious change of the IP address to your Public IP).

    You really should have a firewall (or NAT router) in front of this server otherwise you will regret it sooner rather than later.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by selikm View Post
    Thanks for your advice, I will put it behind a firewall, right now I'm trying to see how it works, The reason why I tried without a firewall because the Split DNS didn't work for me in my previous installation,
    Well it should do, it's fairly straightforward to configure and plenty of people on the forums use a NAT router with ZCS behind it (including me).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Feb 2014
    Location
    dubai
    Posts
    6
    Rep Power
    1

    Default

    hi Bill,

    I have followed DNS configuration guides and configured named.conf and zone files, named service is running but still I'm not able to send emails, I have changed mx record in mydomain.com control panel as well (10 @ mail.fashionfriday.me)

    is there any more records to be created there on hosting control panel or am I missing anything could you please check below configuration?

    I'm still not using NAT or any Firewall


    # hostname
    mail.fashionfriday.me

    # hostname -f
    mail.fashionfriday.me

    Server IP 94.200.36.202

    # nano /etc/hosts
    127.0.0.1 localhost localhost.localdomain
    94.200.36.202 mail.fashionfriday.me mail

    # nano /etc/resolv.conf
    search 213.132.63.25 fashionfriday.me (this IP is ISP's DNS address)
    nameserver 94.200.200.200 (this IP is ISP's DNS address)

    # nano /etc/named.conf
    options {
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;
    };

    //
    // a caching only nameserver config
    //
    controls {
    // inet 127.0.0.1 allow { localhost; } keys { rndckey; };
    };


    zone "fashionfriday.me" IN {
    type master;
    file "/var/named/fashionfriday.me.zone";
    allow-update { none; };
    };

    zone "202.36.200.94.in-addr.arpa" IN {
    type master;
    file "/var/named/202.36.200.94.rev";
    allow-update { none; };
    };

    include "/etc/rndc.key";

    # nano /var/named/fashionfriday.me.zone


    $TTL 86400
    @ IN SOA fashionfriday.me. email.fashionfriday.me. (
    100 ; serial
    1H ; refresh
    1M ; retry
    1W ; expiry
    1D ) ; minimum
    @ IN NS ns1.fashionfriday.me.
    @ IN A 94.200.36.202
    ns1 IN A 94.200.36.202
    @ IN MX 10 email.fashionfriday.me.
    mail IN A 94.200.36.202
    WWW IN A 94.200.36.202



    # nano /var/named/202.36.200.94.rev

    $TTL 86400
    @ IN SOA fashionfriday.me. email.fashionfriday.me. (
    101
    1H
    1M
    1W
    1D )
    @ IN NS ns10.fashionfriday.me.
    202.36.200.94.in-addr.arpa. IN PTR mail.fashionfriday.me.

  6. #6
    Join Date
    Feb 2014
    Location
    dubai
    Posts
    6
    Rep Power
    1

    Default

    Quote Originally Posted by phoenix View Post
    Well it should do, it's fairly straightforward to configure and plenty of people on the forums use a NAT router with ZCS behind it (including me).
    Sorry for the repost to my own, thought you have missed it bill,

    I have followed DNS configuration guides and configured named.conf and zone files, named service is running but still I'm not able to send emails, I have changed mx record in mydomain.com control panel as well (10 @ mail.fashionfriday.me)

    is there any more records to be created there on hosting control panel or am I missing anything could you please check below configuration?

    I'm still not using NAT or any Firewall


    # hostname
    mail.fashionfriday.me

    # hostname -f
    mail.fashionfriday.me

    Server IP 94.200.36.202

    # nano /etc/hosts
    127.0.0.1 localhost localhost.localdomain
    94.200.36.202 mail.fashionfriday.me mail

    # nano /etc/resolv.conf
    search 213.132.63.25 fashionfriday.me (this IP is ISP's DNS address)
    nameserver 94.200.200.200 (this IP is ISP's DNS address)

    # nano /etc/named.conf
    options {
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;
    };

    //
    // a caching only nameserver config
    //
    controls {
    // inet 127.0.0.1 allow { localhost; } keys { rndckey; };
    };


    zone "fashionfriday.me" IN {
    type master;
    file "/var/named/fashionfriday.me.zone";
    allow-update { none; };
    };

    zone "202.36.200.94.in-addr.arpa" IN {
    type master;
    file "/var/named/202.36.200.94.rev";
    allow-update { none; };
    };

    include "/etc/rndc.key";

    # nano /var/named/fashionfriday.me.zone


    $TTL 86400
    @ IN SOA fashionfriday.me. email.fashionfriday.me. (
    100 ; serial
    1H ; refresh
    1M ; retry
    1W ; expiry
    1D ) ; minimum
    @ IN NS ns1.fashionfriday.me.
    @ IN A 94.200.36.202
    ns1 IN A 94.200.36.202
    @ IN MX 10 email.fashionfriday.me.
    mail IN A 94.200.36.202
    WWW IN A 94.200.36.202



    # nano /var/named/202.36.200.94.rev

    $TTL 86400
    @ IN SOA fashionfriday.me. email.fashionfriday.me. (
    101
    1H
    1M
    1W
    1D )
    @ IN NS ns10.fashionfriday.me.
    202.36.200.94.in-addr.arpa. IN PTR mail.fashionfriday.me.

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by selikm View Post
    Sorry for the repost to my own, thought you have missed it bill,
    No I didn't miss it and I do have a life other than answering questions on these forums. In future, do not post duplicate messages and wait for an answer.

    I don't know where you're getting the IP address of that server but your public DNS records do not have a valid A record pointing to the server for your domain name, I mentioned this earlier in post #2. I'll say this one more time, you need to have your server behind a firewall or NAT router you wiil have security problems if you don't protect that server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Replies: 2
    Last Post: 11-20-2012, 05:55 AM
  2. Can't Receive or Send External Mail - DNS Issue
    By afrojoe in forum Administrators
    Replies: 14
    Last Post: 03-26-2012, 01:53 PM
  3. Webmail send issue
    By ITpro10 in forum Administrators
    Replies: 3
    Last Post: 06-09-2010, 08:49 AM
  4. Local mail issue or setup issue?
    By FlyingFish in forum Administrators
    Replies: 0
    Last Post: 09-22-2009, 10:04 AM
  5. Send mail to AOL issue
    By huynguyengds in forum Administrators
    Replies: 3
    Last Post: 05-26-2009, 11:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •