Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: ZCS 8.0.6 on Ubuntu 12.04 Sending External Address (GMAIL) Goes To Deffered Status

  1. #1
    Join Date
    Apr 2013
    Posts
    10
    Rep Power
    2

    Angry ZCS 8.0.6 on Ubuntu 12.04 Sending External Address (GMAIL) Goes To Deffered Status

    G'day GURUS,

    Im sorry guys, as the title stated, I guess i already did what i have read on this forum but I can't find it get through on gmail.

    I hope you guys can help me out and to make it everyone help me better, below is my server configs:

    Ubuntu Server IP: 10.0.1.68
    Ubuntu Server FQDN: pgas.mail
    DNS Server IP: 8.8.8.8
    Domain Name: pgas.mail
    Public IP: 124.XX.XX.XX (port 80 forwarded to windows server running IIS7 to host our web applications)
    Firewall: Cyberoam (Network Security Appliances | Firewall Network Security - Cyberoam) (forwarded port 25 both tcp and udp to zimbra mail server IP 10.0.1.68)
    # cat /etc/hostname
    pgas.mail
    # cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    10.0.1.68 pgas.mail pgas

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback localhost
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    # cat /etc/bind/named.conf.options
    options {
    directory "/var/cache/bind";

    // If there is a firewall between you and nameservers you want
    // to talk to, you may need to fix the firewall to allow multiple
    // ports to talk. See Vulnerability Note VU#800113 - Multiple DNS implementations vulnerable to cache poisoning

    // If your ISP provided one or more IP addresses for stable
    // nameservers, you probably want to use them as forwarders.
    // Uncomment the following block, and insert the addresses replacing
    // the all-0's placeholder.

    forwarders {
    8.8.8.8;
    };

    //================================================== ======================
    // If BIND logs error messages about the root key being expired,
    // you will need to update your keys. See https://www.isc.org/bind-keys
    //================================================== ======================
    dnssec-validation auto;

    auth-nxdomain no; # conform to RFC1035
    listen-on-v6 { any; };
    };

    zone "pgas.mail" {
    type master;
    file "file.pgas.mail";
    };
    # cat /var/cache/bind/file.pgas.mail
    $ttl 38400
    @ IN SOA pgas.mail. pgas.mail. (
    2011091202
    10800
    3600
    604800
    38400 )
    IN NS ns.pgas.mail.
    IN A 10.0.1.68
    IN MX 10 pgas.mail.

    @ A 10.0.1.68
    ns A 10.0.1.68
    pgas A 10.0.1.68
    #cat /etc/resolv.conf
    nameserver 127.0.0.1
    search pgas.mail
    # dig pgas.mail mx
    ; <<>> DiG 9.8.1-P1 <<>> pgas.mail mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14526
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;pgas.mail. IN MX

    ;; ANSWER SECTION:
    pgas.mail. 38400 IN MX 10 pgas.mail.

    ;; AUTHORITY SECTION:
    pgas.mail. 38400 IN NS ns.pgas.mail.

    ;; ADDITIONAL SECTION:
    pgas.mail. 38400 IN A 10.0.1.68
    ns.pgas.mail. 38400 IN A 10.0.1.68

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon Feb 24 15:40:31 2014
    ;; MSG SIZE rcvd: 91
    # dig pgas.mail any
    ; <<>> DiG 9.8.1-P1 <<>> pgas.mail any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60571
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;pgas.mail. IN ANY

    ;; ANSWER SECTION:
    pgas.mail. 38400 IN SOA pgas.mail. pgas.mail. 2011091202 10800 3600 604800 38400
    pgas.mail. 38400 IN NS ns.pgas.mail.
    pgas.mail. 38400 IN A 10.0.1.68
    pgas.mail. 38400 IN MX 10 pgas.mail.

    ;; ADDITIONAL SECTION:
    ns.pgas.mail. 38400 IN A 10.0.1.68

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon Feb 24 15:41:45 2014
    ;; MSG SIZE rcvd: 127
    Also executing the following commands:
    # /etc/init.d/apparmour stop
    # /etc/init.d/apparmor teardown
    # update-rc.d -f apparmor remove

    Also, these commands after zimbra installation:
    # su zimbra
    # zmtlsctl http
    # zmcontrol restart
    Last edited by nbwzrd; 02-24-2014 at 12:06 AM.

  2. #2
    Join Date
    Apr 2013
    Posts
    10
    Rep Power
    2

    Default

    anyone guys?

    sorry, im very desperate!

  3. #3
    Join Date
    Feb 2014
    Posts
    12
    Rep Power
    1

    Default

    Why don't you try discussing the issue with zimbra or ubuntu support? I think they will be able to give you the best solution for this.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by nbwzrd View Post
    anyone guys?

    sorry, im very desperate!
    The problem is your DNS configuration is incorrect, go to the wiki and read the article on Split DNS and then configure it correctly (including the hosts & resolv files) and then run the commands in the 'Verify...' section of that article to check your configuration is working correctly.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Apr 2013
    Posts
    10
    Rep Power
    2

    Default

    Quote Originally Posted by phoenix View Post
    The problem is your DNS configuration is incorrect, go to the wiki and read the article on Split DNS and then configure it correctly (including the hosts & resolv files) and then run the commands in the 'Verify...' section of that article to check your configuration is working correctly.
    can you please specify which line?

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by nbwzrd View Post
    can you please specify which line?
    Have you read the Split DNS article and compared the form of the hosts file to the one in that article?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Apr 2013
    Posts
    10
    Rep Power
    2

    Default

    Quote Originally Posted by phoenix View Post
    Have you read the Split DNS article and compared the form of the hosts file to the one in that article?
    yep i did, the one that on the wiki is
    127.0.0.1 localhost.localdomain localhost
    192.168.1.30 mail.yourdomain.com mail
    while mine is
    127.0.0.1 localhost.localdomain localhost
    10.0.1.68 pgas.mail pgas
    though different because thats what it specifies in my /var/cache/bind/file.pgas.mail file which is
    $ttl 38400
    @ IN SOA pgas.mail. pgas.mail. (
    2011091202
    10800
    3600
    604800
    38400 )
    IN NS ns.pgas.mail.
    IN A 10.0.1.68
    IN MX 10 pgas.mail.

    @ A 10.0.1.68
    ns A 10.0.1.68
    pgas A 10.0.1.68
    also #host $(hostname) returns
    pgas.mail has address 10.0.1.68
    pgas.mail mail is handled by 10 pgas.mail.
    am i doing it right?


    Edit:
    Also the reason of the deffered mail is: Connect to alt4.gmail-smtp-in.l.google.com[74.125.131.26]:25: connection timed out

    is it possible that gmail block my email because the email sender uses public ip instead of domain name?
    Last edited by nbwzrd; 03-10-2014 at 02:02 AM.

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by nbwzrd View Post
    yep i did, the one that on the wiki is
    The format of that one is correct.

    Quote Originally Posted by nbwzrd View Post
    while mine is
    Yours is incorrect.

    Quote Originally Posted by nbwzrd View Post
    though different because thats what it specifies in my /var/cache/bind/file.pgas.mail file which is
    That's because your BIND records are also incorrect.

    Quote Originally Posted by nbwzrd View Post
    am i doing it right?
    No, you're not. Your server should have a Fully Qualified Domain Name (FQDN) and your host does not, you need to modify your DNS configuration, your hosts file to reflect that - those things are covered in the wiki article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Apr 2013
    Posts
    10
    Rep Power
    2

    Default

    I'm very sorry, I wasnt able to tell that im a newbie.

    i just followed instruction from here

    I have read the splilt dns wiki but it seems too blurry for me as a newbie, also found some typos, i dont know... (sorry i dont intend to disrespect).

    Yours is incorrect.
    That's because your BIND records are also incorrect.
    Can you show me what is correct please
    Last edited by nbwzrd; 03-10-2014 at 01:40 PM.

  10. #10
    Join Date
    Apr 2013
    Posts
    10
    Rep Power
    2

    Default

    help please

Similar Threads

  1. Replies: 0
    Last Post: 02-03-2014, 05:00 AM
  2. Replies: 1
    Last Post: 01-21-2014, 01:05 AM
  3. No sent messages when sending via smtp using gmail
    By Validity13 in forum General Questions
    Replies: 2
    Last Post: 07-05-2013, 10:31 AM
  4. Problems sending email to gmail
    By EriSan500 in forum Users
    Replies: 1
    Last Post: 10-28-2005, 08:44 AM
  5. Error sending to external address from web client
    By Billy in forum Administrators
    Replies: 12
    Last Post: 10-24-2005, 09:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •