After preparing for an upgrade (cold backup and reboot), I wanted to start Zimbra 8.0.2 again, and all seems well from the command line, as it stated that all are done. When I run zmcontrol status, I see that the mailbox service is not running due to the fact that mysql.server is not running. I looked in the mysql_error log file and found the following:

140227 07:03:23 mysqld_safe Starting mysqld daemon with databases from /opt/zimbra/db/data
140227 7:03:24 InnoDB: The InnoDB memory heap is disabled
140227 7:03:24 InnoDB: Mutexes and rw_locks use GCC atomic builtins
140227 7:03:24 InnoDB: Compressed tables use zlib 1.2.3
140227 7:03:24 InnoDB: Initializing buffer pool, size = 1.2G
140227 7:03:24 InnoDB: Completed initialization of buffer pool
InnoDB: Error: auto-extending data file ./ibdata1 is of a different size
InnoDB: 0 pages (rounded down to MB) than specified in the .cnf file:
InnoDB: initial 640 pages, max 0 (relevant if non-zero) pages!
140227 7:03:24 InnoDB: Could not open or create data files.
140227 7:03:24 InnoDB: If you tried to add new data files, and it failed here,
140227 7:03:24 InnoDB: you should now edit innodb_data_file_path in my.cnf back
140227 7:03:24 InnoDB: to what it was, and remove the new ibdata files InnoDB created
140227 7:03:24 InnoDB: in this failed attempt. InnoDB only wrote those files full of
140227 7:03:24 InnoDB: zeros, but did not yet use them in any way. But be careful: do not
140227 7:03:24 InnoDB: remove old data files which contain your precious data!
140227 7:03:24 [ERROR] Plugin 'InnoDB' init function returned error.
140227 7:03:24 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
140227 7:03:24 [ERROR] Unknown/unsupported storage engine: InnoDB
140227 7:03:24 [ERROR] Aborting

140227 7:03:24 [Note] /opt/zimbra/mysql/bin/mysqld: Shutdown complete

140227 07:03:24 mysqld_safe mysqld from pid file /opt/zimbra/db/mysql.pid ended

I didn't add any additional data files. I tried removing the ibdata file, and the process creates a new one, but want the logs recreated.

I'm stuck on what to do. Could anyone provide me with a hint or tip on what to do to get the server back up and running.