Results 1 to 5 of 5

Thread: Help... SMTP Auth/LDAP/split domain

Threaded View

  1. #1
    Join Date
    Feb 2007
    Location
    Massachusetts
    Posts
    136
    Rep Power
    8

    Default Help... SMTP Auth/LDAP/split domain

    Oh yeah, it's ugly. Any help would be appreciated!

    So, here's the deal. I'm starting my deploy, starting only with myself.

    Setup looks like this. zimbra.domain.com is set up to receive mail from mail.domain.com due to .forward files on mail.domain.com. zimbra sends to mail.domain.com for SMTP. zimbra.domain.com is set up to be able to receive mail for domain.com using external auth from ldaps://ldap.domain.com.

    Send/receive through the webclient, everything is beautiful, Very happy.

    Receive via IMAP SSL (via both t-bird and OSX Mail) , perfect (except the unsigned cert, but I'm not worried about that yet, I just accept).

    Send through thunderbird or Mail (Mac) fails complaining that username pass is wrong when trying to send anywhere. I am of course trying to authenticate with my external LDAP username/pass. I have tried using a local username/pass (a zimbra user that is set up as a zimbra.domain.com user (so they would authenticate via zimbra ldap). That did not work, and even if it did, would not really be acceptable.

    NAMES HAVE BEEN CHANGED TO PROTECT THE INNOCENT

    Logfile sayz:
    <code>
    Feb 13 19:49:28 zimbra postfix/smtpd[6314]: connect from vpn023.domain.com[192.168.41.23]
    Feb 13 19:49:28 zimbra postfix/smtpd[6314]: setting up TLS connection from vpn023.domain.com[192.168.41.23]
    Feb 13 19:49:31 zimbra postfix/smtpd[6314]: TLS connection established from vpn023.domain.com[192.168.41.23]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Feb 13 19:49:35 zimbra saslauthd[15011]: auth_zimbra: myuser auth failed: curl_easy_perform: error(7):
    Feb 13 19:49:35 zimbra saslauthd[15011]: do_auth : auth failure: [user=myuser] [service=smtp] [realm=] [mech=zimbra] [reason=Unknown]
    Feb 13 19:49:35 zimbra postfix/smtpd[6314]: warning: SASL authentication failure: Password verification failed
    Feb 13 19:49:35 zimbra postfix/smtpd[6314]: warning: vpn023.domain.com[192.168.41.23]: SASL PLAIN authentication failed
    Feb 13 19:49:35 zimbra saslauthd[15007]: auth_zimbra: myuser auth failed: curl_easy_perform: error(7):
    Feb 13 19:49:35 zimbra saslauthd[15007]: do_auth : auth failure: [user=myuser] [service=smtp] [realm=] [mech=zimbra] [reason=Unknown]
    Feb 13 19:49:35 zimbra postfix/smtpd[6314]: warning: vpn023.domain.com[192.168.41.23]: SASL LOGIN authentication failed
    </code>

    I have turned off auth and I can send ok to zimbra users, but not to the outside world.

    Logfile sayz:
    <code>
    Feb 13 19:40:39 zimbra postfix/smtpd[4446]: NOQUEUE: reject: RCPT from vpn023.domain.com[192.168.41.23]: 554 <me@home.net>: Relay access denied; from=<user@domain.com> to=<me@home.net> proto=ESMTP helo=<[192.168.41.23]>
    </code>
    Last edited by Nutz; 02-13-2007 at 06:10 PM.

Similar Threads

  1. Replies: 5
    Last Post: 06-18-2008, 01:50 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  3. domain coexistence
    By marcmac in forum Administrators
    Replies: 14
    Last Post: 06-30-2006, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •