Hello Zimbra Forums =D

I'm at the end of my ideas and solutions, its time to reach out for some help, I've successfully solved a number of other Zimbra email issues via the forums and for that I'm grateful for the help. However this one has me completely stumped as I've gone though the forums extensively and followed solutions / paths for similar issues without much success. I've posted most of the information on what I have already tried and not yet tried as well as a few of the forum threads that appear to be similar to my own issue.

If more information is needed, please let me know as I'm happy to post log-files, configuration files, or anything else requested. I'm still trying to sort out the log files and am making progress, but as yet I'm not able to pull out the information I need to better examine the issue.

I'm still a novice with Fedora as most of my technical support experience is with Windows server 2003 email server and networking issues. Thus I have a good grasp of email server configurations, settings, etc, but unfortunately lack the complete expertise to resolve this one.

First you should know the following...
login to https webmail works find, can send and receive email with no issues to any external address
Thunderbird with SSL, TLS, or no encryption for POP3 and IMAP works great, can receive email

External email can be recieved by the server just fine by both webmail and thunderbird
Email sent to external addresses via webmail goes out just fine

Relay though smtp.comcast.net also works just fine, even before we put in the username / password for the smtp_sasl_password_maps = /opt/zimbra/conf/relay_password fix

Thunderbird sending email through the server fails
Get a constant looping asking for password
Can also sometimes get an SMTP message saying connection refused
This error occures when attempting to relay though the hostname.primarydns.com within the network and outside the network.

We've even tried this with Eudora 4 and 6 both with and without encryption and via SSL, TLS.

We've also double checked that all ports on the router are open and forwarding properly including
25, 110, 143, 465, 995 with the server listening on same ports behind the firewall.

The proxy ports for the server (Configured via the web-admin global-settings interface) are
IMAP Proxy 7143 and 7993 (SSL) for POP Proxy its 7110 and 7995 (SSL) but these are both blocked on the firewall as proxy isn't (or shouldn't be) needed by external email clients.

I'm running this on Fedora Core 5 with all OS and software updates and
I'm running the most recent version of Zimbra Open-source downloaded in January 2007
Zimbra installed cleanly and is using the hostname: hostname.primarydns.com
Server is running with an internal IP address of while external address is from Comcast

The server handles mail for two domains
the fully qualified DNS name of the server is hostname.primarydns.com
the second domain is setup in the @domains area as secondarydns.com
Account aliases setup with the secondary domain can send and receive email fine via webmail

To help resolve the DNS issues that would normally result from this, I'm running split-dns internal with dnsmasq which is configured as follows in the dnsmasq.conf file

the etc/hosts file is localhost.localdomain localhost hostname.primarydns.com hostname primarydns.com

I have verified that the global settings area of the Web-based admin always match the servers settings area. After every change to a file (via web-based admin or via “su zimbra”) I've fully restarted the server before moving onto the next step or making the next significant change.

I've verified that all usernames and passwords are correct
I've verified that the MX records for both primary and secondary domains hosted by no-ip.com resolve back to the real external IP address and that the split-dns is able to translate the records into the local internal IP addresses.

I've reviewed and tried all solutions on the following forums and posts. I've probably tried and seen a few more forum posts and simply haven't listed them here.

I've gone trough all the major files listed in these forum topics and near as I can tell, its all configured properly and so theoretically should be working properly.


I've also followed the suggestions of other forum threads and configured saslauthd.conf and saslauthd.conf.in both with “ http “ and “https” and a few other combinations therein as well as the original configuration

zimbra_url: https://hostname.primarydns.com both with “ http “ and “https”
zimbra_cert_file: /opt/zimbra/conf/smtpd.crt
zimbra_cert_check: off