Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: from 4.0.2 to 4.5.1

  1. #11
    Join Date
    Oct 2006
    Posts
    69
    Rep Power
    9

    Question 443 not responding

    In my opinion
    at the morning as soon as users arrive in office and start their pop3 client
    ram or cpu use increases then my system remain in saturation until a restart
    but i don't know what is that remains pending

    I have to schedule a job in cron daemon to restart zimbra?

    My server:

    OpenSuse 10.0
    Kernel 2.6.13-15.13-smp
    application: only zimbra 4.5.1 migrated from 4.0.2
    installation as single server
    3G RAM
    Processor Xeon(TM) 2.66GHz
    Raid-5
    314 account
    66 distributionlist
    3 domain + the default
    200 threads for imap (but i don't use imap client for the moment)
    50 threads for pop3
    df -h output:

    Filesystem Size Used Avail Use% Mounted on
    /dev/sda3 198G 6.4G 182G 4% /
    tmpfs 1.5G 0 1.5G 0% /dev/shm
    /dev/sda1 99M 11M 84M 12% /boot
    10.110.1.10:/web 6.1G 775M 5.4G 13% /backup


    I know that Raid-5 is not reccommended for installations with more than 100 accounts but the most part are pop3users
    I know that for production environnement minimum 2 GB RAM and Recommend 4 GB
    but first with zimbra 4.0.2 i hadn't problem

    Why have i tmpfs if zimbra 4.5.1 doesn't use it? In /etc/fstab the raw has a '#'
    Last edited by cedbl; 02-21-2007 at 03:14 AM.

  2. #12
    Join Date
    Oct 2006
    Posts
    69
    Rep Power
    9

    Default tmpfs on 4.5.1?

    Hi
    i continue alone in this post
    there is somebody?

    Well this morninig port "443 not responding" continues but if i do:
    df -h i see tmpfs how is it possible?
    In my server i installed zimbra OS 4.5.1 where tmpfs is from?

    Please help me understand why after zimbra restart all is good for all the day but at the morning port 443 not responds.

  3. #13
    Join Date
    Oct 2006
    Posts
    69
    Rep Power
    9

    Default hopeness last to die

    i continue in my experience
    Every morning web access on 443 port doesn't respond
    After reboot ram free is huge but after some hours ram became more and more busy.
    But that is not all !!!
    web access is ok even if free ram is less than before the last reboot

    So all days i have to restart zimbra

    Now i give you my backup script that worked well every night with 4.0.2 could be it my source problem with 4.5.1?

    Code:
    #!/bin/bash
    ZMDATA=/opt/zimbra
    BACKUPFILE=/dev/nst0
    LOG=/root/zimbra/backup.log
    
    
    echo "started at `date`" >  $LOG
    echo "___________________________________" >> $LOG
    
    
    sudo -u zimbra /opt/zimbra/bin/zmcontrol stop
    sleep 30
    
    echo "" >> $LOG
    echo "process list after first zimbra stop:" >> $LOG
    ps -U zimbra >> $LOG
    
    #lets clean up any left-overs...
    kill -9 `ps -U zimbra|grep [0-9]|awk '{print $1}'` > /dev/null
    sleep 10
    
    
    echo "" >> $LOG
    echo "process list after kill `date`:" >> $LOG
    ps -U zimbra >> $LOG
    
    
    cd /opt
    tar -czf $BACKUPFILE $ZMDATA
    
    sudo -u zimbra /opt/zimbra/bin/zmcontrol start &
    
    #salvataggio ldap
    tar cvpzf /dev/nst0 /backup > /var/log/bk 2> /var/log/bkerr
    
    #registrazione su log della dimensione del salvataggio
    # riavvolgimento senza espulsione
    mt -f /dev/nst0 rewind
    # avanzamento al primo archivio
    mt -f /dev/nst0 fsf
    echo "Salvataggio Zimbra" >> $LOG
    mt -f /dev/nst0 tell >> $LOG
    mt -f /dev/nst0 fsf
    echo "Salvataggio Server ldap" >> $LOG
    mt -f /dev/nst0 tell >> $LOG
    #riavvolgimento e espulsione nastro
    mt -f /dev/nst0 rewoffl
    
    #notifica via mail esito backup
    /bin/echo Log del backup | /usr/bin/nail -a $LOG -a /var/log/bk -a /var/log/bkerr -s Log admin@mail.provincia.belluno.it
    Last edited by cedbl; 02-26-2007 at 12:35 AM.

  4. #14
    Join Date
    Oct 2006
    Posts
    69
    Rep Power
    9

    Exclamation

    Hi
    i continue

    I stopped my backup script friday.
    Saturday, Sunday, and today (Monday) web access is ok

    Maybe my backup script doesn't work with 4.5.1?
    Sleep times are too short?

  5. #15
    Join Date
    Oct 2006
    Posts
    69
    Rep Power
    9

    Default sudo is the problem


Similar Threads

  1. Where is the Zimbra 4.5.1 open source edition?
    By indymail in forum Installation
    Replies: 9
    Last Post: 06-28-2007, 09:30 AM
  2. Wrong ZImbra timezone after 4.5.1 upgrade
    By 3RiversTechAdmin in forum Administrators
    Replies: 3
    Last Post: 02-14-2007, 08:39 AM
  3. Replies: 5
    Last Post: 02-06-2007, 10:58 AM
  4. what are the bugs fixed by 4.0.2?
    By zzzzsg in forum Administrators
    Replies: 2
    Last Post: 10-17-2006, 08:49 AM
  5. Upgrade 3.1.4 to 4.0.2
    By Richard in forum Zimbra Connector for Outlook
    Replies: 4
    Last Post: 10-10-2006, 07:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •