Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: Removing Zimbra on Port 80

  1. #11
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default you type faster than I do :)

    The logger problem is probably swatch dying, per my previous post. Check /tmp/logswatch.out for errors (such as DBD choking)

  2. #12
    Join Date
    Nov 2005
    Posts
    24
    Rep Power
    10

    Default

    Well, I get no errors when starting Zimbra now. However, in /tmp/logswatch.out, I get:

    /usr/bin/tail: can not open '/var/log/zimbra.log# for reading: Permission denied
    /usr/bin/tail: no files remaining

    What should the ownership of zimbra.log be?

    Thanks again for all your help

  3. #13
    Join Date
    Nov 2005
    Posts
    24
    Rep Power
    10

    Default

    Also, I am now trying to get mod_jk working and having problems. It seems that there is no ajp13 running on port 8009 as they used to be.

    I'm not a Tomcat expert so not to sure what to do. What I think happened was that mod_jk used my workers.properties to connect to Tomcat by ajp13. However, this no longer exists so it can't connect.

    How can I enabled this? Is it possible?

    Thanks

  4. #14
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default zimbra readable

    you can chown it to zimbra, or just give it world read permissions.

  5. #15
    Join Date
    Nov 2005
    Posts
    24
    Rep Power
    10

    Default

    I now have a different error ;-)

    *** logswatch version 3.1.1 (pid:19806) started at Tue Nov 15 20:23:09 GMT 2005

    DBD::mysql::st execute failed: Column 'loghost' cannot be null at /opt/zimbra/bi
    n/zmlogger line 127, <> line 15.
    DBD::mysql::st execute failed: Column 'loghost' cannot be null at /opt/zimbra/bi
    n/zmlogger line 127, <> line 16.

    Any idea on either this or the Tomcat issue? Thanks Again!

  6. #16
    Join Date
    Nov 2005
    Posts
    24
    Rep Power
    10

    Default

    Yay! Got mod_jk working. It seems you guys have got rid of a lot of rubbish in /opt/tomcat/conf/server.xml and in the time, removed the ajp13 connector. To reinstate it, add these line:


    <!-- Define an AJP 1.3 Connector on port 8009 -->
    <Connector port="8009"
    enableLookups="false" redirectPort="8443" protocol="AJP/1.3" />

    I just it just above:

    <Engine name="Catalina" defaultHost="localhost">

    and just below:

    keystoreFile="/opt/zimbra/tomcat/conf/keystore" keystorePass="zimbra"/>

    Hope it works1

  7. #17
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default You can ignore that one

    The loghost cannot be null error can be ignored - it's just complaining that some logs can't be processed, which is normal

  8. #18
    Join Date
    Sep 2005
    Posts
    10
    Rep Power
    10

    Default

    Is it possible to make Zimbra listen on one IP, and make apache listen on another, instead of messing with all of this mod_jk stuff. Which BTW I have not been able to get working.

  9. #19
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default IP binding

    We don't really support it in our configs, but it shouldn't be that hard.

    Read the apache docs for the config item you need - I think it's the listen directive, which can take an IP:PORT argument.

    For tomcat, it's probably the listenAddress item in server.xml.

    When you do this, make sure Tomcat also binds to the loopback interface...

  10. #20
    Join Date
    Sep 2005
    Posts
    10
    Rep Power
    10

    Default

    Damn I should read more carefully next time. I got Mod_jk working, I was not adding the trailing / on the address so it was failing. I need to create and alias for that so my users don't panic if they type it without the /



    BTW great job on Zimbra
    Last edited by flateric; 11-28-2005 at 11:43 AM.

Similar Threads

  1. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  2. Replies: 16
    Last Post: 09-07-2006, 07:39 AM
  3. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 10:19 AM
  4. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM
  5. Replies: 1
    Last Post: 11-23-2005, 01:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •