Results 1 to 4 of 4

Thread: zimbra antivirus update clamav 0.90 failed

  1. #1
    Join Date
    Dec 2006
    Rep Power

    Default zimbra antivirus update clamav 0.90 failed

    I was trying to upgrade my clamav0.88.7 to clam-0.90 but it gave error during configure. My zimbra uid is 1165 & gid 1041. So I ran following command :-

    ./configure --prefix=/opt/zimbra/clamav-0.90/ --with-user=1165 --with-group=1041

    I am giving here last few lines :-

    checking for zlib installation... /usr
    checking for inflateEnd in -lz... yes
    checking for bzReadOpen in -lbz2... no
    checking bzlib.h usability... yes
    checking bzlib.h presence... yes
    checking for bzlib.h... yes
    checking for sn_sigscan_initdb in -lsn_sigscan... no
    checking for __dn_expand in -lresolv... yes
    checking for resolv.h... yes
    checking whether setpgrp takes no argument... yes
    checking for __gmpz_init in -lgmp... yes
    checking for curl >= 7.10.0... FAILED
    configure: WARNING: curl-config was not found
    checking for recvmsg... yes
    checking for sendmsg... yes
    checking for msg_accrights field in struct msghdr... no
    checking for msg_control field in struct msghdr... yes
    checking for gethostbyname_r... yes, and it takes 6 arguments
    checking for readdir_r... support disabled
    checking for ctime_r... yes, and it takes 2 arguments
    checking for socklen_t... yes
    checking for 1165 in /etc/passwd... no
    configure: error: User 1165 (and/or group 1041) doesn't exist. Please read the documentation !

    User 1165 & group 1041 exists for zimbra, and months back, I had updated clamav.88.4 to clamav.88.7 using this method. Following command reflects this :
    [root@mailserver1 /]# id zimbra
    uid=1165(zimbra) gid=1041(zimbra) groups=1041(zimbra),5(tty),1042(postfix)

    I wonder why it is unable to find user in /etc/passwd. Can anyone help me ?

  2. #2
    Join Date
    Oct 2005
    Thatcher, AZ
    Rep Power


    Just for kicks, have you tried:
    ./configure --prefix=/opt/zimbra/clamav-0.90/ --with-user=zimbra --with-group=postfix



  3. #3
    Join Date
    Jun 2006
    Washington DC
    Rep Power


    username and group of: zimbra
    is what I have been using on FC4 .

    My passwd file lists: zimbra:x:501:501::/opt/zimbra:/bin/bash
    more /etc/group has: zimbra:x:501:

    Anyone see this ( CLAMAV Upgrade howto) in the WIKI?

    If not, I can always add later today.
    Probably better to have in WIKI, as the upgrade forum doc is getting a little stale.


  4. #4
    Join Date
    Dec 2006
    Rep Power

    Default It worked

    Thanks for help. Following command is working fine.

    ./configure --prefix=/opt/zimbra/clamav-0.90/ --with-user=zimbra --with-group=zimbra

    I don't know why simply uid & gid was not working while giving username & group name is working.

Similar Threads

  1. QUE Failure
    By tbullock in forum Administrators
    Replies: 31
    Last Post: 07-30-2008, 12:17 PM
  2. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  3. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 10:34 PM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts