Results 1 to 2 of 2

Thread: LDAP, zimbra 7.2, and localconfig.xml relationship

  1. #1
    Join Date
    Jan 2008
    Posts
    8
    Rep Power
    7

    Default LDAP, zimbra 7.2, and localconfig.xml relationship

    Greetings,

    I am preparing to do a migration of 32 to 64. On a working 7.2 Network/Pro zimbra colloboration suite, I notice this behavior. File permission are set with localconfig.xml as 640 owned by zimbra and group zimbra... same as original. I have already updated the mysql passwords to be the same on both the 32 and 64 machines and this was a non issue getting the two in sync.

    1) If I shutdown working zimbra
    2) Update the localconfig.xml with new passwords from my 32 bit instance and restart
    3) It will fail on startup with:

    Starting ldap...Done.
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.

    then

    1) If I put back the old localconfig.xml and restart its good

    I tried to come at it from another way using zmldapasswd but think I am missing the relationship between localconfig.xml, zmldapasswd, etc.

    I can use zmldappasswd to set the zimbra_ldap_passwd but then next command like zmlpasswd -r ldap_root_password will fail

    Thought I would give myself a headstart by getting most of the passwords the same before I start messing around with ldap structure but not getting very far.

    I was hoping to understand what is going on before I regenerate certs, remove redologs, etc and start mucking around with a working configuration given the many solutions I have found that people have tried.

    I am following along the "Network Edition: Moving from 32-bit to 64-bit Server document" where they mention to edit localconfig.xml

    If I diff my two localconfig.xml - it shows nothing different other than passwords. If I grep for the ldap password in the backup of my ldap dumps, I don't it in there either... Is there a place that these passwords might be stored somewhere else? I am at a loss of what is going on here.

    Any pointers would be much appreciated.

    Thanks

    Jim

  2. #2
    Join Date
    Jan 2008
    Posts
    8
    Rep Power
    7

    Default

    A little more info about my problem.
    [LDAP: error code 49 - Invalid Credentials])

    Fixed it by this article. Apparently it also works for version 7 and not just version 5 as listed

    Setting zimbra admin password in LDAP - Zimbra :: Wiki

    There must be a simpler way but I couldn't find it.

    I did waste a huge amount of time going down wrong paths like DNS, regenerating certs, etc, etc. LOL

    Hope this help others.

    Jim

Similar Threads

  1. No relationship between Contacts and Compose
    By oldron in forum General Questions
    Replies: 3
    Last Post: 01-26-2012, 12:49 AM
  2. LDAP and localconfig.xml
    By pete irvine in forum Administrators
    Replies: 1
    Last Post: 08-01-2011, 09:10 PM
  3. mailbox and messages relationship
    By hvle in forum Administrators
    Replies: 2
    Last Post: 01-14-2008, 02:28 PM
  4. Zimbra Samba PDC with a Trust Relationship to AD
    By kurt.oconnor in forum Administrators
    Replies: 7
    Last Post: 07-30-2007, 10:43 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •