Results 1 to 3 of 3

Thread: Split DNS not working after OS upgrade

  1. #1
    Join Date
    Apr 2008
    Location
    Brighton, ON, Canada
    Posts
    89
    Rep Power
    7

    Default Split DNS not working after OS upgrade

    Hi

    I was previously running an old 6 version on Ubuntu 8.04. Since this is quite old, upgraded to Ubuntu 10.04 and Zimbra 7.2.7 OS edition.

    Since upgrading my Split DNS has stopped functioning (I think) as we are not getting internal emails. In the mail log file is an error:

    Code:
    Host or domain name not found. Name service error for name=mailserv.rci.ca type=A: Host not found, try again
    Have checked the setup as per the Split DNS article at Split DNS - Zimbra :: Wiki

    Here are my files:

    /etc/bind/named.conf.options:
    Code:
    options {
            auth-nxdomain no;    # conform to RFC1035
            query-source address * port 53;
            directory "/var/named";
            dump-file "/var/named/data/cache_dump.db";
            statistics-file "/var/named/data/named_stats.txt";
            forwarders { 24.226.1.93; 24.226.10.193; };
    };
    include "/etc/bind/rndc.key";
    zone "mailserv.rci.ca" {
            type master;
            file "/var/named/db.mailserv.rci.ca";
    };
    /var/named/db.mailserv.rci.ca:
    Code:
    ;
    ; BIND data file for rci.ca
    ;
    $TTL    604800
    @       IN      SOA     mailserv.rci.ca. scott.rci.ca. (
                             070740         ; Serial
                             604800         ; Refresh
                              86400         ; Retry
                            2419200         ; Expire
                             604800 )       ; Negative Cache TTL
    ;
            IN      NS      192.168.7.101
    rci.ca.             IN      MX      10 mailserv.rci.ca.
    mailserv.rci.ca.    IN      A       192.168.7.101
    /etc/hosts:
    Code:
    127.0.0.1       localhost.localdomain localhost
    192.168.7.101   mailserv.rci.ca mailserv
    192.168.7.20    laciebig2
    
    ::1     localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    /etc/resolv.conf:
    Code:
    search rci.ca
    nameserver 127.0.0.1
    dig rci.ca mx:
    Code:
    ; <<>> DiG 9.7.0-P1 <<>> rci.ca mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26469
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 2, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;rci.ca.                                IN      MX
    
    ;; ANSWER SECTION:
    rci.ca.                 400     IN      MX      200 rci.ca.s7a2.psmtp.com.
    rci.ca.                 400     IN      MX      300 rci.ca.s7b1.psmtp.com.
    rci.ca.                 400     IN      MX      400 rci.ca.s7b2.psmtp.com.
    rci.ca.                 400     IN      MX      100 rci.ca.s7a1.psmtp.com.
    
    ;; AUTHORITY SECTION:
    rci.ca.                 83264   IN      NS      connect-to.reach.net.
    rci.ca.                 83264   IN      NS      flamingo-to.reach.net.
    
    ;; ADDITIONAL SECTION:
    connect-to.reach.net.   168771  IN      A       147.194.32.1
    flamingo-to.reach.net.  69769   IN      A       147.194.32.8
    
    ;; Query time: 25 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Apr 17 15:53:02 2014
    ;; MSG SIZE  rcvd: 237
    dig rci.ca any:
    Code:
    ; <<>> DiG 9.7.0-P1 <<>> rci.ca any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40634
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 8, AUTHORITY: 2, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;rci.ca.                                IN      ANY
    
    ;; ANSWER SECTION:
    rci.ca.                 400     IN      SOA     connect-to.reach.net. hostmaster.reach.net. 2013012900 10800 3600 604800 86400
    rci.ca.                 400     IN      A       147.194.32.10
    rci.ca.                 400     IN      MX      200 rci.ca.s7a2.psmtp.com.
    rci.ca.                 400     IN      MX      300 rci.ca.s7b1.psmtp.com.
    rci.ca.                 400     IN      MX      400 rci.ca.s7b2.psmtp.com.
    rci.ca.                 400     IN      MX      100 rci.ca.s7a1.psmtp.com.
    rci.ca.                 400     IN      NS      connect-to.reach.net.
    rci.ca.                 400     IN      NS      flamingo-to.reach.net.
    
    ;; AUTHORITY SECTION:
    rci.ca.                 400     IN      NS      flamingo-to.reach.net.
    rci.ca.                 400     IN      NS      connect-to.reach.net.
    
    ;; ADDITIONAL SECTION:
    connect-to.reach.net.   168742  IN      A       147.194.32.1
    flamingo-to.reach.net.  69740   IN      A       147.194.32.8
    
    ;; Query time: 25 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Apr 17 15:53:31 2014
    ;; MSG SIZE  rcvd: 328
    host $(hostname):
    Code:
    Host mailserv.rci.ca not found: 3(NXDOMAIN)
    Any ideas?

  2. #2
    Join Date
    Apr 2008
    Location
    Brighton, ON, Canada
    Posts
    89
    Rep Power
    7

    Default

    Is a reverse zone file required? I have not needed it in the past.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by strafford View Post
    Is a reverse zone file required? I have not needed it in the past.
    You can use one for completeness but it should not be required on a lan. The problem, however, is in the dig commands you've posted there is no A or MX records for "mailserv.rci.ca" shown anywhere in the output - that's the problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Split DNS - Partly Working
    By Matt Mc in forum Installation
    Replies: 13
    Last Post: 01-23-2014, 06:38 AM
  2. Working with large .PST files ((split them))
    By joshuaneil in forum Migration
    Replies: 0
    Last Post: 12-20-2010, 01:02 PM
  3. Split DNS not working
    By Antonio Mercurio in forum Installation
    Replies: 10
    Last Post: 11-16-2010, 12:41 AM
  4. Split dns working, but Zimbra can't resolve MX
    By Mistoffeles in forum Installation
    Replies: 8
    Last Post: 09-14-2009, 10:53 AM
  5. split dns isn't working for me....
    By lucidblue in forum Installation
    Replies: 5
    Last Post: 06-02-2007, 10:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •