Results 1 to 3 of 3

Thread: After migration Zimbra mail server working fine - but giving error in every 5 mins

  1. #1
    Join Date
    May 2013
    Posts
    27
    Rep Power
    3

    Default After migration Zimbra mail server working fine - but giving error in every 5 mins

    Hi

    I had migrated my zcs 8.0.7 opensource to a new server I had followed the steps given in below URL
    https://blog.zimbra.com/blog/archive...er-server.html

    After migration it gave some few issues and all are solved and now server is working fine. But in every 5 mins I am getting below error in very 5 mins.

    Apr 25 15:27:24 ns1 zmconfigd[7291]: Fetching All configs
    Apr 25 15:27:24 ns1 zmconfigd[7291]: All configs fetched in 0.05 seconds
    Apr 25 15:27:24 ns1 zmconfigd[7291]: Exception in bin/zmamavisdctl: (Cannot run program "/opt/zimbra/bin/zmamavisdctl" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/zmclamdctl: (Cannot run program "/opt/zimbra/bin/zmclamdctl" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/ldap: (Cannot run program "/opt/zimbra/bin/ldap" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/zmloggerctl: (Cannot run program "/opt/zimbra/bin/zmloggerctl" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/zmstorectl: (Cannot run program "/opt/zimbra/bin/zmstorectl" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/zmmailboxdctl: (Cannot run program "/opt/zimbra/bin/zmmailboxdctl" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/zmmemcachedctl: (Cannot run program "/opt/zimbra/bin/zmmemcachedctl" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/zmmtactl: (Cannot run program "/opt/zimbra/bin/zmmtactl" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/zmopendkimctl: (Cannot run program "/opt/zimbra/bin/zmopendkimctl" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/zmproxyctl: (Cannot run program "/opt/zimbra/bin/zmproxyctl" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/zmsaslauthdctl: (Cannot run program "/opt/zimbra/bin/zmsaslauthdctl" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/zmswatchctl: (Cannot run program "/opt/zimbra/bin/zmswatchctl" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/zmspellctl: (Cannot run program "/opt/zimbra/bin/zmspellctl" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/zmstatctl: (Cannot run program "/opt/zimbra/bin/zmstatctl" (in directory "/root"): error=13, Permission denied)
    Apr 25 15:27:25 ns1 zmconfigd[7291]: Exception in bin/zmclamdctl: (Cannot run program "/opt/zimbra/bin/zmclamdctl" (in directory "/root"): error=13, Permission denied)

    I had run zmfixperms it didn't solve the issues.

    Regards
    Vivek

  2. #2
    Join Date
    Aug 2012
    Posts
    110
    Rep Power
    4

    Default

    Hi,

    I just posted an answer for someone else with similar problem. Please, follow these steps. I saw you already ran fixmperms, but, please, do it this way and post your results.

    As "root" user:

    1) su - zimbra -c 'zmcontrol stop'
    2) /opt/zimbra/libexec/zmfixperms -v -e
    3) su - zimbra -c 'zmcontrol start'

    Regards,
    Sebas

  3. #3
    Join Date
    May 2013
    Posts
    27
    Rep Power
    3

    Default

    Hi Sebas

    Thank you very much I had fixed the issue, I had run zmfixperms --verbose --extended many times and got same errors.
    And I had tried like this. My backup of old server still reside in /root so I removed this backup and run the command zmfixperms --verbose --extended and it got solved.

    But now my question is, how the presence of backup in /root gave me this error "Cannot run program "/opt/zimbra/bin/zmamavisdctl" (in directory "/root"): error=13, Permission denied".

    Also when ever I restart the Zimbra I am getting these errors

    [zimbra@ns1 root]$ zmcontrol start
    Use of uninitialized value $current_proto in string eq at /usr/lib64/perl5/Sys/Syslog.pm line 371.
    Use of uninitialized value $current_proto in string eq at /usr/lib64/perl5/Sys/Syslog.pm line 374.
    Host ns1.triventsys.com
    Starting ldap...Done.
    Starting zmconfigd...Done.
    Starting logger...Done.
    Starting mailbox...Done.
    Starting memcached...Done.
    Starting proxy...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting opendkim...Done.
    Starting snmp...Done.
    Starting spell...Done.
    Starting mta...Done.
    Starting stats...Done.

    Can anybody suggest any fix for this
    Last edited by cnvivek; 04-28-2014 at 06:35 AM.

Similar Threads

  1. Replies: 3
    Last Post: 07-11-2013, 08:00 AM
  2. Replies: 0
    Last Post: 09-17-2012, 03:01 PM
  3. Replies: 4
    Last Post: 06-03-2011, 04:19 AM
  4. Replies: 0
    Last Post: 01-17-2011, 10:45 AM
  5. Replies: 0
    Last Post: 01-17-2011, 10:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •