Results 1 to 7 of 7

Thread: send email via cli

  1. #1
    Join Date
    Mar 2006
    Posts
    67
    Rep Power
    9

    Default send email via cli

    on linux I usually send cron messages with:

    echo "text"|mail -s "message subject"

    This doesn't work with zimbra as mta, etc...

    how can I do this with zimbra on linux?

    thx...

  2. #2
    Join Date
    Nov 2005
    Posts
    108
    Rep Power
    9

    Default

    I'm able to do this on CentOS by addressing the email to a valid zimbra user's address.

    Code:
    echo "text"|mail -s "message subject" username@domain.com
    rather than using just the unix username.

    Will that work for you?

    jimbo

  3. #3
    Join Date
    Mar 2006
    Posts
    67
    Rep Power
    9

    Default

    Quote Originally Posted by jimbo View Post
    I'm able to do this on CentOS by addressing the email to a valid zimbra user's address.

    Code:
    echo "text"|mail -s "message subject" username@domain.com
    rather than using just the unix username.

    Will that work for you?

    jimbo
    I've tried that on suse 10 - doesn't work.

  4. #4
    Join Date
    Mar 2008
    Posts
    9
    Rep Power
    7

    Default

    Did you solved this problem?

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    It works for me on openSUSE 11 & CentOS5.2, don't forget if you have openSUSE you'll need the postfix daemon running to send via the command given above. Is that what you're trying to do?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Mar 2008
    Posts
    9
    Rep Power
    7

    Default

    How postfix can be running if it conflicts with postfix from zimbra?

  7. #7
    Join Date
    Mar 2008
    Posts
    9
    Rep Power
    7

    Default

    btw, my zimbra running on CentOS 5

Similar Threads

  1. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  2. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 02:56 AM
  3. send *all* email through relay mta ?
    By keithop in forum Administrators
    Replies: 7
    Last Post: 07-24-2006, 02:27 AM
  4. cannot send email to sina/yahoo
    By koolokamba in forum Administrators
    Replies: 2
    Last Post: 06-20-2006, 08:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •