In the midst of a migration, and trying to set up a catchall for all of our domains.

I've put the list of domains (around 50) in a file called domain.txt, and then I'm running the following:

for each in `cat domain.txt`
echo $each
zmprov ma zimbraMailCatchAllAddress "@$each"

I've tried it both with and without the quotes around "@$each"

This doesn't not seem to take error or success message is given. I then try to run it manually from the command line, like:

zmprov ma zimbraMailCatchAllAddress

Still no output, and I'm still getting bounces from various address. The bounce I get is:

The following recipient(s) could not be reached: on 2/24/2007 9:40 AM
The e-mail account does not exist at the organization this message was sent to. Check the e-mail address, or contact the recipient directly to find out the correct address.
< #5.1.1 SMTP; 550 <>: Recipient address rejected:>

The is indeed added to the system...I can view it through the admin interface.

Am I missing something here?

Thanks guys!