I'm upgrading a current ZCS8.0.6/Ubu12LTS server to v8.0.7.

ZCS 8.0.7's release notes recommend, for Ubuntu 12LTS,

Ubuntu OS
If running Ubuntu 12.0.4.x and using kernal series 3.0 through 3.9, it is
suggested that you upgrade the kernal series to 3.11 for better write
The reference page


lists available stacks for Quantal, Raring, Saucy & Trusty.

Which, if any, is specifically recommended for stable operation with 8.0.7?