Results 1 to 4 of 4

Thread: DNS checks out, looked at the wiki but still cannot receive mail?!?!

  1. #1
    Join Date
    Mar 2007
    Rep Power

    Unhappy DNS checks out, looked at the wiki but still cannot receive mail?!?!

    Ive installed zimbra on an ubuntu server. Seems to work great but I cannot receive mail unless i turn off dns lookups in zimbra. Then, i can receive mail fine but cannot send.

    In looking at the zimbra wiki it states the steps to check your domain and server MX and A records with 'host -t mx' and 'host -t a'. We did these and additionally went to and everything looks perfect. Is there something else we can check to see whats going on?

    fyi in the zimbra admin console i can see the incoming emails being deferred because the connection is refused. Zimbra sits on the same physical box as the host the records are pointing to.

    I would greatly appreciate any help.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    It's difficult to tell what's causing the problem as you haven't posted any details. The words 'NAT router' & 'split-DNS' spring to mind as I don't have anything to go on, try searching the wiki. The fact you have to turn DNS lookups off/on is indicative that your DNS isn't correct.


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Mar 2007
    Rep Power


    Thanks Bill. I will try with the details...let me know what you need.

    If I leave dns enabled for the MTA I get this in the logs:

    postfix/lmtp[32010]: A76D32B4728: to=<>, relay=none, delay=0, status=deferred (connect to {my ip} [ { my ip }]: Connection refused)

    I have tried the wiki solution to change the zimbraMailTransport for this user. I have tried changing it to [myhost.mydomain]:7025 and [myexternalip]:7025 with no affect.

    I can telnet to both ports 25 and 7025. I just dont get it.

    If I disable dns them i can receive fine but cannot send ( makes sense ). Im wondering if I should setup local dns but that sounds odd. Why would I have to have a local dns to point the same server its sitting on????

    Any help would be appreciated.

  4. #4
    Join Date
    Sep 2005
    Rep Power


    Repeat your telnet test, but telnet to the IP that DNS resolves the address to - simply telnetting to the hostname will not force DNS resolution.
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 01:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 03:34 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 03:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts