Results 1 to 3 of 3

Thread: Configure Zimbra to only send mail using specific IP Address

  1. #1
    Join Date
    Jul 2013
    Location
    /dev/urandom
    Posts
    33
    Rep Power
    2

    Default Configure Zimbra to only send mail using specific IP Address

    Hi,

    Sorry to be a bit of a pest here, but I've got a curious problem.

    I'm trying to find an upgrade-friendly method of configuring Zimbra to listen/send using a specific IPv4 Address (While preserving IPv6 compatibility).

    The reasoning behind this is simple: We have two IP's for the server, and only wish for one to be used.

    One IP is the standard IP which is locked to the server, the other is a FailOver IP which can be switched between servers at-will.

    While the IP configuration is up and running without problem, we cannot get Zimbra to only use the FailOver IP (Two IP Addresses assigned to one interface).

    Here's what I've tried so far:

    Setting:
    Code:
    zmprov ms <Server Address> zimbraMailBindAddress "<Failover IP>"
    zmprov ms <Server Address> zimbraMailSSLBindAddress "<Failover IP>"
    zmprov ms <Server Address> zimbraMailSSLClientCertBindAddress "<Failover IP>"
    zmprov ms <Server Address> zimbraAdminBindAddress "<Failover IP>"
    zmprov ms <Server Address> zimbraPop3BindAddress "<Failover IP>"
    zmprov ms <Server Address> zimbraPop3SSLBindAddress "<Failover IP>"
    zmprov ms <Server Address> zimbraLmtpBindAddress "<Failover IP>"
    Doing the above does tell Zimbra to LISTEN on that IP, but it does not tell it to send using that IP.

    I've also tried editing the hosts file to specify the domain to an IP, but Zimbra simply ignores this.

    Lastly, I know of only one method which may/may not work and that is editing postfix's master.cf directly to tell it to use a specific IP Address.

    But this carries a couple of problems:
    1) It may confuse the rest of Zimbra
    2) It will get wiped upon Zimbra upgrade

    So any ideas on a method to get this done without breaking the upgrade-ability of Zimbra?

    I've searched for this on duckduckgo, but can't really find any results suggesting anything other than what I've already tried.

    (So don't tell me to Google it, I already did.)

    Kind Regards,
    Jake

  2. #2
    Join Date
    Jan 2007
    Location
    Austin, Tx
    Posts
    45
    Rep Power
    8

    Default

    You want to tell your server to use the failover IP as the primary for outbound traffic.

    It should be as simple as setting the failover IP as eth0 and the locked IP as the aliased eth0:0.

    If you can't do that then the best solutions(there are a few) are in the below article, using iptables or ip route:

    Brad

  3. #3
    Join Date
    Jul 2013
    Location
    /dev/urandom
    Posts
    33
    Rep Power
    2

    Default

    Hi,

    Thanks for you response.

    I really should of thought of that!

    But yes, I found the solution was to do the following:

    Failover IP moved to eth0 and standard to eth0:0

    Followed by: ip route change default via <gateway> dev eth0 src <Fail IP> metric 2

    This solved my issues :-).

    Kind Regards,
    Jake

Similar Threads

  1. Block mail to a specific external address
    By Koffie in forum Administrators
    Replies: 2
    Last Post: 01-29-2013, 07:35 AM
  2. Replies: 0
    Last Post: 02-29-2012, 11:47 PM
  3. Cannot send email to specific address
    By cosmin.batica in forum Administrators
    Replies: 2
    Last Post: 11-11-2010, 06:52 AM
  4. Replies: 5
    Last Post: 10-24-2010, 01:43 PM
  5. Forward mail that arrives from a specific mail address
    By get2guy in forum Administrators
    Replies: 2
    Last Post: 07-29-2010, 08:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •