Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Zimbra Admin email no longer being sent?

Hybrid View

  1. #1
    Join Date
    Aug 2006
    Location
    Belgrade, Montana
    Posts
    16
    Rep Power
    9

    Default Zimbra Admin email no longer being sent?

    I upgraded to zcs-4.5.3_GA_733.RHEL4.tgz Open Source Edition from the 4.5.1 release... and I don't know if it is a coincidence or what, but I have no longer been getting the zimbra Daily mail report.

    How to fix this?

  2. #2
    Join Date
    Mar 2006
    Posts
    86
    Rep Power
    9

    Default

    We have the same issue. Just checked the cron tab and see:

    # Daily reports
    #
    10 1 * * * /opt/zimbra/libexec/zmdailyreport -m
    # ZIMBRAEND -- DO NOT EDIT ANYTHING BETWEEN THIS LINE AND ZIMBRASTART


    is it just supposed to be a zmdailyreport -m ? IT used to have recipients

  3. #3
    Join Date
    Feb 2006
    Posts
    47
    Rep Power
    9

    Default

    I run three systems with Zimbra.

    I'm no longer receiving the daily admin summary email on two systems which I have recently upgraded to 4.5.2 and 4.5.3.

    The other system is still on 4.5.0 and is still sending the daily admin summary email - the cron file for the zimbra user on this system contains:

    /opt/zimbra/libexec/zmdailyreport | /opt/zimbra/postfix/sbin/sendmail root

    Running this full command line (as the zimbra user) on the 4.5.3 NE system and the 4.5.2 OS system sends the email but with an empty subject line. Adding the -m option, results in an empty email.

    Running /opt/zimbra/libexec/zmdailyreport on the 4.5.0 without the pipe to sendmail shows that the command generates the email headers as the first few lines - eg:

    From: zimbra@zcs.xyz.com
    Subject: Daily mail report from 2007-03-07 00:00:00 to 2007-03-08 00:00:00
    Generating report
    From 2007-03-07 00:00:00 to 2007-03-08 00:00:00

    On the 4.5.2 and 4.5.3 systems, the first line of the output is the "Generating report..."; ie: iit doesn't generate the From: and Subject: headers.

    Rgds - Angus

  4. #4
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    Daily reports are now delivered into the zimbra system, as opposed to system root account. Currently the system is delivering reports to the account defined by the localconfig smtp_destination. Typically this is set to the admin account.

    Code:
    zmlocalconfig smtp_destination
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    Join Date
    Mar 2006
    Posts
    86
    Rep Power
    9

    Default

    On a 4.5.3 NE system, the smtp_* fields that the zmdailyreport script looks for are not set:

    [zimbra@mrmailman ~]$ zmlocalconfig | grep smtp
    postfix_smtpd_client_restrictions = reject_unauth_pipelining
    postfix_smtpd_data_restrictions = reject_unauth_pipelining
    postfix_smtpd_helo_required = yes
    postfix_smtpd_tls_cert_file = ${zimbra_home}/conf/smtpd.crt
    postfix_smtpd_tls_key_file = ${zimbra_home}/conf/smtpd.key
    postfix_smtpd_tls_loglevel = 1

    We of course have a multi-server system with:
    1 mailstore/webmail/master LDAP
    2 MTA/LDAP replicas/AS/AV

    The above was on the mailstore, which is also where the crontab generating the daily report is.

  6. #6
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    I just took a look at the installer and this appears to be a bug. I filed bug 15295 to track this. In the meantime you can add smtp_source and smtp_destination localconfig variables pointing at which ever account you want to receive the notifications.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  7. #7
    Join Date
    Feb 2009
    Posts
    8
    Rep Power
    6

    Default

    Hey there,

    I didn't want to start a new thread so through it best to carry on with this one... If i may

    I've noted that a daily mail report is not coming though to my admin@domain.com account. Absolutely no settings have changed on the server however if i run the command '' /opt/zimbra/libexec/zmdailyreport -m '' i can get a manual email sent out to the admin account.

    how would i get this process automated again so i can keep an eye on the daily reports...?

    any help would be super appreciated [ just getting the hang on zimbra admin]

    Thank you

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Make sure all the ZCS cron entries are still in place
    Code:
    su - zimbra
    zmcontrol -v
    crontab -l

  9. #9
    Join Date
    Feb 2009
    Posts
    8
    Rep Power
    6

    Default

    Release 5.0.9_GA_2533.RHEL5_64_20080815094512 CentOS5_64 FOSS edition

    [zimbra@fyodor root]$ crontab -l
    # ZIMBRASTART -- DO NOT EDIT ANYTHING BETWEEN THIS LINE AND ZIMBRAEND
    #
    # Log pruning
    #
    30 2 * * * find /opt/zimbra/log/ -type f -name \*.log\* -mtime +8 -exec rm {} \; > /dev/null 2>&1
    #
    # Status logging
    #
    */2 * * * * /opt/zimbra/libexec/zmstatuslog
    */10 * * * * /opt/zimbra/libexec/zmdisklog
    #
    # Backups
    #
    # BACKUP BEGIN
    # BACKUP END
    #
    # crontab.ldap
    #
    #
    #
    # crontab.store
    #
    # Log pruning
    #
    30 2 * * * find /opt/zimbra/mailboxd/logs/ -type f -name \*log\* -mtime +8 -exec rm {} \; > /dev/null 2>&1
    #
    # Table maintenance
    #
    30 1 * * 7 /opt/zimbra/libexec/zmmaintaintables >> /dev/null 2>&1
    #
    # Report on any database inconsistencies
    #
    0 23 * * 7 /opt/zimbra/libexec/zmdbintegrityreport -m
    #
    # Monitor for multiple mysqld to prevent corruption
    #
    */5 * * * * /opt/zimbra/libexec/zmcheckduplicatemysqld -e > /dev/null 2>&1

    #
    # crontab.logger
    #
    # process logs
    #
    00,10,20,30,40,50 * * * * /opt/zimbra/libexec/zmlogprocess > /tmp/logprocess.out 2>&1
    #
    # Graph generation
    #
    10 * * * * /opt/zimbra/libexec/zmgengraphs >> /tmp/gengraphs.out 2>&1
    #
    # Daily reports
    #
    10 1 * * * /opt/zimbra/libexec/zmdailyreport -m
    #
    # crontab.mta
    #
    #
    # Queue logging
    #
    0,10,20,30,40,50 * * * * /opt/zimbra/libexec/zmqueuelog
    #
    # Spam training
    #
    0 23 * * * /opt/zimbra/bin/zmtrainsa >> /opt/zimbra/log/spamtrain.log 2>&1
    #
    # Spam training cleanup
    #
    45 23 * * * /opt/zimbra/bin/zmtrainsa --cleanup >> /opt/zimbra/log/spamtrain.log 2>&1
    #
    # Dspam cleanup
    #
    #0 1 * * * find /opt/zimbra/dspam/var/dspam/data/z/i/zimbra/zimbra.sig/ -type f -name \*sig -mtime +7 -exec rm {} \; > /dev/null 2>&1
    #8 4 * * * /opt/zimbra/dspam/bin/dspam_logrotate -a 60 /opt/zimbra/dspam/var/dspam/system.log
    #8 8 * * * /opt/zimbra/dspam/bin/dspam_logrotate -a 60 /opt/zimbra/dspam/var/dspam/data/z/i/zimbra/zimbra.log
    #
    # Spam Bayes auto-expiry
    #
    20 23 * * * /opt/zimbra/libexec/sa-learn -p /opt/zimbra/conf/salocal.cf --dbpath /opt/zimbra/data/amavisd/.spamassassin --siteconfigpath /opt/zimbra/conf/spamassassin --force-expire --sync > /dev/null 2>&1
    #
    # Clean up amavisd/tmp
    #
    15 5,20 * * * find /opt/zimbra/data/amavisd/tmp -maxdepth 1 -type d -name 'amavis-*' -mtime +1 -exec rm -rf {} \; > /dev/null 2>&1
    #
    # Clean up the quarantine dir
    #
    0 1 * * * find /opt/zimbra/data/amavisd/quarantine -type f -mtime +7 -exec rm -f {} \; > /dev/null 2>&1

    # ZIMBRAEND -- DO NOT EDIT ANYTHING BETWEEN THIS LINE AND ZIMBRASTART
    [zimbra@fyodor root]$



    these are the results i got back... looks like the cron entry for daily reports is in there....

  10. #10
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Try restarting the cron daemon.

Similar Threads

  1. Replies: 26
    Last Post: 04-19-2011, 10:24 AM
  2. upgrade woes -made into new thread
    By JustinHarlow in forum Installation
    Replies: 18
    Last Post: 06-08-2007, 01:11 PM
  3. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 03:30 PM
  4. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 10:19 AM
  5. Logger
    By jholder in forum Installation
    Replies: 24
    Last Post: 03-31-2006, 11:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •