Results 1 to 2 of 2

Thread: Removing LDAP

  1. #1
    Join Date
    Jul 2014
    Posts
    1
    Rep Power
    1

    Exclamation Removing LDAP

    Hello everyone, apologies for any noise but I tried figuring something out before posting and failed.

    I inherited a Zimbra 7.0.2 server which had LDAP installed where LDAP was nowhere in the network. Now whenever Zimbra tried to start, I am getting BIND issues. I do not want to configure Split DNS to resolve this issue, because again, I am not using LDAP. Zimbra won't start, because of the BIND failure.

    /etc/init.d/zimbra restart

    Gets to:

    Failed to start slapd
    BIND errno=99

    Goes no further. Is there any CLI syntax as any user (zimbra, root, etc) I can use to remove the LDAP components?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    This is posted in the wrong forum, I'll move it to trhe correct one.

    Quote Originally Posted by zimnewb View Post
    Hello everyone, apologies for any noise but I tried figuring something out before posting and failed.
    What you need to do first is post the exact version of ZCS that's in use by running the following command and posting the output (yes, I've already seen the version you've listed):

    Code:
    zmcontrol -v
    Quote Originally Posted by zimnewb View Post
    I inherited a Zimbra 7.0.2 server which had LDAP installed where LDAP was nowhere in the network. Now whenever Zimbra tried to start, I am getting BIND issues. I do not want to configure Split DNS to resolve this issue, because again, I am not using LDAP. Zimbra won't start, because of the BIND failure.

    /etc/init.d/zimbra restart

    Gets to:

    Failed to start slapd
    BIND errno=99
    What you also need to do, in future, is post the actual error messages from the log file not some cropped out-of-context message but the actual entries from a period before and after the error.

    The command you need to use to start ZCS is:

    Code:
    su - zimbra
    zmcontrol restart
    That will give you more information on what ZCS is doing during start-up and/or you can also tail the log file to see what's happening.

    Quote Originally Posted by zimnewb View Post
    Goes no further. Is there any CLI syntax as any user (zimbra, root, etc) I can use to remove the LDAP components?
    You can't remove LDAP from the Zimbra Server it's a vital internal component.

    This isn't a problem with LDAP, this is possibly caused by some change you've made to the server, take a look at these forum threads and solutions and see if they address your problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Replies: 5
    Last Post: 05-04-2012, 11:04 AM
  2. Removing convertd mime tree from ldap...failed.
    By YetiRick in forum Administrators
    Replies: 0
    Last Post: 03-22-2011, 12:57 AM
  3. Removing convertd mime tree from ldap...failed.
    By YetiRick in forum Installation
    Replies: 0
    Last Post: 03-22-2011, 12:57 AM
  4. Removing posixAccount from LDAP
    By Cheakamus in forum Administrators
    Replies: 0
    Last Post: 10-31-2008, 12:04 PM
  5. Removing SMTP from LDAP
    By jorge in forum Administrators
    Replies: 1
    Last Post: 08-16-2007, 09:05 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •