Results 1 to 6 of 6

Thread: Upgrading from 4.0.0_GA_303 to 4.5.3_GA_733

  1. #1
    Join Date
    Sep 2006
    Posts
    14
    Rep Power
    9

    Default Upgrading from 4.0.0_GA_303 to 4.5.3_GA_733

    I'm doing upgrade from 4.0.0_GA_303 to 4.5.3_GA_733 and it fails with the following error




    Wed Mar 7 22:31:01 2007: Verified schema version 31.
    Wed Mar 7 22:31:01 2007: Updating DB schema version from 31 to 32.
    Wed Mar 7 22:31:02 2007: Running /opt/zimbra/libexec/scripts/migrate20061204-CreatePop3MessageTable.pl
    Wed Mar 7 22:31:04 2007: Verified schema version 32.
    Wed Mar 7 22:31:29 2007: Verified schema version 32.
    Wed Mar 7 22:31:29 2007: Updating DB schema version from 32 to 33.
    Wed Mar 7 22:31:29 2007: Running /opt/zimbra/libexec/scripts/migrate20061205-UniqueAppointmentIndex.pl
    Wed Mar 7 22:31:32 2007: Verified schema version 33.
    Wed Mar 7 22:31:33 2007: Creating unique index on mboxgroup1.appointment
    Wed Mar 7 22:31:35 2007: Creating unique index on mboxgroup10.appointment
    Wed Mar 7 22:31:36 2007: Creating unique index on mboxgroup11.appointment
    Wed Mar 7 22:31:38 2007: Creating unique index on mboxgroup12.appointment
    ERROR 1005 (HY000) at line 2: Can't create table './mboxgroup12/#sql-129c_c3.frm' (errno: 150)
    Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=1leIgKfh6sQECp7T1r9RjbTuPC --database=zimbra --batch --skip-column-names'. at /opt/zimbra/libexec/scripts/Migrate.pm line 220, <OUTPUT> line 33.
    Wed Mar 7 22:31:39 2007: Script failed with code 1 - exiting
    UPGRADE FAILED - exiting

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Hi Nick,
    Please see this post:
    http://www.zimbra.com/forums/showpos...17&postcount=9

    john

  3. #3
    Join Date
    Sep 2006
    Posts
    14
    Rep Power
    9

    Default

    John, thanks for quick response, I've done this edit now should I just restart the install process i.e. install.sh

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Umm, if you have a backup, I'd say go to that.
    If you don't, shame on you

    -john

  5. #5
    Join Date
    Sep 2006
    Posts
    14
    Rep Power
    9

    Default

    John, many thanks have got it to work, could not those get it to work using suggested edit to zimbra/conf/my.cnf
    innodb_buffer_pool_size = 1992294400

    had to use:

    innodb_buffer_pool_size = 348444057

    Thanks Nick

  6. #6
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Welcome to Zimbra.

    Please let us know if you need anything else.

    Enjoy!
    -john

Similar Threads

  1. Replies: 6
    Last Post: 02-26-2007, 03:53 AM
  2. Upgrading to zcs-4.5.1_GA_660.UBUNTU6.tgz failed.
    By eombah in forum Installation
    Replies: 3
    Last Post: 02-08-2007, 10:06 AM
  3. Problem Upgrading from 4.0.1 to 4.0.x
    By shankwc in forum Installation
    Replies: 14
    Last Post: 11-19-2006, 08:18 PM
  4. Error when upgrading from 3.1 -> 3.1.1
    By jeg1972 in forum Installation
    Replies: 2
    Last Post: 05-10-2006, 07:10 AM
  5. Replies: 4
    Last Post: 04-26-2006, 11:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •