I upgrade to 4.5.3 last night which went ok I did this so I could use the Tusted Network. I entered a specific address which stopped me sending mail from the webclient using an email client it was fine. Then tried this stop postfix send mail completely, if you telnet'd to port 25 it did not come with a 220 message and just disconnected after a while.

I then clear the Trusted Network field and save again( from global mta config), this produced the following in zmmtaconfig:
DO: /opt/zimbra/postfix/sbin/postconf -e content_filter=''
DO: /opt/zimbra/postfix/sbin/postconf -e content_filter='smtp-amavis:[]:10024'
DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_use_tls='yes'
DO: /opt/zimbra/postfix/sbin/postconf -e mailbox_size_limit='0'
DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_reject_unlisted_recipient='no'

I then had a look in /opt/zimbra/postfix/conf/main.cf which still had the entry mynetworks =
which I deleted and restarted the service and everything looks ok.

In the mailbox.log you got the following error when I first had a specific address in the trusted network field:

Caused by: javax.mail.SendFailedException: Invalid Addresses;
nested exception is:
com.sun.mail.smtp.SMTPAddressFailedException: 554 <nickteagle@gmail.com>: Relay access denied

at com.sun.mail.smtp.SMTPTransport.rcptTo(SMTPTranspo rt.java:1196)
at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTr ansport.java:584)
at javax.mail.Transport.send0(Transport.java:169)
at javax.mail.Transport.send(Transport.java:98)
at com.zimbra.cs.mailbox.MailSender.sendMessage(MailS ender.java:368)
at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:248)