Results 1 to 10 of 10

Thread: Daylight Savings Time

  1. #1
    Join Date
    Nov 2006
    Posts
    25
    Rep Power
    9

    Default Daylight Savings Time

    March 11th is now here and I'm seeing all calendar appointments one hour ahead of the correct time. All devices have been patched, mac, win xp, WM5 and blackberry. Anyone else seeing this problem? Anyone have a fix?

    If I turn off "automatically adjust DST" in XP it works, but I don't have a work around for the mac or mobile devices.

    Keith

  2. #2
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    There is a DST bug in the version of java that comes with zimbra. You can download patches from Sun, or wait for zimbra to release patch.

  3. #3
    Join Date
    Nov 2006
    Posts
    25
    Rep Power
    9

    Default

    I've just discovered a clue to this problem. I think Zimbra has messed up the GMT-4 AST time zone again! When I change any device to a different GMT-4 such as LaPaz and move the clock ahead an hour, the calendar time displays correctly.

    I'll give the java update a try because I don't want to have to deal with clients tomorrow morning.

    Any tips on how I should proceed with the java fix?

  4. #4
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    It's not zimbra's fault, this is a mistake by Sun related to TLA handling (that is timezones with Three Letter Acronyms). This code should trip the problem if you're vulnerable:

    import java.text.*;
    import java.util.*;
    public class DSTest {
    public static void main(String[] args) throws Exception
    { SimpleDateFormat timestampFormatWithZone = new SimpleDateFormat("yyyy-MM-dd HH:mm zzz");
    Date date = timestampFormatWithZone.parse("2007-06-06 14:00 EDT"); // The problem is here
    //Calendar calendar = timestampFormatWithZone.getCalendar();
    System.out.println(date);
    }
    }

    There's a compiled version attached to this post. Copy it somewhere on your zimbra server, and from the same directory, run:

    /opt/zimbra/java/bin/java -Duser.timezone=America/Los_Angeles DSTest

    If it returns 12pm, you need patching, if it returns 11am you're OK. Unpatched zimbra returns 12pm.

    To patch, download the tzupdater.jar file attached to this post. Run it:

    willow:~/tzupdater-1.1.0-2007c# /opt/zimbra/java/bin/java -jar tzupdater.jar -f -bc -v
    java.home: /opt/zimbra/jdk1.5.0_08/jre
    java.vendor: Sun Microsystems Inc.
    java.version: 1.5.0_08
    JRE time zone data version: tzdata2006d
    Embedded time zone data version: tzdata2007c
    Extracting files... done.
    Making changes for JDK 1.1 compatibiltiy... done.
    Renaming directories... done.
    Validating the new time zone data... done.
    Time zone data update is complete.

    run the test to make sure:
    willow:~/tzupdater-1.1.0-2007c# /opt/zimbra/java/bin/java -jar tzupdater.jar -t -v
    java.home: /opt/zimbra/jdk1.5.0_08/jre
    java.vendor: Sun Microsystems Inc.
    java.version: 1.5.0_08
    JRE time zone data version: tzdata2007c
    Embedded time zone data version: tzdata2007c
    Validating the time zone data
    Validation complete

    and if you run the DSTest.class test again it should show 11am.
    Attached Files Attached Files

  5. #5
    Join Date
    Nov 2006
    Posts
    25
    Rep Power
    9

    Default

    I applied the java patch but it didn't solve the problem. It will display correctly in winXP if "auto adjust dst" is turned off using gmt-4 AST.

    Thanks for the suggestion.

    Keith

  6. #6
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    Did you fully restart zimbra? Java needs to be completely shut down to dump zi cache. Make sure you clear out your browser cache and try with new, rather than existing appointments, as well.
    Last edited by dijichi2; 03-11-2007 at 10:13 AM.

  7. #7
    Join Date
    Nov 2006
    Posts
    25
    Rep Power
    9

    Default

    Yes, I actually did a server reboot. I've cleared the cache in Firefox, newly created appointments seem to be fine, although moving existing ones around produced erratic results. I have one appointment set for today that is two hours off from the detailed view.

  8. #8
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    I'm seeing some similar problems, but it is kind of hit and miss. I applied the Java fix, but it didn't fix the Zimbra issues I am seeing. Most of my appointments looked OK. However, I had one weekly appointment scheduled for 1:30 to 2:30. When I looked at my calendar it was showing up with a 2:30 starting time. This might be related to the "missing 2" problem (see bug 15284 and this thread - http://www.zimbra.com/forums/showthread.php?t=7544). When I opened the "series" event and did nothing but save it, the appointment was fixed, but hopefully I (and other users) don't have to do this for many events.

  9. #9
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    okie dokie, looks like zimbra may still have some issues as well. at least I hope so and it's not some as yet undiscovered bug in java or i'm in for a world of pain on monday at work!!

  10. #10
    Join Date
    Mar 2008
    Posts
    1
    Rep Power
    7

    Default

    For those of you that have also encountered this problem and stumbled into this thread, here is the solution that worked for me:

    The PCs affrected with this DTS problem had an environment variable called "TZ" set to the wrong value. In our case this variable was no longer used on the affected machines so we simply deleted the entry and restarted the browser. The problem then disappeared. Here is how you do it:

    --Right click on the "My Computer" icon. This will open the "System Properties" window.
    --Select the tab for "Advanced" in the "System Properties" window.
    --Click on the button for " Environmental Variables"
    --Scroll down the list of variables until you reach the entry for "TZ" (time zone).
    --Either correct or delete this entry and close all windows.
    --Restart your web browser and the problem is gone.

    Good luck,

    fes@laika.com

Similar Threads

  1. Time mess everything up
    By Peque in forum Zimbra Connector for Outlook
    Replies: 4
    Last Post: 05-10-2007, 03:31 AM
  2. Replies: 4
    Last Post: 03-21-2007, 06:47 PM
  3. Replies: 6
    Last Post: 01-26-2007, 11:00 AM
  4. Replies: 5
    Last Post: 01-19-2007, 12:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •