Results 1 to 3 of 3

Thread: Resetting the version number

  1. #1
    Join Date
    Dec 2006
    Posts
    5
    Rep Power
    8

    Default Resetting the version number

    We are running Zimbra on Fedora Core 6 for our 5 person office. We've been using it since January and everyone has been very happy with Zimbra.

    This weekend I went to upgrade from the zcs-4.0.4_GA_457.FC5.tgz version that we were running to the current zcs-4.5.3_GA_733.FC5.tgz version.

    I backed up /opt/zimbra, ran the install.sh for the new version and wallah, I had the new version up and going in about 10 min.

    I should have stopped there :-)

    Then I ran updates on the server and when the updates were finished, Zimbra wouldn't run at all any longer... I assumed that the update had overwritten some package with a bad version, so I reinstalled 4.5.3, no joy.

    I reverted to my backup by copying it back to /opt/zimbra and rebooting... That mostly worked but some perms and ownerships were wrong, so looked this up here in the forums and tried reinstalling the original version as an upgrade on top of the backup (not sure if should have just tried zmfixperms). That fixed everything and we are back up, but the install failed when it said that I was already on ver 4.5.3 and that I could not do an upgrade of 4.0.4 over that.

    Do I do the 4.0 .4 install over again, or is there another way to reset the reported version to the right one so I can try the 4.5 upgrade again? Or is that not an issue and shold i just go to 4.5.3?

    Also, does anyone know when FC6 will be supported?

    Thanks!
    Steve

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Ick,
    So you've got the system thinking it has 4.5.3 RPMS, when you have 4.0 RPMS?
    That sounds like a problem waiting to explode.

    You'd be better to follow the wiki instructions.
    FC6 will be out as soon as we can test it, and make sure things work.

  3. #3
    Join Date
    Dec 2006
    Posts
    5
    Rep Power
    8

    Default

    Yup, ick...

    I went to the wiki and that was where I found the info about doing a second reinstall of the same version over the top of the current one.

    From the wiki:

    http://wiki.zimbra.com/index.php?tit...dure#Restoring

    "This will create a folder in the directory named "zcs", cd to it and run the install script...

    The script will remove the existing packages, and install them again. The script will attempt to stop Zimbra Services and "UPGRADE FAILED - exiting". This is okay, simply rerun the script, and it will install normally."

    My question is whether this should fix the reported version issue...

    Thanks again,

    Steve

Similar Threads

  1. Replies: 3
    Last Post: 08-01-2007, 03:07 PM
  2. How to manually change version number
    By shankwc in forum Installation
    Replies: 4
    Last Post: 07-29-2007, 08:02 PM
  3. Toaster Problem
    By jdell in forum Users
    Replies: 8
    Last Post: 03-08-2007, 03:03 AM
  4. Upgrading from 3.1.4_GA_518 to 4.0.3_GA_406
    By a2mc in forum Installation
    Replies: 6
    Last Post: 11-13-2006, 11:52 AM
  5. Bayes filter import bug
    By jwilso2 in forum Developers
    Replies: 4
    Last Post: 11-03-2005, 08:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •