Results 1 to 5 of 5

Thread: Received mail bounced

Hybrid View

  1. #1
    Join Date
    Oct 2005
    Posts
    8
    Rep Power
    10

    Angry Received mail bounced

    I've sent my first email to my new Zimbra mta. But unfortunately it bounced. zimbra.log reports:

    status=bounced (Host or domain name not found. Name service error for name=localhost.localdomain type=A: Host not found)

    But my /etc/hosts certainly has the line

    127.0.0.1 localhost.localdomain localhost

    (as the first line of two - the second has my 'real' host name and ip address)

    Note that I added an entry for the domain in the admin console and I added a user for that domain as well. I sent an email to that user. Also note that the name of the host is not the same as the name of the domain - this host is to handle mail for the domain.

    Can anyone tell me 1) why it bounced and 2) how to fix it so that the mail gets delivered to the user?

    Peter

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default Dns

    Disabling DNS lookups in the admin UI and restarting postfix should fix this.

    The problem is that postfix doesn't look at your hosts file, unless you force it to. Otherwise, it prefers DNS

  3. #3
    Join Date
    Oct 2005
    Posts
    8
    Rep Power
    10

    Smile

    Thank you - that appears to have fixed the local delivery problem. I don't understand it though. My /etc/host.conf says order hosts,bind which means that if zimbra uses the resolver library I would expect that localhost.localdomain would be found in hosts before a DNS lookup was done. Do they do something else?

    Peter

  4. #4
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default

    Quote Originally Posted by pheitman
    My /etc/host.conf says order hosts,bind which means that if zimbra uses the resolver library I would expect that localhost.localdomain would be found in hosts before a DNS lookup was done.
    Postfix looks in DNS, regardless of what your nsswitch.conf says, unless this variable is set:
    http://www.postfix.org/postconf.5.ht...le_dns_lookups

  5. #5
    Join Date
    Oct 2005
    Posts
    8
    Rep Power
    10

    Default

    Thanks for the pointer - I never knew that. I've configured postfix, but the tutorial I followed also set up amavis as part of the delivery route. The configuration for the amavis-smtp process also disabled the dns lookups. I never looked closely enough at what I was doing to see it.

    Learn something new every day

    Peter

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 02:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 09:09 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 04:34 PM
  5. Mail not getting to mail boxes
    By ehults in forum Installation
    Replies: 5
    Last Post: 10-31-2005, 09:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •