Results 1 to 2 of 2

Thread: Lost Messages Moving from POP3 to IMAP in Mail.app

Hybrid View

  1. #1
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default Lost Messages Moving from POP3 to IMAP in Mail.app

    I've got a Mac Mail.app users that I'm trying to move over to Zimbra. Her existing account was a POP3 account. I setup the Zimbra server as an IMAP account. We were trying to move her saved email from the POP3 folders to the Zimbra IMAP folders and we've run into an issue. It seems as if within Mail.app if you drag-and-drop a whole folder of messages it does a copy, but if you DND individual messages it does a move. Well, the user tried copying a whole folder, but Mail.app crashed in the middle of the process. She opened Mail back up, and everything was still there. She saw that only about a third of her message made it to the Zimbra server (65 of 180+). So she found the 120+ messages that weren't on the Zimbra server and tried to drag them over to the Zimbra, but only three more messages were copied over. Unfortunately, for some reason Mail.app considered the operation complete and apparently permanently deleted the message locally. Has anyone seen this before? I think it is partially a Mail.app problem and partially a Zimbra problem. Should I file a bug?

    I found the following in the Zimbra mailbox.log file, which I believe is related to the problem:
    Code:
    2007-03-23 11:30:25,173 INFO  [ImapServer-573] [] ProtocolHandler - Exception oc
    curred while handling connection
    java.net.SocketException: Connection reset
            at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:96)
            at java.net.SocketOutputStream.write(SocketOutputStream.java:136)
            at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:65
    )
            at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:123)
            at com.zimbra.cs.imap.ImapHandler.sendLine(ImapHandler.java:2072)
            at com.zimbra.cs.imap.ImapHandler.sendResponse(ImapHandler.java:2062)
            at com.zimbra.cs.imap.ImapHandler.sendBAD(ImapHandler.java:2049)
            at com.zimbra.cs.imap.ImapHandler.processCommand(ImapHandler.java:265)
            at com.zimbra.cs.tcpserver.ProtocolHandler.processConnection(ProtocolHan
    dler.java:231)
            at com.zimbra.cs.tcpserver.ProtocolHandler.run(ProtocolHandler.java:198)
            at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(Unknown So
    urce)
            at java.lang.Thread.run(Thread.java:595)
    2007-03-23 11:30:25,173 INFO  [ImapServer-573] [] imap - [129.100.202.6] excepti
    on while closing connection
    java.net.SocketException: Broken pipe
            at java.net.SocketOutputStream.socketWrite0(Native Method)
            at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:92)
            at java.net.SocketOutputStream.write(SocketOutputStream.java:136)
            at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:65
    )
            at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:123)
            at com.zimbra.cs.imap.ImapHandler.sendLine(ImapHandler.java:2072)
            at com.zimbra.cs.imap.ImapHandler.sendResponse(ImapHandler.java:2062)
            at com.zimbra.cs.imap.ImapHandler.sendUntagged(ImapHandler.java:2051)
            at com.zimbra.cs.imap.ImapHandler.dropConnection(ImapHandler.java:2021)
            at com.zimbra.cs.imap.ImapHandler.dropConnection(ImapHandler.java:2007)
            at com.zimbra.cs.tcpserver.ProtocolHandler.run(ProtocolHandler.java:210)
            at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(Unknown So
    urce)
            at java.lang.Thread.run(Thread.java:595)
    2007-03-23 11:30:25,173 INFO  [ImapServer-573] [] ProtocolHandler - Handler exit
    ing normally
    2007-03-23 11:30:25,180 INFO  [ImapServer-575] [] imap - [129.100.202.6] connect
    ed
    2007-03-23 11:30:25,212 INFO  [ImapServer-576] [] imap - [129.100.202.6] connect
    ed

  2. #2
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default Update

    Well, I still think there is a potential issue with the copy process from folder to folder using Mail.app, but I'm happy to report that the lost messages have been found. After a couple of hours of searching around the Mac for the messages, the user went to lunch and when she came back they had "magically" reappeared. I'm not a Mac guy, but this seems pretty strange to me. Oh, well, at least the user is happy.

Similar Threads

  1. Replies: 3
    Last Post: 07-19-2007, 02:00 AM
  2. SMTP SSL Problem
    By nexus in forum Installation
    Replies: 8
    Last Post: 03-15-2007, 07:26 AM
  3. Empty Messages breaking 3rd party IMAP clients
    By ronnyek in forum Administrators
    Replies: 0
    Last Post: 01-24-2007, 08:20 AM
  4. Spam assassain not traiing properly!
    By Mike T in forum Administrators
    Replies: 1
    Last Post: 10-09-2006, 01:34 PM
  5. inbox got wiped overnight (lost messages)
    By tachijuan in forum Administrators
    Replies: 3
    Last Post: 09-07-2006, 09:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •