Results 1 to 8 of 8

Thread: Urgent help required from the community please

  1. #1
    Join Date
    Sep 2006
    Location
    Space station 101
    Posts
    182
    Rep Power
    9

    Exclamation Urgent help required from the community please

    Hello to all,

    I have been running zimbra for approximately six months now.

    I am using the CentOS 4.4 Linux platform (RHEL4 clone).

    Whilst I was in Florida between 2nd - 18th March (and previous to that) there were no problems.

    Since my return Zimbra shuts down intermittently.

    I have no idea what the cause might be.

    A) Can anyone advise what I should be looking for in which particular logs as to which service is failing and the reason why?

    B) What I can do to stop this happening?

    At present I just login as user zimbra and run zmcontrol stop;zmcontrol start, which brings all services back up online.

    Please reply as soon as you can anyone - I am very worried about this as I am just about to sign a new client and dont want them seeing these issues. Not to mention my current clients on my back every day.

    Look forward to your replies

    Costa
    ------------------------------
    http://www.lcrm.co.uk

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Quote Originally Posted by Costa-101 View Post
    A) Can anyone advise what I should be looking for in which particular logs as to which service is failing and the reason why?
    What do you mean by stops. Does EVERYTHING stop, or just one component?
    Take a look at /opt/zimbra/log/mailbox.log

    Quote Originally Posted by Costa-101 View Post
    B) What I can do to stop this happening?
    Gotta figure out what's happening.

  3. #3
    Join Date
    Sep 2006
    Location
    Space station 101
    Posts
    182
    Rep Power
    9

    Default

    Should i post the contents here or what should i be looking for do you think?
    ------------------------------
    http://www.lcrm.co.uk

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    It might be easier to post the contents
    I have a little bit more experence in reading these things.

    In general, you're looking for exceptions, and especially the "Caused by:" line.

    -john

  5. #5
    Join Date
    Sep 2006
    Location
    Space station 101
    Posts
    182
    Rep Power
    9

    Default

    Great thanks for your help, hopefully I will learn a lot from this experience.

    I have attached the latest log file.

    Appreciate your help no end.

    I had to zip the file as it was too large
    Attached Files Attached Files
    ------------------------------
    http://www.lcrm.co.uk

  6. #6
    Join Date
    Sep 2006
    Location
    Space station 101
    Posts
    182
    Rep Power
    9

    Default

    HEEELLPP,


    My email server shut down again today.

    I tried zmcontrol start and got this:

    Starting logger...FAILED


    Starting mailbox...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...FAILED


    Starting spell...Done.
    Starting mta...FAILED
    saslauthd[21079] :set_auth_mech : failed to initialize mechanism zimbra
    zmsaslauthdctl failed to start



    Please, please help as soon as possible guys.

    Big thanks

    Costa
    ------------------------------
    http://www.lcrm.co.uk

  7. #7
    Join Date
    Sep 2006
    Location
    Space station 101
    Posts
    182
    Rep Power
    9

    Default

    This was also one of the latest sections of the mailbox.log that I found

    at com.zimbra.cs.launcher.TomcatLauncher.main(TomcatL auncher.java:74)
    2007-03-27 13:50:22,974 ERROR [main] [] [/service] - Servlet /service threw load() exception
    javax.servlet.ServletException: Invalid port number 0 in allowed.ports parameter; port number must be greater than zero
    at com.zimbra.cs.servlet.ZimbraServlet.init(ZimbraSer vlet.java:107)
    at com.zimbra.cs.dav.service.DavServlet.init(DavServl et.java:56)
    at javax.servlet.GenericServlet.init(GenericServlet.j ava:211)
    at org.apache.catalina.core.StandardWrapper.loadServl et(StandardWrapper.java:1105)
    at org.apache.catalina.core.StandardWrapper.load(Stan dardWrapper.java:932)
    at org.apache.catalina.core.StandardContext.loadOnSta rtup(StandardContext.java:3915)
    at org.apache.catalina.core.StandardContext.start(Sta ndardContext.java:4176)
    at org.apache.catalina.core.ContainerBase.addChildInt ernal(ContainerBase.java:759)
    at org.apache.catalina.core.ContainerBase.addChild(Co ntainerBase.java:739)
    at org.apache.catalina.core.StandardHost.addChild(Sta ndardHost.java:524)
    at org.apache.catalina.startup.HostConfig.deployDirec tory(HostConfig.java:910)
    at org.apache.catalina.startup.HostConfig.deployDirec tories(HostConfig.java:873)
    at org.apache.catalina.startup.HostConfig.deployApps( HostConfig.java:474)
    at org.apache.catalina.startup.HostConfig.start(HostC onfig.java:1118)
    at org.apache.catalina.startup.HostConfig.lifecycleEv ent(HostConfig.java:310)
    at org.apache.catalina.util.LifecycleSupport.fireLife cycleEvent(LifecycleSupport.java:119)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1020)
    at org.apache.catalina.core.StandardHost.start(Standa rdHost.java:718)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1012)
    at org.apache.catalina.core.StandardEngine.start(Stan dardEngine.java:442)
    at org.apache.catalina.core.StandardService.start(Sta ndardService.java:450)
    at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:700)
    at org.apache.catalina.startup.Catalina.start(Catalin a.java:551)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:275)
    at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:406)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)


    Can anyone help me figure this out please?
    ------------------------------
    http://www.lcrm.co.uk

  8. #8
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    Sounds like sasl libs mixed up. Make sure your zimbra lines are at the start of your /etc/ld.so.conf, and rerun ldconfig, then restart zimbra and see if that helps.

Similar Threads

  1. Replies: 4
    Last Post: 08-16-2011, 12:39 PM
  2. Replies: 7
    Last Post: 04-26-2006, 03:56 AM
  3. Need Urgent Affordable and Reliable Zimbra Hostiing
    By nazeeronline in forum Administrators
    Replies: 4
    Last Post: 04-11-2006, 12:18 PM
  4. Community and Network Edition - differences?
    By goetzi in forum I18N/L10N - Translations
    Replies: 1
    Last Post: 12-04-2005, 08:35 AM
  5. LDAP required?
    By debianfoo in forum Installation
    Replies: 6
    Last Post: 10-27-2005, 01:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •