Results 1 to 5 of 5

Thread: Logwatch stops sending mail?

Hybrid View

  1. #1
    Join Date
    Mar 2007
    Location
    Melbourne, Australia
    Posts
    8
    Rep Power
    8

    Default Logwatch stops sending mail?

    Hi!

    This is a CentOS 4 based install, with the Zimbra Commmunity edition, version 4.5.1. Zimbra is running fine, managing domains, and its great stuff.

    What I have noticed is that since installing Zimbra, logwatch stops sending mail to the root user. The Zimbra daily mail reports are making it fine, however

    Logwatch is set to use /bin/mail and from what I can tell, /bin/mail isn't exactly working (since postfix/sendmail is disabled on the system in favour of having all mail handled by Zimrbra's postfix).

    Should I set logwatch to use something rather than /bin/mail?

    From what I can tell, this thread might be related: http://www.zimbra.com/forums/showthread.php?p=40424

    As will this thread: http://www.zimbra.com/forums/archive...php/t-180.html however that test of sending mail within the zimbra user, fails for me

    Any help to getting logwatch working again, would rock? Its true, /bin/mail is not writing to zimbra's queue. Running mailq as the zimbra user shows no mail, but running mailq as root, I see "postqueue: warning: Mail system is down -- accessing queue directly" and there's a good 100+ messages waiting to be delivered (mainly logwatch, i presume)

    Sendmail is not installed, postfix is postfix-2.2.10-1.RHEL4.2.mysql_pgsql.c4 but disabled (in favor of the zimbra version)

    Any help will be greatly appreciated. Thanks

  2. #2
    Join Date
    Mar 2007
    Location
    Perth, Australia
    Posts
    1
    Rep Power
    8

    Default

    What I did to get this working was to install the CentOS version of Postfix but leave it disabled in the startup scripts.

    Ran "alternatives --config mta" to set sendmail.postfix as the default MTA for the system. I then configured postfix to use Zimbra's postfix spool directory as it's own spool (/etc/postfix/main.cf):

    queue_directory = /opt/zimbra/postfix-2.2.9/spool


    Result - the mail command (aliased to sendmail, which in turn uses sendmail.postfix) now drops mail in Zimbra's postfix queue, allowing it to be delivered.

  3. #3
    Join Date
    Mar 2007
    Location
    Melbourne, Australia
    Posts
    8
    Rep Power
    8

    Default

    Thanks! Thats exactly what needed to be done.

  4. #4
    Join Date
    May 2007
    Location
    Europe
    Posts
    48
    Rep Power
    8

    Thumbs up

    I solved this by linking to quene folder
    first I did is rename folder
    Code:
    mv /var/spool/postfix/ /var/spool/postfix_bck
    then I sym. link to zimbra postfix
    Code:
    ln -s /opt/zimbra/postfix/spool/ /var/spool/postfix/
    I had problems running SuSE default postfix and Zimbra postfix,
    so I shutdown Suse postfix and remove all sym links in /etc/init.d/rc.xy folders
    witch points to /etc/init.d/postfix
    Now I can send email from console or script in case of errors...
    like
    Code:
    echo "test"|mail -s ERROR my.mail@server.net

  5. #5
    Join Date
    Apr 2007
    Posts
    3
    Rep Power
    8

    Default Simpler solution

    A much simpler solution for me was to simply softlink the zimbra sendmail program to /usr/sbin. I didn't need to install any additional mailers or packages:

    sudo ln -s /opt/zimbra/postfix-2.6.7.2z/sbin/sendmail /usr/sbin/sendmail

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 02:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 09:09 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 04:34 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •