Results 1 to 8 of 8

Thread: Incorrect calednar url

  1. #1
    Join Date
    Mar 2007
    Posts
    35
    Rep Power
    8

    Default Incorrect calednar url

    I'd like to know how to set the url that is displayed on the calendar share page. The bottom of the page reads:

    "To allow others to access this item, direct them to this URL:"

    It then displays a URL using the internal domain of the server which is invalid for the user. I need it to display the external domain, the one that the user is viewing the site with. How can I do that?

    Example:
    User logs in at at https://www.example.com/
    Currently displays:
    https://internal.server/home/user/Calendar
    Should display:
    https://www.example.com/home/user/Calendar

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    The Zimbra server will only display what it's hostname is.
    Multiple hostnames are not allowed.

    Soo...if your DNS/Port forwarding is working correctly, then it likely will not matter.

    If you really want it changed, then your zimbra/hostname server will have to change to www

  3. #3
    Join Date
    Mar 2007
    Posts
    35
    Rep Power
    8

    Default

    Thanks, that's disappointing. I need it changed because my local hostname isn't valid on the internet and we never intended for it to be. Perhaps I can use zmlocalconfig to change it? Or will I need to re-install the application?

  4. #4
    Join Date
    Jan 2010
    Location
    Berlin, Germany
    Posts
    19
    Rep Power
    5

  5. #5
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    9

    Default Message sent with share request...

    can be modified. Can you not put the URL you want them to use in the message and ask them to use it instead? As long as it resolves to the correct IP I think it should work. I've not tried it so I may be wrong.

  6. #6
    Join Date
    Jan 2010
    Location
    Berlin, Germany
    Posts
    19
    Rep Power
    5

    Default

    Quote Originally Posted by Bill Brock View Post
    Can you not put the URL you want them to use in the message and ask them to use it instead? As long as it resolves to the correct IP I think it should work.
    Yes, that works. And that's why I think it is a bug in the user interface.

    Zimbra should present an URL that is similar to the URL the user uses to connect to the web interface.

  7. #7
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    9

    Default The URL could be anything.

    How would Zimbra know?

  8. #8
    Join Date
    Jan 2010
    Location
    Berlin, Germany
    Posts
    19
    Rep Power
    5

    Default

    Quote Originally Posted by Bill Brock View Post
    How would Zimbra know?
    A webserver knows the hostname the client is using to connect to the server.

    And the relevant parts of the UI run as JavaScript in the browser, where the hostname is also known. I see no need to get the REST_URL from the server. But I may not know the side effects.

Similar Threads

  1. Lotus Notes Protocol URL problems
    By bjared in forum Administrators
    Replies: 2
    Last Post: 06-24-2009, 01:17 PM
  2. rest url and accents
    By lfasci in forum Developers
    Replies: 1
    Last Post: 03-02-2007, 10:58 AM
  3. FC4 Test install getting SU: Incorrect Password
    By bbepristis in forum Installation
    Replies: 16
    Last Post: 08-11-2006, 11:07 AM
  4. how to use a URL with parameter to login
    By crossany in forum Developers
    Replies: 3
    Last Post: 05-11-2006, 09:17 PM
  5. Change spell checker URL
    By paintbuoy in forum Administrators
    Replies: 1
    Last Post: 02-12-2006, 09:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •