Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 34

Thread: Mail server host name in greeting

  1. #21
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by nfear24 View Post
    my server Hello line is this 220 mail.tickus.com ESMTP Postfix I want it to be tickus.com
    No, you don't want it to be that - that's wrong. It has to be a fully qualified domain name - again, that's made up from your server name 'mail' and your domain name 'tickus.com' = mail.tickus.com.

    The name mail.tickus.com DOES exist at your IP address it's the FULLY QUALIFIED DOMAIN NAME of your Zimbra server. How many times can I say the same thing, if you don't believe me then please search the forums for 'DNS in a Nutshell' or any of the dozens of posts that cover DNS problems and their resolution.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  2. #22
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    actually, tickus.com is an FQDN. in this particular situation i'm not sure that using it will work however, as zimbra usually expects an fqdn and a shortname in /etc/hosts that matches the server hostname, and there's no way of specifying the short host of an @ record. it may be possible to change the servername in the install wizard, but i dont see the point of this.

    also, your mail.tickus.com is a CNAME to tickus.com. generally CNAMEs are a bad idea unless there's a particular reason to use one, multiple A records pointing to the same IP are more reliable. this is particularly true with MX records, you must not use a CNAME with MX records. in this case your DNS is correct, because the MX points to the A, not CNAME record. your DNS is correct. i'm just not sure zimbra will cope with the /etc/hosts format in this case.

    change your mail.tickus.com to an A record, repoint your MX to mail.tickus.com (that's not 100% necessary but you might as well, will make your setup less ambiguous). live with mail.tickus.com in your smtp banner, i really don't get why that's a problem. it's normal, it's how 99% of everyone else does it.
    Last edited by dijichi2; 04-03-2007 at 06:23 PM.

  3. #23
    Join Date
    Jan 2007
    Posts
    121
    Rep Power
    8

    Default

    Quote Originally Posted by dijichi2 View Post
    actually, tickus.com is an FQDN. in this particular situation i'm not sure that using it will work however, as zimbra usually expects an fqdn and a shortname in /etc/hosts that matches the server hostname, and there's no way of specifying the short host of an @ record. it may be possible to change the servername in the install wizard, but i dont see the point of this.

    also, your mail.tickus.com is a CNAME to tickus.com. generally CNAMEs are a bad idea unless there's a particular reason to use one, multiple A records pointing to the same IP are more reliable. this is particularly true with MX records, you must not use a CNAME with MX records. in this case your DNS is correct, because the MX points to the A, not CNAME record. your DNS is correct. i'm just not sure zimbra will cope with the /etc/hosts format in this case.

    change your mail.tickus.com to an A record, repoint your MX to mail.tickus.com (that's not 100% necessary but you might as well, will make your setup less ambiguous). live with mail.tickus.com in your smtp banner, i really don't get why that's a problem. it's normal, it's how 99% of everyone else does it.
    Ok, what should I setup then as you explain. here is what I have.
    locally on the zimbra server I have these settings setup with the split dns:

    root@mail:~# host `hostname`
    mail.tickus.com has address 192.168.0.104
    mail.tickus.com mail is handled by 10 mail.tickus.com.
    zone file for split dns has these settings:

    ; Define the nameservers and the mail servers
    IN NS 192.168.0.104 ; local ip
    IN A 192.168.0.104 ; local ip
    IN MX 10 mail.tickus.com. ;MXrecord
    /etc/hosts file
    127.0.0.1 localhost.localdomain localhost
    192.168.1.103 FQDN mail.tickus.com mail
    192.168.1.103 tickus.com mail
    My domain is through godaddy.com and I have these settings there:

    (A)Host - Points to
    @ - 12.236.45.155
    mail.tickus.com - 12.236.45.155

    (MX)
    priority Host Goes to
    10 @ tickus.com
    20 mail.tickus.com tickus.com

  4. #24
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    zone file for split dns has these settings:

    Quote:
    ; Define the nameservers and the mail servers
    IN NS 192.168.0.104 ; local ip
    IN A 192.168.0.104 ; local ip
    IN MX 10 mail.tickus.com. ;MXrecord
    NS points to A record not IP. Change A record to mail.tickus.com, not the origin. MX is fine.
    Code:
    IN NS mail.tickus.com.
    mail IN A 192.186.0.104
    IN MX 10 mail.tickus.com.
    /etc/hosts file
    127.0.0.1 localhost.localdomain localhost
    192.168.1.103 FQDN mail.tickus.com mail
    192.168.1.103 tickus.com mail
    Remove FQDN! You do realise you're pointing to different IP from the DNS, right? Get rid of your tickus.com entry. You can't have two entries for same IP, second will overwrite the first.
    Code:
    127.0.0.1 localhost.localdomain localhost
    192.168.1.104 mail.tickus.com mail
    (A)Host - Points to
    @ - 12.236.45.155
    mail.tickus.com - 12.236.45.155

    (MX)
    priority Host Goes to
    10 @ tickus.com
    20 mail.tickus.com tickus.com
    OK. Remove @ record. Remove first MX.
    (A)Host - Points to
    mail.tickus.com - 12.236.45.155

    (MX)
    priority Host Goes to
    10 mail.tickus.com tickus.com

  5. #25
    Join Date
    Jan 2007
    Posts
    121
    Rep Power
    8

    Default

    locally everything checks out ok, but the external DNS never seems to work no matter what I try. The only way it will ever read the mx record is if its tickus.com I have tried many settings and it just continues to only work and read this mx record:

    Your 1 MX record is:
    30 tickus.com

    see attached file.
    Attached Images Attached Images
    Last edited by nfear24; 04-05-2007 at 08:58 AM.

  6. #26
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    10

    Default

    Not sure if this will help or not, but I had to change my helo greeting as well.

    I edited my main.cf file and added:

    smtp_helo_name = webmail.avmax.ca

    I did this because my actual host name on this machine is not a public domain but rather an internal one here:

    myhostname = webmail.avmax-internal.net
    Cheers,

    Travis

    "Let's look at this from a standpoint of "Status". What exactly, on the Space Craft, IS working?"
    -Flight Control, Apollo 13

  7. #27
    Join Date
    Jan 2007
    Posts
    121
    Rep Power
    8

    Default

    Quote Originally Posted by tbullock View Post
    Not sure if this will help or not, but I had to change my helo greeting as well.

    I edited my main.cf file and added:

    smtp_helo_name = webmail.avmax.ca

    I did this because my actual host name on this machine is not a public domain but rather an internal one here:

    myhostname = webmail.avmax-internal.net
    when I add that line and change it to

    smtp_helo_name = tickus.com

    still doesnt use that.

  8. #28
    Join Date
    Apr 2007
    Posts
    24
    Rep Power
    8

    Talking

    Quote Originally Posted by tbullock View Post
    Not sure if this will help or not, but I had to change my helo greeting as well.

    I edited my main.cf file and added:

    smtp_helo_name = webmail.avmax.ca

    I did this because my actual host name on this machine is not a public domain but rather an internal one here:

    myhostname = webmail.avmax-internal.net
    That is what I've been looking / asking for since I started my install of Zimbra, I'll test it out now.

    Thanks

  9. #29
    Join Date
    Apr 2007
    Posts
    24
    Rep Power
    8

    Talking

    Quote Originally Posted by nfear24 View Post
    when I add that line and change it to

    smtp_helo_name = tickus.com

    still doesnt use that.
    I got mine to work, I placed mine directly after the line in the main.cf file that reads smtpd_helo_required = yes then just stop and start Zimbra and send yourself a test message to confirm it.
    Last edited by Nicrad; 04-10-2007 at 05:42 PM.

  10. #30
    Join Date
    Jan 2007
    Posts
    121
    Rep Power
    8

    Default

    Problem has been fixed but I still am being blocked by a friends email service and also hotmail. everywhere else is fine.

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 02:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  4. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 09:09 AM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •