Results 1 to 6 of 6

Thread: Can't create users/aliases

  1. #1
    Join Date
    Mar 2007
    Posts
    22
    Rep Power
    8

    Default Can't create users/aliases

    I restored a zimbra backup a week ago and everything works correctly but today the logger crashed for some reason (don't know why, are there any "crash" logs?).

    Now I have the problem that I can't create new mailboxes or aliases, if I try to do so I get following error message:

    Code:
    Message:  system failure: unable to create alias: [LDAP: error code 32 - No Such Object]
    Error code:  service.FAILURE
    Method:  ZmCsfeCommand.prototype.invoke
    Details:soap:Receiver
    I thought maybe the permissions are wrong but I fixed these by running
    Code:
    chown -R zimbra:zimbra /opt/zimbra
    /opt/zimbra/libexec/zmfixperms

    Has anybody an idea why I can't create new objects in the ldap directory?


    thanks!

  2. #2
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    10

    Default

    Quote Originally Posted by voltcraft View Post

    I thought maybe the permissions are wrong but I fixed these by running
    Code:
    chown -R zimbra:zimbra /opt/zimbra
    /opt/zimbra/libexec/zmfixperms
    Did you run the zmfixperms as root user? I can't say for sure but I think running chown -R zimbra:zimbra /opt/zimbra may not be a correct procedure.

    What version of Zimbra are you running?
    Cheers,

    Travis

    "Let's look at this from a standpoint of "Status". What exactly, on the Space Craft, IS working?"
    -Flight Control, Apollo 13

  3. #3
    Join Date
    Mar 2007
    Posts
    22
    Rep Power
    8

    Default

    Yes, I did. I think the permissions must be set correctly after running this command. But this doesn't solve the strange problem...

    I ran a reinstallation of zimbra but the problem isn't solved...

    Any idea?

    Where can I find extended logs? For example why a daemon crashed and so on?

    I figured out that only some domains have this strange problem. So I tried to delete the domain and it worked but I'm not able to delete the accounts completly so I can't add the domain again because zimbra says that there is already a domain with this name.
    Last edited by voltcraft; 04-10-2007 at 01:52 PM.

  4. #4
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    10

    Default

    What version of Zimbra are you running?
    Cheers,

    Travis

    "Let's look at this from a standpoint of "Status". What exactly, on the Space Craft, IS working?"
    -Flight Control, Apollo 13

  5. #5
    Join Date
    Mar 2007
    Posts
    22
    Rep Power
    8

    Default

    Currently I run version 4.5.3

    If I do following I'll get an error from ldap, is there a way to remove the object completly?

    Code:
    prov> gaa
    [] WARN: unable to list all objects
    javax.naming.NameNotFoundException: [LDAP: error code 32 - No Such Object]; remaining name 'ou=people,dc=xx,dc=xx'
            at com.sun.jndi.ldap.LdapCtx.mapErrorCode(LdapCtx.java:3010)
            at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCtx.java:2931)
            at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCtx.java:2737)
            at com.sun.jndi.ldap.LdapCtx.searchAux(LdapCtx.java:1808)
            at com.sun.jndi.ldap.LdapCtx.c_search(LdapCtx.java:1731)
            at com.sun.jndi.toolkit.ctx.ComponentDirContext.p_search(ComponentDirContext.java:368)
            at com.sun.jndi.toolkit.ctx.PartialCompositeDirContext.search(PartialCompositeDirContext.java:338)
            at com.sun.jndi.toolkit.ctx.PartialCompositeDirContext.search(PartialCompositeDirContext.java:321)
            at javax.naming.directory.InitialDirContext.search(InitialDirContext.java:248)
            at com.zimbra.cs.account.ldap.LdapProvisioning.searchObjects(LdapProvisioning.java:939)
            at com.zimbra.cs.account.ldap.LdapProvisioning.getAllAccounts(LdapProvisioning.java:3165)
            at com.zimbra.cs.account.ProvUtil.doGetAllAccounts(ProvUtil.java:715)
            at com.zimbra.cs.account.ProvUtil.doGetAllAccounts(ProvUtil.java:746)
            at com.zimbra.cs.account.ProvUtil.execute(ProvUtil.java:376)
            at com.zimbra.cs.account.ProvUtil.interactive(ProvUtil.java:1387)
            at com.zimbra.cs.account.ProvUtil.main(ProvUtil.java:1452)

  6. #6
    Join Date
    Mar 2007
    Posts
    22
    Rep Power
    8

    Default

    Is there no way to delete these user accounts? I also tried to copy an account to another domain but now I have duplicated ids, for example one account foo@bar.com and one account with the same id foo@newbar.com. With zimbra it's impossible to remove these accounts.

    In my ldap browser I can't see this account but it must exist, any idea how to delete that?

    Ldapdelete gives me following error:

    ldapdelete -x -D "uid=zimbra,cn=admins,cn=zimbra" -w xxx "uid=user,ou=people,dc=foo,dc=bar"
    ldap_delete: Internal (implementation specific) error (80)
    additional info: could not locate parent of entry
    What should I do to repair the database?

    ldapsearch -x -D "uid=zimbra,cn=admins,cn=zimbra" -w xxx-b "uid=user,ou=people,dc=foo,dc=bar"

    dn: uid=user,ou=people,dc=foo,dc=bar
    zimbraMailTransport: lmtp:mail.xxx.at:7025
    givenName: Eva
    zimbraMailDeliveryAddress: user@foo.at
    sn: Bakalar
    userPassword:: e1xxxxxxx
    zimbraId: 481ae42b-cd0e-46b4-b11d-4a7dd8eb1bea
    displayName: Name
    objectClass: organizationalPerson
    objectClass: zimbraAccount
    objectClass: amavisAccount
    uid: user
    zimbraPasswordModifiedTime: 20070302163738Z
    cn: Name
    zimbraMailHost: mail.xxx.at
    zimbraLastLogonTimestamp: 20070310212835Z
    mail: user@foo.bar
    zimbraAccountStatus: closed
    zimbraMailStatus: disabled

    # search result
    search: 2
    result: 0 Success

    # numResponses: 2
    # numEntries: 1
    Thanks!
    Last edited by voltcraft; 05-06-2007 at 09:32 AM.

Similar Threads

  1. unable to create inexistent folder
    By dhain in forum Developers
    Replies: 2
    Last Post: 07-16-2007, 12:27 PM
  2. How to move backup to another drive
    By ghanedan in forum Administrators
    Replies: 1
    Last Post: 06-25-2007, 07:43 AM
  3. Fedora 5: Could not create the Java virtual machine
    By mi2enno in forum Installation
    Replies: 6
    Last Post: 06-01-2007, 04:16 AM
  4. Opensource backup Question.
    By nfear24 in forum Administrators
    Replies: 3
    Last Post: 04-01-2007, 12:47 AM
  5. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 11:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •