Results 1 to 10 of 16

Thread: Zimbra-Samba Admin Extention

Hybrid View

  1. #1
    Join Date
    Oct 2006
    Location
    Bangalore, India
    Posts
    95
    Rep Power
    9

    Default Zimbra-Samba Admin Extention

    Hi All,

    I have ZCS OSS 4.5.4 currently running and using external LDAP (Ldap server of my SAMBA PDC) for authentication. Things working perfectly in a single source of sign on manner. I got from forum that there is a new admin extention for managing SAMBA domain from admin UI of zimbra. But unfortunately i am not able to deploy the extention module. It showing failed.

    Can anyone please tell admin extention is possible for a zimbra server using external LDAP for authentication......Otherwise what could be the problem...

    Thanks in advance...

    Premoddev

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    It showing failed.
    What failed. The install or the auth?

  3. #3
    Join Date
    Oct 2006
    Location
    Bangalore, India
    Posts
    95
    Rep Power
    9

    Default

    Installation failed...

  4. #4
    Join Date
    Sep 2005
    Location
    Tucson - San Francisco - Moscow
    Posts
    127
    Rep Power
    10

    Default

    Quote Originally Posted by premoddev View Post
    Installation failed...
    Hm.. there are actually three extensions which you need to deploy to get the functionality:

    this
    http://gallery.zimbra.com/gallery.ph...d&productId=52
    this
    http://gallery.zimbra.com/gallery.ph...d&productId=53
    and this
    http://gallery.zimbra.com/gallery.ph...d&productId=54

    which one fails ?
    Bugzilla - Wiki - Downloads - Before posting... Search!
    P.S.: don't forget to vote on this bug
    add Samba LDAP entries to Exchange Migration Tool

  5. #5
    Join Date
    Mar 2007
    Posts
    44
    Rep Power
    8

    Default

    I personally just tried all three without any luck on NE 4.5.2 for Ubuntu. I'm assuming the LDAPUtils is installed, but cannot tell with the admin console. The zimlets fail to install for me with the following error:

    Error: zimlet description not found: zimbrasamba.xml
    Error: zimlet description not found: zimbraposixaccount.xml

    I'm uncertain why these show the files without the "_"

    The installation was attempted using the zmzimletctl install command

    Should these zimlets work in all versions of Zimbra? I'm about ready to try a new installation under Debian to see if they will work there.

  6. #6
    Join Date
    Mar 2007
    Posts
    44
    Rep Power
    8

    Default

    Noticed this in my logs after adding the zimbraldaputils

    WARN [main] [] extensions - no Zimbra-Extension-Class found, ignored: /opt/zimbra/lib/ext/zimbraldaputils

    looks like 'chmod 644' needs to be run on the file before tomcat is loaded.

Similar Threads

  1. Replies: 26
    Last Post: 04-19-2011, 10:24 AM
  2. zimbra-core missing
    By kinaole in forum Developers
    Replies: 1
    Last Post: 10-02-2006, 12:59 PM
  3. Replies: 16
    Last Post: 09-07-2006, 07:39 AM
  4. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 01:58 AM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •