Results 1 to 4 of 4

Thread: zmtrainsa does not see attachments

  1. #1
    Join Date
    Nov 2006
    Rep Power

    Default zmtrainsa does not see attachments


    My apologies in advance for a long post.

    For some reason, zmtrainsa is not seeing the attached spams I am sending to my spam training account and is therefore not processing the messages properly. It sees the container message, but it claims that no attachment exists and consequently learns nothing from the spam.

    I have tried three different clients (Outlook Express 6, Thunderbird 1.5 and Mulberry 4.0.7) and it doesn't matter which one I use — each time I run zmtrainsa to test, I get the message:

    [] WARN: message uri=/service/user/ message-id=<001701c78b6a$7bcaa1e0$> had no attachments
    It then goes on to report:

    [] INFO: Total messages processed: 1
    [] INFO: Total messages processed: 0
    Learned from 0 message(s) (0 message(s) examined).
    Learned from 0 message(s) (0 message(s) examined).
    bayes: synced databases from journal in 0 seconds: 1119 unique entries (1292 total entries)
    Oddly enough, if log into the web client as the spam training user and forward one of these messages back to the spam training account, zmtrainsa picks it right up:

    [] WARN: message uri=/service/user/ message-id=<> had no attachments
    [] INFO: Total messages processed: 2
    [] INFO: Total messages processed: 0
    Learned from 1 message(s) (1 message(s) examined).
    Learned from 0 message(s) (0 message(s) examined).
    bayes: synced databases from journal in 0 seconds: 257 unique entries (264 total entries)
    The two messages being parsed above are the one that it choked on and the same one resent from the web client as an attachment. As you can see, it continues to choke on the first one, but it apparently likes the second one just fine. This is confusing because I am already sending the spam as an attachment.

    Here is what I have tried:

    - Creating new messages in each client app and attaching a spam by dragging and dropping it into the e-mail.

    - Using the Forward As Attachment menu option in Outlook Express

    - Using the Forward option in Mulberry with both the and Forward as Attachment and Use Embedded Message options as well as the Forward as Attachment option by itself.

    - I also had a Thunderbird user forward a message as an attachment. I did confirm that she was sending the spam as an attachment.

    Just to be sure it wasn't the modified zmtrainsa from this thread causing the problem, I restored the original file and I got the same warning, only with the addition of the raw location "-" is not supported error. So I went back to the modified version.

    I am running 4.5.4 Network on CentOS.

    Has anyone else experienced this? I'm going to post this to bugzilla, but I thought it might generate some discussion here as well.


    Last edited by dvb; 04-30-2007 at 07:10 PM.

  2. #2
    Join Date
    May 2007
    Rep Power



    I have the exact same problem. Did you find a solution or what was your BugID?


  3. #3
    Join Date
    Nov 2006
    Rep Power


    The Zimbra folks were able to reproduce the behavior and the bug was assigned. No resolution yet.

    What I've been doing is having people drag their stuff into a separate IMAP folder in their clients and then "batching" them using the Junk button in the GUI.


  4. #4
    Join Date
    Apr 2012
    Rep Power

    Default *bump*

    I'm in the process of training SA and noticed that I am having the same issue with ZCS 7.1.4. My method:

    - Move messages(30) from one IMAP account to another.
    - Highlight the 30 messages(from Zimbra Web Mail) and forward them to my account
    - From CLI run zmtrainsa
    - Result:

    20120424100934 Starting spam/ham extraction from system accounts.
    [] WARN: Spam/notspam messages must have attachments (skipping /service/user/
    [] INFO: Total messages processed: 1
    [] INFO: Total messages processed: 0
    20120424100946 Finished extracting spam/ham from system accounts.
    20120424100946 Starting spamassassin training.
    netset: cannot include as it has already been included
    20120424100956 Finished spamassassin training.

    I have already double checked to make sure that these attachments are rfc/822, which they are.

    I see this thread is from 2007, so I am hoping that by now someone has figured out what the issue is. The latest post in Bug: 16509 is from 2007 and the status is showing that it is fixed. Am I missing something here?

    Thanks in advance.

    Also, I notice that it is saying "Starting spamassassin spam training for using using folder junk". Does this train for the entire domain or for each individual user? I would hope for the domain :-\
    Last edited by birdsthewurd; 04-24-2012 at 08:26 AM.

Similar Threads

  1. Attachments Getting Munged
    By taliskar in forum Administrators
    Replies: 36
    Last Post: 09-02-2010, 09:05 AM
  2. Large number of attachments
    By matthijsberg in forum Users
    Replies: 5
    Last Post: 04-11-2007, 03:41 PM
  3. COS and attachments and mails "to the outside"
    By Klug in forum Administrators
    Replies: 0
    Last Post: 10-19-2006, 10:06 AM
  4. Drag email to calendar and attachments
    By Richard in forum Users
    Replies: 2
    Last Post: 09-14-2006, 12:09 AM
  5. Rewrote zmtrainsa for DSPAM
    By unilogic in forum Developers
    Replies: 18
    Last Post: 01-12-2006, 05:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts