Results 1 to 10 of 22

Thread: Temporary message delivery failure

Hybrid View

  1. #1
    Join Date
    Mar 2007
    Posts
    9
    Rep Power
    8

    Default Temporary message delivery failure

    Hi,
    I've followed the instructions in this thread without success. /opt/zimbra/log/convertd.log doesnt exist on my system.

    The only solution I've found is to remove the mailbox in question, recreate it, then flush the queues. This is obviously less than optimal. It also seems that once there is an error like this concerning one mailbox all subsequent mail to that box results in the same error:

    May 7 12:43:26 localhost postfix/lmtp[16765]: C241B84C43D: to=<xxx@yyy.com>, relay=zimbra.zzz.com.au[192.168.10.2], delay=2350, status=deferred (host zimbra.zzz.com.au[192.168.10.2] said: 451 4.0.0 Temporary message delivery failure try again (in reply to end of DATA command))

    Any help would be appreciated.

  2. #2
    Join Date
    Mar 2007
    Posts
    9
    Rep Power
    8

    Default

    I'm still having this problem and have some more info on it. Firstly it seems to have no relation to attachments.

    Whenever I stop, then restart the server I start recieving these errors. Looking in the defered mail queue the first few mailboxes that try and recieve mail seem to lock up. A solution I have found is the re-index the mailboxes in question and flush the queues. The problem will not occur again until I restart the server. Any ideas on what could be causing this?

  3. #3
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Along the convertd thought process, what are your versions of compat-libstdc++-33 & compat-libstdc++-296?
    -Is this a 64-bit system?
    -Version string? (zmcontrol -v)

  4. #4
    Join Date
    Nov 2007
    Posts
    7
    Rep Power
    8

    Default

    Quote Originally Posted by mmorse View Post
    Along the convertd thought process, what are your versions of compat-libstdc++-33 & compat-libstdc++-296?
    -Is this a 64-bit system?
    -Version string? (zmcontrol -v)
    Here is my stuff.

    Installed Packages
    compat-libstdc++-296.i386 2.96-138 installed
    compat-libstdc++-33.i386 3.2.3-61 installed
    compat-libstdc++-33.x86_64 3.2.3-61 installed

    I am on a 64bit version.

    Release 5.0.1_GA_1902.RHEL5_64_20080109190819 CentOS5_64 NETWORK edition

  5. #5
    Join Date
    Feb 2007
    Location
    Sioux Falls, SD
    Posts
    67
    Rep Power
    8

    Unhappy

    I am experiencing the same issues. Certain mailboxes seem to crash convertd when a message is piped into it. Same Mailbox.log messages reported earlier and same version strings.

    I have tried to re-index the offending mailboxes with no success.

    DJS
    CoSentry - www.cosentry.com - Co-Location & Business Resiliency Solutions

  6. #6
    Join Date
    Nov 2007
    Posts
    7
    Rep Power
    8

    Default

    Does anyone have any ideas on how to fix this?

  7. #7
    Join Date
    Sep 2005
    Posts
    93
    Rep Power
    10

    Default

    Quote Originally Posted by arkade View Post
    I'm still having this problem and have some more info on it. Firstly it seems to have no relation to attachments.

    Whenever I stop, then restart the server I start recieving these errors. Looking in the defered mail queue the first few mailboxes that try and recieve mail seem to lock up. A solution I have found is the re-index the mailboxes in question and flush the queues. The problem will not occur again until I restart the server. Any ideas on what could be causing this?
    You'll need to look in the mailbox.log and find the error that's causing failed message delivery. Should be some kind of an exception going off with LMTP on the stack -- probably something in the index, since re-indexing fixes it.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  8. #8
    Join Date
    Nov 2007
    Posts
    7
    Rep Power
    8

    Default

    here is whats in my mailbox.log. Any thoughts?

    2008-01-24 00:40:39,747 WARN [LmtpServer-4019] [ip=204.16.240.61;] ParsedMessage - Parse error on MIME part 2 (application/x-zip-compressed, Message-ID: <F1838B76D14DAD4D9F4BFC126B45C1DA02EB16DEC2@WGMAIL CCR.walshgroup.com>)
    com.zimbra.cs.mime.MimeHandlerException: cannot extract text
    at com.zimbra.cs.mime.handler.DefaultHandler.getConte ntImpl(DefaultHandler.java:81)
    at com.zimbra.cs.mime.MimeHandler.getContent(MimeHand ler.java:148)
    at com.zimbra.cs.mime.ParsedMessage.analyzePart(Parse dMessage.java:872)
    at com.zimbra.cs.mime.ParsedMessage.analyzeMessage(Pa rsedMessage.java:788)
    at com.zimbra.cs.mime.ParsedMessage.analyze(ParsedMes sage.java:325)
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver MessageToLocalMailboxes(ZimbraLmtpBackend.java:340 )
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver (ZimbraLmtpBackend.java:140)
    at com.zimbra.cs.lmtpserver.LmtpHandler.processMessag eData(LmtpHandler.java:375)
    at com.zimbra.cs.lmtpserver.TcpLmtpHandler.continueDA TA(TcpLmtpHandler.java:67)
    at com.zimbra.cs.lmtpserver.LmtpHandler.doDATA(LmtpHa ndler.java:364)
    at com.zimbra.cs.lmtpserver.LmtpHandler.processComman d(LmtpHandler.java:174)
    at com.zimbra.cs.lmtpserver.TcpLmtpHandler.processCom mand(TcpLmtpHandler.java:61)
    at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:160)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:128)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:619)
    Caused by: java.io.EOFException
    at java.io.DataInputStream.readUnsignedShort(DataInpu tStream.java:323)
    at java.io.DataInputStream.readUTF(DataInputStream.ja va:572)
    at java.io.DataInputStream.readUTF(DataInputStream.ja va:547)
    at com.zimbra.cs.convert.TransformationClient.extract (TransformationClient.java:153)
    at com.zimbra.cs.convert.SocketTransformationStub.doE xtract(SocketTransformationStub.java:75)
    at com.zimbra.cs.convert.SocketTransformationStub.ext ract(SocketTransformationStub.java:109)
    at com.zimbra.cs.mime.handler.DefaultHandler.getConte ntImpl(DefaultHandler.java:78)
    ... 15 more


    com.zimbra.cs.mime.MimeHandlerException: cannot extract text
    at com.zimbra.cs.mime.handler.DefaultHandler.getConte ntImpl(DefaultHandler.java:83)
    at com.zimbra.cs.mime.MimeHandler.getContent(MimeHand ler.java:148)
    at com.zimbra.cs.mime.ParsedMessage.analyzePart(Parse dMessage.java:872)
    at com.zimbra.cs.mime.ParsedMessage.analyzeMessage(Pa rsedMessage.java:788)
    at com.zimbra.cs.mime.ParsedMessage.analyze(ParsedMes sage.java:325)
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver MessageToLocalMailboxes(ZimbraLmtpBackend.java:340 )
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver (ZimbraLmtpBackend.java:140)
    at com.zimbra.cs.lmtpserver.LmtpHandler.processMessag eData(LmtpHandler.java:375)
    at com.zimbra.cs.lmtpserver.TcpLmtpHandler.continueDA TA(TcpLmtpHandler.java:67)
    at com.zimbra.cs.lmtpserver.LmtpHandler.doDATA(LmtpHa ndler.java:364)
    at com.zimbra.cs.lmtpserver.LmtpHandler.processComman d(LmtpHandler.java:174)
    at com.zimbra.cs.lmtpserver.TcpLmtpHandler.processCom mand(TcpLmtpHandler.java:61)
    at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:160)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:128)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:619)
    Caused by: com.zimbra.cs.convert.ConversionException: Cannot connect to convertd
    at com.zimbra.cs.convert.SocketTransformationStub.doE xtract(SocketTransformationStub.java:78)
    at com.zimbra.cs.convert.SocketTransformationStub.ext ract(SocketTransformationStub.java:109)
    at com.zimbra.cs.mime.handler.DefaultHandler.getConte ntImpl(DefaultHandler.java:78)

Similar Threads

  1. One account not receving email
    By EnglishDude in forum Administrators
    Replies: 12
    Last Post: 04-30-2010, 07:19 AM
  2. Replies: 3
    Last Post: 01-16-2008, 08:31 AM
  3. Temporary message delivery failure
    By goetzi in forum Administrators
    Replies: 40
    Last Post: 06-25-2007, 11:41 AM
  4. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 11:30 PM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •