Results 1 to 6 of 6

Thread: Too_many_hops

  1. #1
    Join Date
    May 2007
    Posts
    4
    Rep Power
    8

    Default Too_many_hops

    Hi,

    Whenever I use zmprov to modify a new user's password, I get:

    zimbra@mail:~$ zmprov sp doug@myserver.net password
    ERROR: service.TOO_MANY_HOPS (mountpoint loop detected)
    zimbra@mail:~$

    I've noticed that the zimbraMailHost and zimbraMailTransport properties for the user are set differently than other users. The problem is I can't change them through zmprov -- I get the same error message. I can't delete the account either -- same message.

    Is there any way to manually delete the account or change the properties listed above (I am assuming that they are the cause of the problem). Also, when I create users in the future, is there a way to set the default properties listed above?

    Thanks for your help.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    A search would have found this thread (amongst many).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    May 2007
    Posts
    4
    Rep Power
    8

    Default

    Thank you for your quick reply.

    I did previously search for on the term TOO_MANY_HOPS. No results were returned. I also searched on "mountpoint loop detected". I got 5 results, including the one you pointed me too. I tried the suggestions as I thought were relevant and none helped me solve the problem. Perhaps there is a better search term that you used?

    Thanks again for your help.

  4. #4
    Join Date
    May 2007
    Posts
    4
    Rep Power
    8

    Default More information

    If this helps anyone, the following is logged to /opt/zimbra/mailbox.log:
    2007-05-09 16:43:23,246 INFO [http-7071-Processor48] [ip=192.168.3.251;aname=zi
    mbra;name=doug@myserver(not the real name).net;] SoapEngine - handler exception
    com.zimbra.common.service.ServiceException: mountpoint loop detected
    at com.zimbra.common.service.ServiceException.TOO_MAN Y_HOPS(ServiceExcep
    tion.java:230)
    at com.zimbra.soap.ZimbraSoapContext.<init>(ZimbraSoa pContext.java:157)
    at com.zimbra.soap.DocumentHandler.proxyRequest(Docum entHandler.java:254
    )
    at com.zimbra.cs.service.admin.AdminDocumentHandler.p roxyIfNecessary(Adm
    inDocumentHandler.java:80)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:267)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:168)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:90)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:223)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:162)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(Appl
    icationFilterChain.java:252)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationF
    ilterChain.java:173)
    at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperV
    alve.java:213)
    at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextV
    alve.java:178)
    at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.j
    ava:126)
    at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.j
    ava:105)
    at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineVal
    ve.java:107)
    at org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:
    541)
    at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:148)
    at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:869)
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processCo
    nnection(Http11BaseProtocol.java:667)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java
    :527)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWor
    kerThread.java:80)
    at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java
    :684)
    at java.lang.Thread.run(Thread.java:595)
    Last edited by jholder; 05-09-2007 at 03:39 PM. Reason: put in quote to prevent line breaks

  5. #5
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Try adding the -l (that's an ell , not an eye) with your zmprov command

  6. #6
    Join Date
    May 2007
    Posts
    4
    Rep Power
    8

    Default Solved! Thank you!

    This problem had been plaguing me for over a week. I very much appreciate your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •