Results 1 to 5 of 5

Thread: Zimbra and other web site(s)

  1. #1
    Join Date
    May 2007
    Posts
    13
    Rep Power
    8

    Default Zimbra and other web site(s)

    First off here's my setup:

    Mac OSX 10.4.9
    ZCS 4.5.5

    I have read through the various postings here in the forum and the wiki, but have run into issues trying to get another web site running alongside Zimbra. I want to have the corporate web site running on the same box as Zimbra, with Zimbra available at http://mail.server.com and the web site available at http://www.server.com.

    I know this involves having Zimbra listen on another port (besides 80). What I'm not sure of is if I can use the Apple installed Apache for hosting the corporate site or do I need to use Zimbra's Apache? Also, I would like to make Zimbra only available on the mail.server.com address.

    Please let me know if I need to elaborate more on my plans.

    Thanks much,
    Steve

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    apache on pt 80 to serve the website
    zimbra on say pt 8080
    to not have to type mail.domain.com:8080 to view the web client -search the forurms, there's tons of posts on it
    to get you started:
    http://wiki.zimbra.com/index.php?title=ZimbraApache
    http://wiki.zimbra.com/index.php?tit...e_using_mod_jk
    http://wiki.zimbra.com/index.php?tit...e_%28mod_jk%29 -might need some updating
    Last edited by mmorse; 05-24-2007 at 04:06 PM.

  3. #3
    Join Date
    May 2007
    Posts
    13
    Rep Power
    8

    Default

    I've tried following the wiki article but have had no luck at all. Here is the Virtual Host section of my /opt/zimbra/conf/httpd.conf file:

    Code:
    <VirtualHost *:8009>
        ServerAdmin webmaster@lakelandradiology.com
        ServerName server.lakelandradiology.com
        ServerAlias mail.lakelandradiology.com
        DocumentRoot /opt/zimbra/httpd-2.0.54
        ErrorLog logs/mail.lakelandradiology.com-error_log
        CustomLog logs/mail.lakelandradiology.com-access_log common
    </VirtualHost>
         
    <VirtualHost *:80>
        ServerAdmin webmaster@lakelandradiology.com
        ServerName server.lakelandradiology.com
        ServerAlias www.lakelandradiology.com
        DocumentRoot /Users/webmaster/Sites
        ErrorLog logs/www.lakelandradiology.com-error_log
        CustomLog logs/www.lakelandradiology.com-access_log common
    </VirtualHost>
    Yet when I got either www.lakelandradiology.com or mail.lakelandradiology.com, I see the Zimbra sign in page glaring back at me in defiance.

    I tried to follow along with the other links you provided for me, but when it came time to install the modules I ran into problems since the installs referenced Linux installs and I am working with a Mac box.

    Any further thoughts?

    TIA,
    Steve

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    You should probably be editing /opt/zimbra/conf/httpd.conf.in

    jh

  5. #5
    Join Date
    May 2007
    Posts
    13
    Rep Power
    8

    Default

    Thanks for the tip. I will give it a try and let you know of the results. Maybe the wiki article should be updated with the correct information?

    Thanks much,
    Steve

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •