Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Emails stuck in Deferred

  1. #1
    Join Date
    Mar 2007
    Location
    Near Pittsburgh
    Posts
    146
    Rep Power
    8

    Exclamation Emails stuck in Deferred

    Ok - my server has been up and running for a while but emails are not getting to mailboxes.

    I go into the mail queues and there are 74 emails waiting to be be delivered.

    I'm not sure I want to hit "flush" - I'm worried they might disappear.

    Any help on this greatly appreciated.

    Rob

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Just don't hit the delete button...
    The flush button is to immediately attempt delivery of all messages in the deferred, incoming and active queues.
    You can also requeue them-it drops the recorded attempt numbers (so you don't loose emails when it hits max attempts)

    the deferred queue is usually outgoing-you have 70+ mails already?

    if they don't go out let us know-more to troubleshoot
    Last edited by mmorse; 05-27-2007 at 05:55 PM.

  3. #3
    Join Date
    Mar 2007
    Location
    Near Pittsburgh
    Posts
    146
    Rep Power
    8

    Default

    all incoming. This is probably a rush of emails from the last 3 days or so.

    Is there a limit to the number of emails it can handle at any one time? Should I reboot or something?

  4. #4
    Join Date
    Mar 2007
    Location
    Near Pittsburgh
    Posts
    146
    Rep Power
    8

    Default

    also - I check the emails themselves - I get:

    delivery temporarily suspended: connect to 1270.0.0.1[127.0.0.1] connection refused.

    I tried flushing - just ended up the same. I tried requeueing a single email - just went back into deferred.

  5. #5
    Join Date
    Mar 2007
    Location
    Near Pittsburgh
    Posts
    146
    Rep Power
    8

    Default

    Ok - this is weird....

    I can now select a couple emails and reque them - and they get to the mailboxes...

    Is there a way to do all of them at once?
    Last edited by mmorse; 05-27-2007 at 06:01 PM.

  6. #6
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    their not in the incoming queue though?
    the deferred is usually outgoing mails that can't be delivered for whatever reason-and they retry for about 4 days (depending on settings)

    what's you /etc/hosts file say?

  7. #7
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    sry meant to hit quote-
    Quote Originally Posted by sternfan View Post
    Ok - this is weird....

    I can now select a couple emails and reque them - and they get to the mailboxes...

    Is there a way to do all of them at once?
    flush the queue
    but if it's only 70 something...and you got a method that works-keep at it

    your getting these posts in as i'm typing a response-lol
    Last edited by mmorse; 05-27-2007 at 06:07 PM.

  8. #8
    Join Date
    Mar 2007
    Location
    Near Pittsburgh
    Posts
    146
    Rep Power
    8

    Default

    Everything seems to be working now - I think the server just got hit with a whole bunch of emails at the same time and some 70 of them ended up as deferred.

    Thanks,
    Rob

  9. #9
    Join Date
    May 2007
    Posts
    8
    Rep Power
    8

    Default

    I have a similar setup on my spam filter and i'll get the same problem after a huge peak of messages. The connection between postfix and amavis can timeout (that's why its saying connection to 127.0.0.1) meaning the message will stay in the queue and get deferred.

    To speed off the process, a "postfix flush" will do the trick. It will requeue every current message that are held in the queue. If they are still held there, start than stop amavis and than flush the queue again.

  10. #10
    Join Date
    Aug 2007
    Posts
    10
    Rep Power
    8

    Default Zimbra User

    Hi,

    We ar using zimbra version 4.5 in our organisation. For last few days, our mail server received Emails, got choked in the active queue thus causing problems in receiving/sending email. we have since requeuethe mails and rebooted the server twice/thrice a day. The reason why mail queued up as per server is written below:

    4BBAD2004847D 9311 Sat Jan 5 01:23:02 nandini@indebo.com
    (connect to mx02.t-online.de[194.25.134.9]: server refused to talk to me: 554 IP:61.247.224.88 - A problem occurred. (Ask your postmaster for help or to contact tosa@rx.t-online.de to clarify.))
    BITT-taher@t-online.de

    E98FB2004ABD8 6560 Sat Jan 5 01:23:00 archana@indebo.com
    (Host or domain name not found. Name service error for name=rainbowcruises.in type=MX: Host not found, try again)
    info@rainbowcruises.in
    reservations@rainbowcruises.in
    We are very thankful if anyone help us to sort this problem.


    Thanks

    Mandeep Kaur

Similar Threads

  1. Replies: 4
    Last Post: 11-15-2009, 08:56 PM
  2. Replies: 3
    Last Post: 07-19-2007, 03:00 AM
  3. Inbound mail stuck in deferred queue
    By tclauson in forum Administrators
    Replies: 2
    Last Post: 04-24-2007, 06:54 AM
  4. Emails sent to AOL accounts are deferred
    By sunshineknox in forum Administrators
    Replies: 3
    Last Post: 04-16-2007, 10:02 AM
  5. Errors because of Deffered emails
    By mansuper in forum Administrators
    Replies: 0
    Last Post: 11-20-2006, 04:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •