Results 1 to 5 of 5

Thread: How to remove message size restrictions

  1. #1
    Join Date
    May 2007
    Location
    San Mateo
    Posts
    68
    Rep Power
    8

    Default How to remove message size restrictions

    Under the Global Settings the MTA tab has the subsection of Messages. The subsection has two fields.

    Maximum message size (kb):*
    Maximum size of an uploaded file(kb):*

    We have some rather large files being transfered.
    1. Will setting the values to zero work in disabling the checks? Or will an empty field be sufficient?
    2. What do the red asterisks mean?

    Haven't found this in the wiki or the forum so if I missed it please let me know and I'll look at the original post.

    Thanks,

    David

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    1. Will setting the values to zero work in disabling the checks? Or will an empty field be sufficient?
    Never tried-just set it really high; like to 1048576 KB (which =1GB) no one should ever hit that limit-if you're sending 1GB emails around it's time for a different file sharing solution...
    2. What do the red asterisks mean?
    You have a space, comma, or other invalid character in the line. Enter just numbers in KB with no spaces.

  3. #3
    Join Date
    Apr 2007
    Posts
    14
    Rep Power
    8

    Default

    I've used the Admin UI to change the values to 20480, but the asterisk are still there.

    I used the console UI using zmprov, and after a refresh the asterisks are still there.

    And I still can't send attachments over 10mb.

    Help?

    Also, it seems that the postfix settings for message_size_limit isn't updating even when changed through zmprov and the admin UI.
    Last edited by antonmb; 06-13-2007 at 12:51 AM.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by antonmb View Post
    And I still can't send attachments over 10mb.
    I'm not surprised, you've changed the maximum size to 20kilobytes.

    You need to do the following commands:

    Code:
    zmprov mcf zimbraMtaMaxMessageSize 10240000
    zmprov mcf zimbraFileUploadMaxSize 10485760
    That's the original settings and it's in Bytes. Make sure you increase the size to an amount that will include at least 60% more than the original file size as it's larger when it's converted for upload.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    May 2007
    Location
    San Mateo
    Posts
    68
    Rep Power
    8

    Default

    Thanks but, like antonmb, the red asterisks remain. Even after setting the values from the command line. Minor issue but worth noting.

    1Gb! I'm not sending DNA peptide sequences. Just experience has shown that any maximum value will have an exception that needs to be worked around. So the easiest answer for me would have been a no maximum size limit.

Similar Threads

  1. Max imap message size
    By vogon1 in forum Developers
    Replies: 13
    Last Post: 10-25-2009, 09:47 PM
  2. Replies: 3
    Last Post: 07-19-2007, 03:00 AM
  3. Changing the Maxium Message Size
    By plan9 in forum Administrators
    Replies: 1
    Last Post: 03-01-2007, 05:00 PM
  4. Max Message (Send/Receive) Size
    By Oswald-Kolle in forum Installation
    Replies: 10
    Last Post: 09-06-2006, 08:04 AM
  5. Replies: 42
    Last Post: 08-11-2006, 10:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •