Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: lost connection after STARTTLS

  1. #1
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default lost connection after STARTTLS

    I have been tring to use an IMAP client to connect to zimbra and send emails but it is broken and i keep getting this in my logs.

    This is a fresh install of M2 on fedora core 3 but i forgot to enable https during the initial setup this has caused me some problems one being that i can login from http and https undesirable and this new problem.

    Seems there is a certificate missing or something can i create one without doing a reinstall? Or should i reinstall and hopfully fix both problems? If i do reinstall can i select no to upgrade and then yes to save users and mailboxes?



    Nov 28 08:43:56 shoemasters postfix/smtpd[14794]: initializing the server-side TLS engine
    Nov 28 08:43:56 shoemasters postfix/smtpd[14794]: warning: cannot get certificate from file /opt/zimbra/conf/smtpd.crt
    Nov 28 08:43:56 shoemasters postfix/smtpd[14794]: warning: TLS library problem: 14794:error:02001002:system library:fopen:No such file or directory:bss_file.c:259:fopen('/opt/zimbra/conf/smtpd.crt','r'):
    Nov 28 08:43:56 shoemasters postfix/smtpd[14794]: warning: TLS library problem: 14794:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:261:
    Nov 28 08:43:56 shoemasters postfix/smtpd[14794]: warning: TLS library problem: 14794:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:758:
    Nov 28 08:43:56 shoemasters postfix/smtpd[14794]: cannot load RSA certificate and key data
    Nov 28 08:43:56 shoemasters postfix/smtpd[14794]: connect from digi.spots.ab.ca[209.115.173.9]
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Did you try to just recreate the certs?

  3. #3
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default

    I recreated the certs it broke some more things and now get this error when trying to start zimbra using zmcontrol start

    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException shoemasters.com:389)

    Also i got some java errors that according to this post
    http://www.zimbra.com/forums/showthr...ighlight=certs

    are ok but one error during about line 47 print or something during the command zmtlsctl https


    Kevin if i do an upgrade using the the .install.sh are my chances pretty good? ie do not want to loose users emails again however it has only been a couple of days?

    Do you u think upgrade will fix and my http and https prob or is this an error you have come across before?
    Last edited by rmvg; 11-28-2005 at 05:39 PM.
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    install.sh can do an overinstall. You could try that and just let it reinstall the pkgs but keep the data.

  5. #5
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default

    does that mean click yes or no to upgrade?
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  6. #6
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    yes for upgrade.

  7. #7
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default

    the setup cannot seem to use port 389 for ldap and will not let me set to 389 which causes me to exit without changes

    All this kinda makes sense cause it relates to the error i am getting while tring to start/stop zimbra seems like neither zimbra or ldap are running.

    [root@shoemasters zcs]# ps -aux |grep ldap
    Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.3/FAQ
    root 10182 0.0 0.1 3728 644 pts/1 S+ 13:18 0:00 grep ldap

    [root@shoemasters zcs]# ps -aux |grep zimbra
    Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.3/FAQ
    root 10254 0.0 0.1 3728 644 pts/1 S+ 13:24 0:00 grep zimbra
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  8. #8
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default

    I tried using a different port but that doesnt work either

    Please enter the ldap server port 10389
    Checking ldap on localhost:10389...FAILED
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  9. #9
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default upgrade installs

    On an upgrade, it attempts to start ldap, and connect to it to verify that your ldap host/passwd/port are correct.

    If ldap isn't starting, the re-install won't work. Let me check on the cert creation error, and post another fix.

  10. #10
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default cert recreation

    The print error in zmcertinstall is complaining that the certificate file can't be found - so let's try recreating your certs.

    Run, as zimbra:
    sh -x bin/zmcreatecert

    and post the output.

Similar Threads

  1. zmprov mc default zimbraFeatureNotebookEnabled TRUE
    By nbhanji in forum Installation
    Replies: 11
    Last Post: 04-29-2008, 10:39 AM
  2. Replies: 3
    Last Post: 07-19-2007, 02:00 AM
  3. SMTP SSL Problem
    By nexus in forum Installation
    Replies: 8
    Last Post: 03-15-2007, 07:26 AM
  4. lost connection after RCPT
    By scott_mcneilage in forum Administrators
    Replies: 1
    Last Post: 05-20-2006, 04:00 AM
  5. lost connection after AUTH
    By avisser in forum Administrators
    Replies: 4
    Last Post: 10-18-2005, 02:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •