Results 1 to 10 of 41

Thread: Temporary message delivery failure

Hybrid View

  1. #1
    Join Date
    Nov 2005
    Location
    Austria
    Posts
    223
    Rep Power
    10

    Default Temporary message delivery failure

    Hi,

    since 3 days I have sometimes the following error for a few hours... all incoming mails are "blocked" then:

    Code:
    Nov 29 17:50:01 zimbra zimbramon[19900]: 19900:info: 2005-11-29 17:50:01, QUEUE: 7466 5
    Nov 29 17:50:13 zimbra zimbramon[19904]: 19904:info: 2005-11-29 17:50:01, STATUS: zimbra.*my domain*.de: antispam: Running
    Nov 29 17:50:13 zimbra zimbramon[19904]: 19904:info: 2005-11-29 17:50:01, STATUS: zimbra.*my domain*.de: antivirus: Running
    Nov 29 17:50:13 zimbra zimbramon[19904]: 19904:info: 2005-11-29 17:50:01, STATUS: zimbra.*my domain*.de: ldap: Running
    Nov 29 17:50:13 zimbra zimbramon[19904]: 19904:info: 2005-11-29 17:50:01, STATUS: zimbra.*my domain*.de: logger: Running
    Nov 29 17:50:13 zimbra zimbramon[19904]: 19904:info: 2005-11-29 17:50:01, STATUS: zimbra.*my domain*.de: mailbox: Running
    Nov 29 17:50:13 zimbra zimbramon[19904]: 19904:info: 2005-11-29 17:50:01, STATUS: zimbra.*my domain*.de: mta: Running
    Nov 29 17:50:13 zimbra zimbramon[19904]: 19904:info: 2005-11-29 17:50:01, STATUS: zimbra.*my domain*.de: snmp: Running
    Nov 29 17:50:13 zimbra zimbramon[19904]: 19904:info: 2005-11-29 17:50:01, STATUS: zimbra.*my domain*.de: spell: Running
    Nov 29 17:50:13 zimbra zimbramon[19904]: 19904:info: 2005-11-29 17:50:01, DISK: zimbra.*my domain*.de: dev: /dev/ida/c0d0p3, mp: /, tot: 16139, avail: 11952
    Nov 29 17:50:13 zimbra zimbramon[19904]: 19904:info: 2005-11-29 17:50:01, DISK: zimbra.*my domain*.de: dev: /dev/ida/c0d0p1, mp: /boot, tot: 97, avail: 81
    Nov 29 17:50:21 zimbra postfix/qmgr[22811]: 76FDCC6D41: from=<SRS0=4M74=ZZ=3ai.net=mail@gmx.at>, size=1528702, nrcpt=1 (queue active)
    Nov 29 17:50:21 zimbra postfix/qmgr[22811]: 849DAC6D44: from=<SRS0=GeeA=Z4=3ai.net=mail@gmx.at>, size=1529043, nrcpt=1 (queue active)
    Nov 29 17:50:24 zimbra postfix/lmtp[20122]: 849DAC6D44: to=<michael@*my domain*.de>, relay=zimbra.*my domain*.de[192.168.0.15], delay=3272, status=deferred (host zimbra.*my domain*.de[192.168.0.15] said: 451 4.0.0 Temporary message delivery failure try again (in reply to end of DATA command))
    Nov 29 17:50:24 zimbra postfix/lmtp[20121]: 76FDCC6D41: to=<michael@*my domain*.de>, relay=zimbra.*my domain*.de[192.168.0.15], delay=262478, status=deferred (host zimbra.*my domain*.de[192.168.0.15] said: 451 4.0.0 Temporary message delivery failure try again (in reply to end of DATA command))
    What could this be?

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default backups?

    Are you running scheduled backups? (zmschedulebackup with no arguments will dump the backup schedule). Backups put accounts into maintenance mode, which will cause a temporary delivery failure.

    Is there anything else in the logs around this time? What about /opt/zimbra/log/zimbra.log or /opt/zimbra/tomcat/logs/catalina.out?

    If nothing there - comment out the "loglevel 0" line in /opt/zimbra/conf/slapd.conf and restart ldap - ldap may log something the next time it occurs.

  3. #3
    Join Date
    Nov 2005
    Posts
    13
    Rep Power
    10

    Default

    I'm having a similar, but slightly different problem. 'mailq' reports that postfix has several messages queued for local delivery. Backups were not running during the time that these messages were received. Most messages are received and delivered without a problem.

    Code:
    4490129506B8   883537 Mon Dec 12 19:18:45  johnxx@inreach.com
    (host z1.sfo2.xxxx.com[209.xx.xx.xx] said: 451 4.0.0 Temporary message delivery failure try again (in reply to end of DATA command))
    dan@xxxxx.com

  4. #4
    Join Date
    Nov 2005
    Location
    Austria
    Posts
    223
    Rep Power
    10

    Default

    Are you running scheduled backups? (zmschedulebackup with no arguments will dump the backup schedule). Backups put accounts into maintenance mode, which will cause a temporary delivery failure.
    Not as I know
    Never did something with scheduled backups, so if Zimbra doesn't do it automatically: No.

    Is there anything else in the logs around this time? What about /opt/zimbra/log/zimbra.log or /opt/zimbra/tomcat/logs/catalina.out?
    In /opt/zimbra/log/zimbra.log there is nothing else and /opt/zimbra/tomcat/logs/catalina.out is completely empty.

    If nothing there - comment out the "loglevel 0" line in /opt/zimbra/conf/slapd.conf and restart ldap - ldap may log something the next time it occurs.
    Does LDAP have an own log or will this entries be in /opt/zimbra/log/zimbra.log?

    Edit: There IS an error once befor this other errors occur (don't know if it has something to do with my problem):
    Code:
    Dec 13 08:40:10 zimbra postfix/smtpd[28791]: connect from unknown[219.133.246.141]
    Dec 13 08:40:13 zimbra postfix/smtpd[28791]: NOQUEUE: reject: RCPT from unknown[219.133.246.141]: 504 <62.2.100.203>: Helo command rejected: need fully-qualified hostname; from=<dfvdfbzsega@pamil.com> to=<popogigi1975@yahoo.com.tw> proto=SMTP helo=<62.2.100.203>
    I give you a part of my zimbra.log, maybe you see other things I didn't recognise.
    As you can see, most time it is NOT working. Very nasty
    Attached Files Attached Files
    Last edited by goetzi; 12-13-2005 at 01:31 AM.

  5. #5
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Can you try a "zmprov ga michael@glatter-goetz.de" this should dump all the user attrs.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  6. #6
    Join Date
    Nov 2005
    Posts
    13
    Rep Power
    10

    Default

    My problem appears to be related mostly to two user accounts. What should I be looking for in the output of 'zmprov ga username@domain.com'?

    Also, this doesn't appear to be a temporary failure, as the mailq message indicates. The same messages are still in the Postfix deferred queue as yesterday, plus a few more of them.

Similar Threads

  1. One account not receving email
    By EnglishDude in forum Administrators
    Replies: 12
    Last Post: 04-30-2010, 07:19 AM
  2. Temporary message delivery failure
    By arkade in forum Administrators
    Replies: 21
    Last Post: 04-01-2008, 01:17 PM
  3. Replies: 3
    Last Post: 01-16-2008, 08:31 AM
  4. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 11:30 PM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •