Results 1 to 4 of 4

Thread: PDF attachment from one particular sender not coming though

  1. #1
    Join Date
    Jan 2007
    Posts
    2
    Rep Power
    8

    Question PDF attachment from one particular sender not coming though

    OK, so there is one particular sender who sends us PDF attachments that the Zimbra web UI doesn't recognize (I guess). The little paper clip is there and the attachment is clearly there in the raw message, but the link to get the attachment is not there.

    We get PDF attachments fine from everybody else, but not from this one person. We tested having the person email the attachments to an AOL email account, and it works fine.

    It also seems to work if we use Thunderbird as opposed to the web client...

    Any advice??

    Jared

  2. #2
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default "inline"

    This is probably a case of the sender using AppleMail to compose the message and the PDF being tagged as "Content-Disposition: inline". We're actively working on this right now.

    You could attach a copy of one of these messages to a post to make sure...
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Jan 2007
    Posts
    2
    Rep Power
    8

    Default not inline

    That doesn't seem to be the problem...

    Here is one of the emails... I didn't include the entire encoded PDF for obvious reasons... and I changed the domain names and such for privacy...

    Also, the sender appears to be using SAP R/3 Internet Mail Gateway to send the attachment...

    Code:
    Received: from localhost (localhost.localdomain [127.0.0.1])
    	by mail.fakedomain.com (Postfix) with ESMTP id B649B3685B9
    	for <janedoe@fakedomain.com>; Mon, 11 Jun 2007 15:41:27 -0400 (EDT)
    X-DSPAM-Result: Innocent
    X-DSPAM-Processed: Mon Jun 11 15:41:25 2007
    X-DSPAM-Confidence: 0.9997
    X-DSPAM-Probability: 0.0000
    X-DSPAM-Signature: 466da56560172145363081
    X-DSPAM-Factors: 27,
    X-Virus-Scanned: amavisd-new at 
    X-Spam-Score: -1.115
    X-Spam-Level: 
    X-Spam-Status: No, score=-1.115 tagged_above=-10 required=3 tests=[AWL=-0.724,
    	BAYES_00=-2.599, DSPAM_HAM=-0.1, EMPTY_MESSAGE=2.308]
    Received: from mail.fakedomain.com ([127.0.0.1])
    	by localhost (mail.fakedomain.com [127.0.0.1]) (amavisd-new, port 10024)
    	with ESMTP id r2Mo6K9gUg1o for <janedoe@fakedomain.com>;
    	Mon, 11 Jun 2007 15:41:25 -0400 (EDT)
    Received: from fakedomain.com (proxy.fakedomain.com [192.168.201.1])
    	by mail.fakedomain.com (Postfix) with ESMTP id 63E183685B8
    	for <janedoe@fakedomain.COM>; Mon, 11 Jun 2007 15:41:25 -0400 (EDT)
    Received-SPF: none (proxy.fakedomain.com: 00.000.00.000 is neither permitted nor denied by domain of fakesender.com) client-ip=00.000.00.000; envelope-from=john.doe@fakesender.com; helo=sfwcr01s.fakethistoo.com;
    Received: from ns1.fakethistoo.com ([00.000.00.000] helo=sfwcr01s.fakethistoo.com)
    	by proxy.fakedomain.com with esmtp (Exim 4.43)
    	id 1HxplU-0002cX-Du
    	for janedoe@fakedomain.COM; Mon, 11 Jun 2007 15:41:25 -0400
    Date: Mon, 11 Jun 2007 14:41:23 -0500
    X-Authentication-Warning: sr3a04px.fakethistoo.com: rp0adm set sender to john.doe@fakesender.com using -f
    To: janedoe@fakedomain.COM
    From: "JOHN DOE" <john.doe@fakesender.com>
    Message-Id: <200706111941.l5BJfN2C013050@sfwcr01s.fakethistoo.com>
    Mime-Version: 1.0
    X-Mailer: SAP R/3 Internet Mail Gateway 4.6D12
    Subject: Attached...
    Content-Type: APPLICATION/PDF;
     Name="Fakename.PDF"
    Content-Transfer-Encoding: BASE64
    
    JVBERi0xLjMNCiXi48/TDQoyIDAgb2JqDQo8PA0KL1R5cGUgL1hPYmplY3QNCi9TdWJ0eXBlIC9J
    bWFnZQ0KL0xlbmd0aCAzIDAgUg0KL0ZpbHRlciAvQVNDSUk4NURlY29kZQ0KL05hbWUgLzAwMDAy
    DQovV2lkdGggMTE2Nw0KL0hlaWdodCA0NjUNCi9CaXRzUGVyQ29tcG9uZW50IDENCi9JbWFnZU1h
    c2sgdHJ1ZQ0KPj4NCnN0cmVhbQ0KczhXLSFzOFctIXM4Vy0hczhXLSFzOFctIXM4Vy0hczhXLSFz
    OFctIXM4Vy0hczhXLSFzOFctIXM4Vy0hczhXLSFzOFctIXM4Vy0hczhXLSENCnM4Vy0hczhXLSFz
    Last edited by jrich; 06-22-2007 at 08:58 AM.

  4. #4
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default inline bug

    In the absence of a Content-Disposition header, the top MIME part defaults to "inline" disposition. Since PDFs aren't displayable inline, you're seeing bug 7271 in action. We're actively working on this.
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. Forwarding, and forwarding as Attachments
    By gfdos.sys in forum Users
    Replies: 4
    Last Post: 06-06-2007, 08:22 AM
  2. Pdf Attachment
    By Rick Baker in forum Administrators
    Replies: 2
    Last Post: 01-03-2007, 12:21 PM
  3. Replies: 2
    Last Post: 10-19-2006, 11:26 PM
  4. Message forwarded as attachment problem
    By wildstyle in forum Users
    Replies: 13
    Last Post: 06-20-2006, 05:26 PM
  5. what's the attachment filename charset?
    By crossany in forum Administrators
    Replies: 2
    Last Post: 06-16-2006, 12:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •