Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: Internal Mails Stop Working After a While

  1. #11
    Join Date
    Nov 2005
    Location
    UK
    Posts
    117
    Rep Power
    10

    Default

    Quote Originally Posted by dkarp
    One possibility: Make sure that the number of IMAP threads is sufficient to handle the number of active connections. (Each IMAP client may open multiple connections simultaneously, so don't be overly stingy here.) You can configure this number in the admin UI; it requires a tomcat server restart to take effect.

    How many connections would you allow for per client? 3? 5? more?

    Or should I just go for the max this server configuration could handle?

  2. #12
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default Split the difference.

    Quote Originally Posted by mintra
    How many connections would you allow for per client? 3? 5? more?

    Or should I just go for the max this server configuration could handle?
    Let's try 4 and see if the issue resolves itself. A future version of the server will remove the thread-per-connection constraint, but for now it's still an issue.

  3. #13
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default DNS vs. Ping

    ping uses the order in /etc/nsswitch.conf - postfix (by default) only uses DNS.

    If you want to set up a relay host for outgoing mail, you can disable DNS in the admin console for postfix, which will caues it to use the local value for LMTP delivery.

  4. #14
    Join Date
    Nov 2005
    Location
    UK
    Posts
    117
    Rep Power
    10

    Default

    Ok following instructions on this thread
    http://www.zimbra.com/forums/showthread.php?t=585


    I've setup Bind DNS server on the zimbra machine,

    dig domain.com returns the local ip address of the server.

    Lets see if it does the trick

  5. #15
    Join Date
    Nov 2005
    Location
    UK
    Posts
    117
    Rep Power
    10

    Default DNS Server installed

    command "host domain.com" now returns the internal ip address

    The Mail Queues are alot smaller now.

    only 2 internal messages in the queue, with this error.

    (conversation with host.domain.com[private_ip_addr] timed out while sending end of data -- message may be sent more than once)

  6. #16
    Join Date
    Nov 2005
    Location
    UK
    Posts
    117
    Rep Power
    10

    Default Spoke too soon

    Still having problems.

    After Machine running for 3 hours, it stops delivery again.

    ------------------ Zimbra Logs

    A9F21D4623 4900 Fri Dec 2 12:21:19 userxyz@someweb.com
    (delivery temporarily suspended: connect to host.domain.com[192.168.1.60]: read timeout)
    user1@domain.com
    --
    A0FEFD461C 7895 Fri Dec 2 12:15:30 userxyz2@someweb.com
    (connect to host.domain.com[192.168.1.60]: read timeout)
    user2@domain.com

    --
    137FAD4617 5826 Fri Dec 2 12:10:05 userxyz3@someweb.com
    (connect to host.domain.com[192.168.1.60]: read timeout)
    user3@domain.com
    --
    6767DD4618 5826 Fri Dec 2 12:11:22 user4@domain.com
    (connect to host.domain.com[192.168.1.60]: read timeout)
    user4@domain.com


    Any Ideas?

  7. #17
    Join Date
    Nov 2005
    Location
    UK
    Posts
    117
    Rep Power
    10

    Default

    zmcontrol status

    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running

  8. #18
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    What gets things going again? restarting tomcat/mailbox or restarting postfix/mta? If it's tomcat you might want to try "kill -QUIT <tomcat pid>" this will dump a stack trace in the catalina.out posting this may help us determine what tomcat is doing when it stops.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  9. #19
    Join Date
    Nov 2005
    Location
    UK
    Posts
    117
    Rep Power
    10

    Default

    Don't know if this is any help, here is what I get

    INFO: Pausing Coyote HTTP/1.1 on http-80
    Dec 5, 2005 9:59:30 AM org.apache.coyote.http11.Http11Protocol pause
    INFO: Pausing Coyote HTTP/1.1 on http-443
    Dec 5, 2005 9:59:30 AM org.apache.coyote.http11.Http11Protocol pause
    INFO: Pausing Coyote HTTP/1.1 on http-7071
    Dec 5, 2005 9:59:31 AM org.apache.catalina.core.StandardService stop
    INFO: Stopping service Catalina


    (After a zmcontrol stop)

  10. #20
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Is there anything in the log when mail processing stops? Can you try a Kill -QUIT <tomcat pid> when this happens?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

Similar Threads

  1. Zimbra .pids / service monitoring
    By bin2hex in forum Administrators
    Replies: 24
    Last Post: 04-03-2010, 10:12 PM
  2. Zimbra internal mails delivery
    By samuelier in forum Installation
    Replies: 3
    Last Post: 06-15-2007, 08:30 AM
  3. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 11:30 PM
  4. Authentication to external ldap stop working.
    By jahaj in forum Installation
    Replies: 3
    Last Post: 12-05-2006, 03:17 PM
  5. Replies: 2
    Last Post: 09-30-2006, 07:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •