Results 1 to 2 of 2

Thread: Missing User

  1. #1
    Join Date
    Jun 2007
    Rep Power

    Default Missing User

    Ok, this is a strange one, but critical.

    I tried updating my server to the latest version, but it failed on ldap. Instead of continuing to mess with it I deleted and restored a copy of the zimbra directory I created just before the upgrade attempt.

    Now there is one user that is missing, so far as I can tell and it just happens to be the owner of the company.

    His domain is there as well as several of the other users for that domain, but his account does not show up. He can't log in and attempts to send email to him result in a recipient rejected error.

    I tried to re-add his account, but I get a server error and this long message:
    Message: system failure: createAccount
    com.zimbra.cs.service.ServiceException: system failure: createAccount
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser
    at com.zimbra.cs.account.ldap.LdapProvisioning.create Subcontext(
    at com.zimbra.cs.account.ldap.LdapProvisioning.create Account(
    at com.zimbra.cs.account.ldap.LdapProvisioning.create Account(
    at com.zimbra.cs.service.admin.CreateAccount.handle(C
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:162)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:223)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at ternalDoFilter(
    at Filter(
    at org.apache.catalina.core.StandardWrapperValve.invo ke(
    at org.apache.catalina.core.StandardContextValve.invo ke(
    at org.apache.catalina.core.StandardHostValve.invoke(
    at org.apache.catalina.valves.ErrorReportValve.invoke (
    at org.apache.catalina.core.StandardEngineValve.invok e(
    at org.apache.catalina.valves.AccessLogValve.invoke(A
    at org.apache.catalina.connector.CoyoteAdapter.servic e(
    at org.apache.coyote.http11.Http11Processor.process(H
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt
    at Socket(
    at ead.runIt(
    at org.apache.tomcat.util.threads.ThreadPool$ControlR
    Caused by: javax.naming.NamingException: [LDAP: error code 80 - internal error]; remaining name 'uid=amuse,ou=people,dc=m-ven,dc=com'
    at com.sun.jndi.ldap.LdapCtx.mapErrorCode(LdapCtx.jav a:3029)
    at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCt
    at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCt
    at com.sun.jndi.ldap.LdapCtx.c_createSubcontext(LdapC
    at com.sun.jndi.toolkit.ctx.ComponentDirContext.p_cre ateSubcontext(
    at com.sun.jndi.toolkit.ctx.PartialCompositeDirContex t.createSubcontext( :248)
    at com.sun.jndi.toolkit.ctx.PartialCompositeDirContex t.createSubcontext( :236)
    at context(
    at com.zimbra.cs.account.ldap.LdapProvisioning.create Subcontext(
    ... 25 more

    Error code: service.FAILURE
    Method: ZmCsfeCommand.prototype.invoke

    Everything else seems to be operating as normal. Please help asap if you can.


  2. #2
    Join Date
    Jun 2007
    Rep Power


    Well I got it working, I hope no one else is missing.

    I deleted and re-copied the /opt/zimbra directory
    ran /opt/zimbra/libexec/zmfixperms
    ran zmcontrol start
    All of which I did at least 2 or 3 times.

    And the missing user is back.

    The only difference this time was that I was experiencing the permissions bug on redo.log and removed that file before starting.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Traslation SVN tree status
    By meikka in forum I18N/L10N - Translations
    Replies: 7
    Last Post: 02-13-2007, 11:13 AM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  4. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 10:19 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts