Results 1 to 4 of 4

Thread: Zimbra + Samba: can't create new user

Hybrid View

  1. #1
    Join Date
    Jul 2007
    Location
    The Netherlands
    Posts
    2
    Rep Power
    8

    Default Zimbra + Samba: can't create new user

    Hi,

    I've followed the instructions from "UNIX and Windows Accounts in Zimbra LDAP and Zimbra Admin UI". Everything as described in steps 1-4 show up nicely, my Samba domain is recognized in the Zimbra Admin, I can do getent group and passwd and get the right response.

    However when I want to create a new user all the right dialog boxes pop up including posix and samba with the correct data regarding domain etc ... but when I click on Finish I get the following error:

    Message: createAccount invalid attr value: [LDAP: error code 21 - objectClass: value #4 invalid per syntax]
    Error code: account.INVALID_ATTR_VALUE
    Method: ZmCsfeCommand.prototype.invoke
    Details:soap:Sender

    I'm stumped, could anybody point me in the right direction on how to resolve this problem?

    Regards,

    Meint
    Last edited by postme; 07-04-2007 at 07:24 AM.

  2. #2
    Join Date
    Sep 2005
    Location
    Tucson - San Francisco - Moscow
    Posts
    127
    Rep Power
    10

    Default

    Can you post the whole SOAP or JSON response with the error message? You can get the SOAP trace in a separate debug window if you run the admin UI with ?mode=mjsf&gzip=false&debug=1 or if you use FireBug plugin to FireFox browser.
    Bugzilla - Wiki - Downloads - Before posting... Search!
    P.S.: don't forget to vote on this bug
    add Samba LDAP entries to Exchange Migration Tool

  3. #3
    Join Date
    Oct 2006
    Location
    USA, AZ, PHX
    Posts
    9
    Rep Power
    9

    Default Zimbra + Samba: can't create new user

    Quote Originally Posted by Greg View Post
    Can you post the whole SOAP or JSON response with the error message? You can get the SOAP trace in a separate debug window if you run the admin UI with ?mode=mjsf&gzip=false&debug=1 or if you use FireBug plugin to FireFox browser.
    I have a similar problem, here's the debug.
    This seems to have happened since upgrading with zcs-NETWORK-4.5.6_GA_1024.RHEL4.tgz. Thanks for taking a look!

    Code:
    Body: {
      Fault: {
        Code: {
          Value: "soap:Sender"
         },
        Detail: {
          Error: {
            Code: "account.INVALID_ATTR_VALUE",
            Trace: "com.zimbra.cs.account.AccountServiceException: createAccount invalid attr value: [LDAP: error code 21 - objectClass: value #2 invalid per syntax]
    	at com.zimbra.cs.account.AccountServiceException.INVALID_ATTR_VALUE(AccountServiceException.java:119)
    	at com.zimbra.cs.account.ldap.LdapUtil.createEntry(LdapUtil.java:1024)
    	at com.zimbra.cs.account.ldap.LdapProvisioning.createAccount(LdapProvisioning.java:725)
    	at com.zimbra.cs.account.ldap.LdapProvisioning.createAccount(LdapProvisioning.java:590)
    	at com.zimbra.cs.service.admin.CreateAccount.handle(CreateAccount.java:65)
    	at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:270)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:168)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:90)
    	at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:223)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
    	at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:162)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
    	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
    	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
    	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
    	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
    	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
    	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:541)
    	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
    	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
    	at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:667)
    	at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
    	at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
    	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
    	at java.lang.Thread.run(Thread.java:595)
    Caused by: javax.naming.directory.InvalidAttributeValueException: [LDAP: error code 21 - objectClass: value #2 invalid per syntax]; remaining name 'uid=aaatest,ou=people,dc=remedymd,dc=com'
    	at com.sun.jndi.ldap.LdapCtx.mapErrorCode(LdapCtx.java:2998)
    	at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCtx.java:2931)
    	at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCtx.java:2737)
    	at com.sun.jndi.ldap.LdapCtx.c_createSubcontext(LdapCtx.java:770)
    	at com.sun.jndi.toolkit.ctx.ComponentDirContext.p_createSubcontext(ComponentDirContext.java:319)
    	at com.sun.jndi.toolkit.ctx.PartialCompositeDirContext.createSubcontext(PartialCompositeDirContext.java:248)
    	at javax.naming.directory.InitialDirContext.createSubcontext(InitialDirContext.java:183)
    	at com.zimbra.cs.account.ldap.LdapUtil.createEntry(LdapUtil.java:1018)
    	... 25 more
    ",
            _jsns: "urn:zimbra"
           }
         },
        Reason: {
          Text: "createAccount invalid attr value: [LDAP: error code 21 - objectClass: value #2 invalid per syntax]"
         }
       }
     },
    Header: {
      context: {
        _jsns: "urn:zimbra",
        change: {
          token: 224207
         },
        sessionId: [
          0: {
            _content: "268",
            id: "268",
            type: "admin"
           }
         ]
       }
     },
    _jsns: "urn:zimbraSoap"
    Code:
    code: "account.INVALID_ATTR_VALUE",
    detail: "soap:Sender",
    method: "ZmCsfeCommand.prototype.invoke",
    msg: "createAccount invalid attr value: [LDAP: error code 21 - objectClass: value #2 invalid per syntax]"

  4. #4
    Join Date
    Oct 2006
    Location
    USA, AZ, PHX
    Posts
    9
    Rep Power
    9

    Thumbs up

    It seems that the last upgrade overwrote the slapd.conf.in.
    Once I put the changes back in, it's working.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  3. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 03:30 PM
  4. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 07:47 AM
  5. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 10:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •