Results 1 to 3 of 3

Thread: Changing certificates and server name

  1. #1
    Join Date
    Jul 2007
    Rep Power

    Default Changing certificates and server name

    Hi all! This is my first post, please forgive me :-)
    I tried to replace the self-created certificate with one from an external CA, i.e. Cacert.
    The previous certificate was linked to an internal name, ex: zimbra.internal.lan while the cert has the FQDN of
    While changing the certificate using the procedure in the wiki, tomcat didn't start anymore.
    It was difficult to find some information in the logs, so I started manually and I found that must be related to opening the keystore
    Then I decided to change the hostname using the zmsethostname to the external name, because I was thinking it was somehow related to the different CN field.
    At the moment no services are running, even the mailbox task is not starting up anymore.
    Any ideas where to look?
    I would rather find the problem than re-installing......
    Also, I would like to keep users' data: it was a test system with less than 10 users, but if I can I would keep data.
    Thank you!

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    Welcome to the forums.

    Did you make a backup before you started making these changes? If you didn't then I suggest you make on now.

    You can have problems running zmsetservername if your DNS and/or hosts set-up isn't correct. Check this post and make sure that your LDAP settings are correct.


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jul 2007
    Rep Power


    I pretty much did anything, i.e.:
    followed also certs instruction on wiki for CaCert.
    As soon as I start, this is what I have:

    zimbra$ zmcontrol start
    Starting ldap...Done.

    No other services running.
    If I try starting up the mailbox services with zmmailboxctl this is the output:
    ]$ zmmailboxctl start
    Thu Jul 12 11:44:38 2007 Skipping Configuration for server update.
    Thu Jul 12 11:44:38 2007 ERROR: account.NO_SUCH_SERVER (no such server:
    Thu Jul 12 11:44:38 2007 Key lookup failed.
    zmmtaconfig shutting down
    A mysqld process already exists

Similar Threads

  1. [SOLVED] Installing existing SSL certificates (solved)
    By inigoml in forum Administrators
    Replies: 22
    Last Post: 02-24-2009, 09:32 AM
  2. Perdition not restart !!!!
    By olibite in forum Administrators
    Replies: 2
    Last Post: 05-22-2007, 03:50 AM
  3. Untrusted Server Certificate Chain Error
    By fmodola in forum Administrators
    Replies: 3
    Last Post: 05-14-2007, 03:39 AM
  4. perdition won't start after 4.5 Upgrade
    By freeformz in forum Administrators
    Replies: 1
    Last Post: 01-29-2007, 06:39 PM
  5. Re-create certificates
    By demanl in forum Administrators
    Replies: 4
    Last Post: 05-23-2006, 06:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts