Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: 3.0.1 Released - Bugfix release

  1. #1
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default 3.0.1 Released - Bugfix release

    Just posted ZCS 3.0.1 which is a bugfix release. Notable fixes include fix for mailbox move, Firefox 1.0.X HTML message rendering issues, and i18n date parsing. Release notes are attached. Network customers and trial participants can get the latest release from the support portal. The OSS release is available via the downloads page.
    Attached Files Attached Files
    Last edited by KevinH; 02-22-2006 at 08:10 AM.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  2. #2
    Join Date
    Oct 2005
    Location
    Milwaukee, WI, USA
    Posts
    5
    Rep Power
    10

    Default Support URL

    Thanks for the bugfix. However, the Support link above has a typo.

    Just to avoid confusion here's the correct support URL:

    http://www.zimbra.com/support/

    Cheers.
    Ted Dargis

    Milwaukee Microbusiness, LLC
    We invented the Internet.
    www.milwaukeemicro.com

  3. #3
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Link fixed! Sorry about that. Had a stray quote in there.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  4. #4
    Join Date
    Nov 2005
    Location
    Beloit, Wisconsin
    Posts
    71
    Rep Power
    10

    Default

    Are there any plans to have a small update download for bug fixes and minor revisions instead of downloading the whole package and updating? I looked through bugzilla and the forums but couldn't find anything. Not that big of a deal but I was just curious.

    I switched my production email (from windows finally!!!) over to Zimbra the day GA came out and couldn't be happier!

  5. #5
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Yes a patching framework is something we will add eventually. We know everyone wants to just get the patch, but our first goal was to make sure the upgrade works well with a full package.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  6. #6
    Join Date
    Oct 2005
    Location
    Belgium
    Posts
    68
    Rep Power
    10

    Default

    Some problems I encountered when upgraded from GA 3.0 to 3.0.1.

    The server original version: GA 3.0
    hostname: moon.example.be
    email domain: example.be

    -> Stopped zimbra with zmcontrol stop
    -> Make a copy of /opt/zimbra to /opt/zimbra_GA_3.0
    -> run install.sh
    -> select upgrade

    The first problem occured because I don't have an MX record for "example.be", so Zimbra suggested the "moon.example.be" as new mail domain and didn't know that I was upgrading from the "example.be" domain. I did choose to not enter a new domain and continue.
    Now the real problem occured when the script tried to get some information from the LDAP server, The script didn't know on witch port http an https zimbra should run. I did told the script port 80 and 443, returned to the main menu, but the script didn't allow me to apply the changes. Then I "Ctrl + c" the script.
    ....
    Drink strong coffee ...

    -> Started zimbra with 'zmcontrol start'
    -> run install.sh
    -> select upgrade
    Zimbra complained again about not finding a MX record for 'moon.example.be', but just ignored it again and the script continued.
    Now the script found the information in LDAP, so it found the http/https port that Zimbra was running on originaly.
    So far so good ...
    The only issue I encountered then. The script still wanted to create a new domain 'moon.example.be', so I told not to create the new domain.
    Applied the changes and zimbra upgraded and started just fine

    So after this story ,I would suggest:
    1) Let the script check if LDAP is running, if not let the script try to start it up or give a warning.
    2) The script didn't know I use the email domain 'example.be'
    3) It's not because the hostname is 'moon.example.be' that I want to create a new email domain 'moon.example.be'.
    4) Because the translation files are not included in the zimbra package , and the script didn't make a backup of those files they where lost.

    So before upgrading, Make a Backup! And check the settings that the install script suggests at the end.

  7. #7
    Join Date
    Oct 2005
    Posts
    34
    Rep Power
    10

    Default

    I have seen this in the last two releases (M4 and GA) but wasn't able to post any meaningful bug as I didn't have the messages that came up and like you it worked when I ran the script again.

    I'll try and capture the messages this time...

    Have any of the Zimbra guys seen this yet?

  8. #8
    Join Date
    Feb 2006
    Posts
    5
    Rep Power
    9

    Default questions

    Hi. I have too 3.0 installed now. After read the last post i have a question, ¿the upgrade proccess is secure?, ¿i can upgrade without data lost (accounts, mails, ...)?, ¿where i can find the detailed upgrade proccess (documentation)?

    Regards

  9. #9
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    Yes
    Yes
    Read the install guide

  10. #10
    Join Date
    Feb 2006
    Posts
    5
    Rep Power
    9

    Default

    Ok, i found the upgrade documentation proccess into "Zimbra OS Release Notes.pdf".

    many thanks,

Similar Threads

  1. ZCS 4.5.6 Has Been Released
    By jholder in forum Announcements
    Replies: 1
    Last Post: 06-28-2007, 07:45 PM
  2. Confusion on Bugs Fixed in New Release
    By soxfan in forum Administrators
    Replies: 6
    Last Post: 03-30-2007, 02:05 AM
  3. ZCS 4.05 - Do two bug fixes make a release?
    By greenrenault in forum Administrators
    Replies: 7
    Last Post: 12-21-2006, 03:26 AM
  4. ZCS 3.1.1 Released
    By KevinH in forum Announcements
    Replies: 10
    Last Post: 05-24-2006, 07:09 PM
  5. Two problems with 3.0.1 release
    By phoenix in forum Administrators
    Replies: 4
    Last Post: 02-22-2006, 01:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •