Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: connector versioning and compatability

  1. #1
    Join Date
    Sep 2007
    Posts
    48
    Rep Power
    8

    Default connector versioning and compatability

    The documentation is unclear on the compatability of various versions of the connector with versions of zimbra. I'm assuming this is what is causing my problem.

    I downloaded the 4.5.10_1571 connector. We run ZCS 4.5.6. Whenever I try to connect it says Server License Needed.

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    High Shawn-
    The version of iSync shipped with 4.5.10 has some issues. Please feel free to download this one:
    Zimbra Hosted Demo Downloads

  3. #3
    Join Date
    Jun 2007
    Location
    Oregon
    Posts
    51
    Rep Power
    8

    Default

    Any oddities we should expect when running a 5.0 connector against a 4.5 server? (I am upgrading to 4.5.10 tonight and want to make sure I warn my users if there are connector issues.)

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Yeah, don't do it. AFAIK, the connectors call different SOAP calls. I'll have to get someone more knowledgeable to chime in

    I'm only the janitor

  5. #5
    Join Date
    Jun 2007
    Location
    Oregon
    Posts
    51
    Rep Power
    8

    Default

    Well, see, that's what I thought. Which is why your suggestion to get the beta connectors from the demo has really confused me.

  6. #6
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Yeah,
    I'm an idiot. Don't download that.

    The 4.5.10 connector does have issues. contact support@zimbra.com they will send you a newer one.

  7. #7
    Join Date
    Jun 2007
    Location
    Oregon
    Posts
    51
    Rep Power
    8

    Default

    The information returned from support@zimbra.com, recorded here for reference to those that might look at this thread later.

    The released version of 4.5.10 iSync connector does have a backwards-compatibility issue. That is why it will not work for the original poster. However, if you are upgrading your servers to 4.5.10, the connector will work fine.

  8. #8
    Join Date
    Sep 2007
    Posts
    48
    Rep Power
    8

    Default

    All this conflicting information and lack of consistency is scaring me. What are the plans to make this connector enterprise-ready? Surely Zimbra considers backwards/forwards compatibility an important aspect in creating an enterprise-grade connector.
    Last edited by shawnlhood; 12-05-2007 at 11:15 AM. Reason: typo

  9. #9
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    The connector is backward compatible on the 4.5 series. The notable exceptions are: 4.5.10 had a bug, and Leopard caused us to write some new code.

    We consider it Enterprise ready. Bugs happen, and no matter how hard we try, there will always be bugs. That's the software business.

  10. #10
    Join Date
    Sep 2007
    Posts
    48
    Rep Power
    8

    Default

    I'm just expressing disdain for needing to communicate on the forums and then e-mail support for a new connector. Why is is not posted to the Downloads section on the Support portal?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •