Results 1 to 6 of 6

Thread: Calendar name with non-ASCII chars in it (eg ) breaks CalDav

  1. #1
    Join Date
    Jan 2008
    Location
    Gent, Belgium
    Posts
    62
    Rep Power
    7

    Default Calendar name with non-ASCII chars in it (eg ) breaks CalDav

    Server: verified on both 5.0.6 and 5.0.8 (both NE).
    Client: Apple iCal (latest updates) and Mulberry (behaviour in Mulberry is slightly different, read on for more info).

    How to reproduce:
    1) configure some calendars in your Zimbra webinterface, setup your CalDav client, make sure it's working, that you can see al calendars etc.
    2) add a new calendar, with a special (non-ASCII) character in it (eg: "test with ").
    3) Refresh the calendar list in iCal. ==> It won't show up in iCal (shows up as a calendar with an empty name in Mulberry)

    Even worse:

    4) Add a few new calendars, without special chars in the name.
    5) Refresh the Calendar list ==> They won't show up either in iCal (they do show in Mulberry)

    To prove my point:

    6) Completely erase all data in your iCal, quit iCal, start it again and recreate the CalDav account. ==> Not a single calendar will show up.

    7) Delete the calendar with an accented name in it in your Zimbra interface. Refresh the iCal list ==> They all show up again.

    Can anyone confirm this and tell me if there is a fix? Thanks.

    PS: Please note that adding UTF-8 data to the content of an appointment does seem to work, shows up fine, the error only happens when the name of the calendar contains non-ASCII chars in it.

  2. #2
    Join Date
    Jan 2008
    Location
    Gent, Belgium
    Posts
    62
    Rep Power
    7

    Default

    Anyone that knows if there is a way around this? Or shall I file a bug?

  3. #3
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default

    Please file a bug.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  4. #4
    Join Date
    Jan 2008
    Location
    Gent, Belgium
    Posts
    62
    Rep Power
    7

  5. #5
    Join Date
    Oct 2005
    Posts
    59
    Rep Power
    10

    Default

    We had a similar bug earlier (bug 26245) which was fixed for ZCS 5.0.5. Since then iCal had several revision updates, and it looks like iCal 3.0.4 no longer works correctly with encoded URL. I've filed a bug for that on Apple (Bug ID# 6156572). As for mulberry, we don't support it yet and I can't say whether it's a problem with client or server.

  6. #6
    Join Date
    Jan 2008
    Location
    Gent, Belgium
    Posts
    62
    Rep Power
    7

    Default

    JLee, thank you for your feedback. I tried Mulberry as well because I read (in this forum or on the zimbra blog) that MB is the most "standard-compliant" CalDav client out there ...

    Thank you for filing the Apple bug. Is there a way for me to track that bug? I am registered in Apple's devel program, but it seems I can only file the bugs I created myself.

Similar Threads

  1. Changing Calendar Organizer script
    By snsparrish in forum Administrators
    Replies: 4
    Last Post: 05-02-2011, 05:41 AM
  2. Oracle Calendar to Zimbra pain
    By jwtadmin in forum Zimbra in Education
    Replies: 4
    Last Post: 05-26-2008, 02:48 PM
  3. Replies: 1
    Last Post: 02-11-2008, 07:41 PM
  4. calendar migration failed with utf8 chars
    By xingjing in forum Migration
    Replies: 3
    Last Post: 12-18-2007, 12:35 PM
  5. Outlook/Zimbra Private Appointments Issue
    By Smurthey in forum Zimbra Connector for Outlook
    Replies: 0
    Last Post: 03-09-2007, 07:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •