Results 1 to 4 of 4

Thread: Reset Sync Data in Apple iSync not completing

Hybrid View

  1. #1
    Join Date
    Dec 2009
    Posts
    2
    Rep Power
    6

    Default Reset Sync Data in Apple iSync not completing

    I am having problems with Apple iSync when trying to Reset Sync Data. Let me start at the beginning... After the last Zimbra upgrade we installed (we are running 5.0.18_GA_3011.MACOSXx86_10.5 NETWORK edition) I noticed on my iPhone that a new contact I had made in Address Book was duplicating itself on a never-ending basis. So, I logged into zimbra webmail and sure enough, there it is, going on forever. There was only 1 in my Apple Address Book, however. So, my computer guy tells me to Reset the sync data via the Zimbra pane in my System Preferences. I do and it works great. No more duplicating contact. My boss then realizes he is having the same issue, so I try to reset the sync data on his machine. It says it has finished the sync, but it only pushed 25 contacts to the server (there were over 600). Then, it continues to ask him if it is okay to delete data for several days. So, I think maybe he needs a newer version of the iSync connector, so I download it from the Admin Console, but it crashes when trying to install. I then notice that the iSync connector is version 5.0.17, even though the server is running 5.0.18. So, I contact tech support and finally figure out they want me to install version 5.0.19 (of the iSync connector). So, I do. Version 5.0.19 installs on the affected machine fine, but still will not complete the sync when resetting the sync data. And, now, since I have installed version 5.0.19 on my machine, it is doing the same thing. Even when I re-installed version 5.0.17 on my machine, it still will not complete the reset sync data. And, it doesn't give an error message. It says that the sync finished even though it only pushed a fraction of the contacts to the server. Also, those few that do get pushed are now duplicating themselves over and over. I have several ideas on how to get around it, but it would be nice if iSync worked properly, so I thought I would give the forum a try. Maybe there is a bug someone knows about? Any help would be MUCH appreciated! Thank you!

  2. #2
    Join Date
    Dec 2008
    Posts
    4
    Rep Power
    7

    Default

    Did you ever get any resolution to this? I am seeing the exact same behavior with Zimbra 6 and iSync connector 6.0.2169.

  3. #3
    Join Date
    Dec 2009
    Posts
    2
    Rep Power
    6

    Default

    No, it just continues to get worse. I will be moving away from Zimbra soon. The functionality is not reliable and the customer service might as well be non-existent. I'm very much regretting spending the money to renew my licenses recently.

    Sorry I couldn't be of more help!

  4. #4
    Join Date
    Dec 2008
    Posts
    4
    Rep Power
    7

    Default Possible fix for repeating "OK to delete data?" and duplicate contact entries

    I got on chat with my Zimbra provider's support today and we did the following that seems to have eliminated repeat "OK to delete data?" dialog boxes and missing/duplicate contacts.

    1. First open the Zimbra connector prefPane and change the sync interval to "Manual".
    2. Make sure that your Apple Address Book contains all your contacts and they are all correct.
    3. Login to the Zimbra web interface with the Standard HTML version (not the "Preferred" or "Advanced AJAX" version). Go to your addressbook. In the left column where it lists your different contact lists, at the top of the list is a little link called "Edit". Click that and you should get a set of preferences in the body pane. At the bottom is a checkbox entitled "Permanently delete all contacts in this address book. This operation can not be undone." Check that, then click "Delete all contacts." This will wipe out your addressbook in Zimbra
    4. Now open Applications->iSync. Pull down the Preferences menu and click "Reset Sync History". Click the same button in the subsequent warning dialog.
    5. Open the Zimbra connector prefPane. Remove your Zimbra account and re-add it. Make sure the correct contact lists are checked on the Sync tab.
    6. Then click the Advanced tab and click "Reset Sync Data". In the resulting dialog tell the connector to replace the contents of Zimbra with your addressbook on your local computer.

    This seems to have fixed the problem for me though I haven't done extensive testing yet.

Similar Threads

  1. Zimbra Desktop Stopped Syncing with Zimbra Online
    By dasofsky in forum Error Reports
    Replies: 0
    Last Post: 01-19-2009, 03:57 PM
  2. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  3. [SOLVED] After reset of sync data, no longer able to sync
    By rojs in forum CalDAV / CardDAV / iSync
    Replies: 10
    Last Post: 06-14-2007, 05:30 PM
  4. [SOLVED] iSync issues (calendar sync hangs)
    By mbd in forum CalDAV / CardDAV / iSync
    Replies: 17
    Last Post: 06-11-2007, 12:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •